aboutsummaryrefslogtreecommitdiffstats
path: root/games/monster-masher
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2009-01-06 04:36:33 +0800
committerpav <pav@FreeBSD.org>2009-01-06 04:36:33 +0800
commit460836ff23b6dcedf0492f75495022dc42f6eb99 (patch)
tree5c97de462ec70569d72e34d640782d1b9348d6de /games/monster-masher
parentfbbcbe4a59e1074c58bbdabf056cd9c13db27392 (diff)
downloadfreebsd-ports-gnome-460836ff23b6dcedf0492f75495022dc42f6eb99.tar.gz
freebsd-ports-gnome-460836ff23b6dcedf0492f75495022dc42f6eb99.tar.zst
freebsd-ports-gnome-460836ff23b6dcedf0492f75495022dc42f6eb99.zip
- Remove conditional checks for FreeBSD 5.x and older
Diffstat (limited to 'games/monster-masher')
-rw-r--r--games/monster-masher/Makefile9
-rw-r--r--games/monster-masher/files/extra-patch-src-vector.hpp30
2 files changed, 1 insertions, 38 deletions
diff --git a/games/monster-masher/Makefile b/games/monster-masher/Makefile
index 2348d2981f9e..633988664911 100644
--- a/games/monster-masher/Makefile
+++ b/games/monster-masher/Makefile
@@ -27,11 +27,4 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GCONF_SCHEMAS= monster-masher.schemas
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500010
-IGNORE= Freezes when starting a new game
-EXTRA_PATCHES= ${PATCHDIR}/extra-patch-src-vector.hpp
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/monster-masher/files/extra-patch-src-vector.hpp b/games/monster-masher/files/extra-patch-src-vector.hpp
deleted file mode 100644
index 1ba2faf2887e..000000000000
--- a/games/monster-masher/files/extra-patch-src-vector.hpp
+++ /dev/null
@@ -1,30 +0,0 @@
---- src/vector.hpp.orig Fri Aug 15 19:07:16 2003
-+++ src/vector.hpp Wed Nov 5 20:34:27 2003
-@@ -107,25 +107,17 @@
- }
-
- template <typename T>
--inline bool operator !=(Vector<T> lhs, Vector<T> rhs)
--{
-- return !(lhs == rhs);
--}
--
--template <typename T>
- inline bool operator ==(Vector<T> lhs, Vector<T> rhs)
- {
- return lhs.x == rhs.x && lhs.y == rhs.y;
- }
-
--template <>
--inline bool operator ==<double>(Vector<double> lhs, Vector<double> rhs)
-+inline bool operator ==(Vector<double> lhs, Vector<double> rhs)
- {
- return std::abs(lhs.x - rhs.x) < 0.001 && std::abs(lhs.y - rhs.y) < 0.001;
- }
-
--template <>
--inline bool operator ==<float>(Vector<float> lhs, Vector<float> rhs)
-+inline bool operator ==(Vector<float> lhs, Vector<float> rhs)
- {
- return std::abs(lhs.x - rhs.x) < 0.001 && std::abs(lhs.y - rhs.y) < 0.001;
- }