aboutsummaryrefslogtreecommitdiffstats
path: root/games/motogt
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-08-26 22:06:08 +0800
committertijl <tijl@FreeBSD.org>2014-08-26 22:06:08 +0800
commitf8357b5cbaa160ccdf9943cac099f5e092c591da (patch)
treed0c8617b772b8f0a175d436d938b8d844590b41f /games/motogt
parent89a7d6ecbdde724b92ca6650493f56cf68855f35 (diff)
downloadfreebsd-ports-gnome-f8357b5cbaa160ccdf9943cac099f5e092c591da.tar.gz
freebsd-ports-gnome-f8357b5cbaa160ccdf9943cac099f5e092c591da.tar.zst
freebsd-ports-gnome-f8357b5cbaa160ccdf9943cac099f5e092c591da.zip
- Fix missing library problems when the linker enforces explicit linking
PR: 192062 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'games/motogt')
-rw-r--r--games/motogt/Makefile4
-rw-r--r--games/motogt/files/patch-src-Makefile.lnx2
2 files changed, 3 insertions, 3 deletions
diff --git a/games/motogt/Makefile b/games/motogt/Makefile
index 2397475b01ef..425db2d5b573 100644
--- a/games/motogt/Makefile
+++ b/games/motogt/Makefile
@@ -21,14 +21,14 @@ LICENSE_PERMS_CCbySA= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LICENSE_FILE_CCbySA= ${WRKSRC}/doc/cc-by-sa.txt
USES= zip
+USE_GL= gl
BUILD_WRKSRC= ${WRKSRC}/src
MAKEFILE= Makefile.lnx
MAKE_JOBS_UNSAFE= yes
CFLAGS+= -I${LOCALBASE}/include/libpng15
-MAKE_ENV+= PTHREAD_LIBS="${PTHREAD_LIBS}"
SUB_FILES= motogt
CXXFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+LDFLAGS+= -L${LOCALBASE}/lib
PLIST_FILES= bin/${PORTNAME} libexec/MotoGT.bin
PORTDATA= *
diff --git a/games/motogt/files/patch-src-Makefile.lnx b/games/motogt/files/patch-src-Makefile.lnx
index 9905f7ac207c..aba2597dfd59 100644
--- a/games/motogt/files/patch-src-Makefile.lnx
+++ b/games/motogt/files/patch-src-Makefile.lnx
@@ -8,7 +8,7 @@
-TEMP_DIR=../tmp-lnx
+CXX?= g++
+CXXFLAGS?= -O2 -ffast-math
-+LIBS= -lpng -lsfml-window -lsfml-graphics -lsfml-system -lsfml-audio
++LIBS= -lpng -lsfml-window -lsfml-graphics -lsfml-system -lsfml-audio -lGL
+LDFLAGS?= -s
+TEMP_DIR= ../tmp-lnx