aboutsummaryrefslogtreecommitdiffstats
path: root/games/mvdsv
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2004-11-15 19:41:43 +0800
committerdanfe <danfe@FreeBSD.org>2004-11-15 19:41:43 +0800
commitb89e7eaaf7e89de96570775cb08161cf2a4bd053 (patch)
tree9f4012749d43c817d1a25eabfe98938e578ceb47 /games/mvdsv
parent307493aefa7d37fe3da7544dc8f1d62fb812307b (diff)
downloadfreebsd-ports-gnome-b89e7eaaf7e89de96570775cb08161cf2a4bd053.tar.gz
freebsd-ports-gnome-b89e7eaaf7e89de96570775cb08161cf2a4bd053.tar.zst
freebsd-ports-gnome-b89e7eaaf7e89de96570775cb08161cf2a4bd053.zip
Update to 0.176, latest stable version.
Approved by: fjoe (mentor, implicit)
Diffstat (limited to 'games/mvdsv')
-rw-r--r--games/mvdsv/Makefile17
-rw-r--r--games/mvdsv/distinfo4
-rw-r--r--games/mvdsv/files/Makefile31
-rw-r--r--games/mvdsv/pkg-descr2
4 files changed, 40 insertions, 14 deletions
diff --git a/games/mvdsv/Makefile b/games/mvdsv/Makefile
index e3697546d4b4..4862284191af 100644
--- a/games/mvdsv/Makefile
+++ b/games/mvdsv/Makefile
@@ -5,15 +5,15 @@
# $FreeBSD$
#
-PORTNAME= mvdsv
-PORTVERSION= 0.1725b
-CATEGORIES= games
+PORTNAME?= mvdsv
+PORTVERSION= 0.176
+CATEGORIES?= games
MASTER_SITES= http://quakeworld.ru/files/vvd/mvdsv/ \
http://freebsd.nsu.ru/distfiles/
-DISTNAME= ${PORTNAME}${PORTVERSION}-sources
+DISTNAME= mvdsv_${PORTVERSION}_sources
MAINTAINER= danfe@FreeBSD.org
-COMMENT= Enhanced QuakeWorld server with multi-view demos capability
+COMMENT?= Enhanced QuakeWorld server with multi-view demos capability
USE_BZIP2= yes
@@ -34,10 +34,11 @@ GCC_VER= 3
.endif
MAKEFILE= ${FILESDIR}/Makefile
+ALL_TARGET= ${PORTNAME}
MAKE_ARGS+= GCC_VER=${GCC_VER}
-PLIST_FILES= bin/mvdsv
-WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}/source
+PLIST_FILES= bin/${PORTNAME}
+WRKSRC= ${WRKDIR}/mvdsv_${PORTVERSION}/source
pre-everything::
.if !defined(WITH_OPTIMIZED_CFLAGS)
@@ -48,6 +49,6 @@ pre-everything::
.endif
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/../${PORTNAME} ${PREFIX}/bin
.include <bsd.port.post.mk>
diff --git a/games/mvdsv/distinfo b/games/mvdsv/distinfo
index 1eb0c28ab8c4..b4d3b1def178 100644
--- a/games/mvdsv/distinfo
+++ b/games/mvdsv/distinfo
@@ -1,2 +1,2 @@
-MD5 (mvdsv0.1725b-sources.tar.bz2) = 64b3818220f8b82140f3030ec54d4b02
-SIZE (mvdsv0.1725b-sources.tar.bz2) = 467501
+MD5 (mvdsv_0.176_sources.tar.bz2) = 2bce9836c859b3b42067b391ed15e2eb
+SIZE (mvdsv_0.176_sources.tar.bz2) = 742898
diff --git a/games/mvdsv/files/Makefile b/games/mvdsv/files/Makefile
index f8c2efa4aa16..bc1f37e86d85 100644
--- a/games/mvdsv/files/Makefile
+++ b/games/mvdsv/files/Makefile
@@ -27,6 +27,8 @@ DO_CFLAGS += -falign-loops=2 -falign-jumps=2 -falign-functions=2
.endif
########################################################################
+## MVDSV
+########################################################################
SV_OBJS = \
pr_cmds.o \
@@ -57,6 +59,7 @@ SV_OBJS = \
net_udp.o \
pmove.o \
pmovetst.o \
+ sha1.o \
version.o \
world.o \
zone.o
@@ -70,14 +73,36 @@ SV_AS_OBJS = \
SV_LIBS = -lm
+########################################################################
+## QWDTOOLS
+########################################################################
+
+QWDTOOLS_OBJS = \
+ qwdtools/dem_parse.o \
+ qwdtools/dem_send.o \
+ qwdtools/ini.o \
+ qwdtools/init.o \
+ qwdtools/main.o \
+ qwdtools/marge.o \
+ qwdtools/qwz.o \
+ qwdtools/sync.o \
+ qwdtools/tools.o
+
+########################################################################
+
.c.o:
- ${CC} ${DO_CFLAGS} -c $< -o $*.o
+ ${CC} ${DO_CFLAGS} -I. -c $< -o $*.o
.s.o:
${CC} ${DO_CFLAGS} -DELF -x assembler-with-cpp -c $< -o $*.o
-all: ${SV_OBJS} ${SV_AS_OBJS}
- ${CC} ${CFLAGS} -o mvdsv ${SV_OBJS} ${SV_AS_OBJS} ${SV_LIBS}
+all: mvdsv qwdtools
+
+mvdsv: ${SV_OBJS} ${SV_AS_OBJS}
+ ${CC} ${CFLAGS} -o ../mvdsv ${SV_OBJS} ${SV_AS_OBJS} ${SV_LIBS}
+
+qwdtools: ${QWDTOOLS_OBJS}
+ ${CC} ${CFLAGS} -o ../qwdtools ${QWDTOOLS_OBJS} ${SV_LIBS}
clean:
-rm -f *.o *.core
diff --git a/games/mvdsv/pkg-descr b/games/mvdsv/pkg-descr
index 4cd760c12166..65435a53e81c 100644
--- a/games/mvdsv/pkg-descr
+++ b/games/mvdsv/pkg-descr
@@ -4,4 +4,4 @@ biggest step in QuakeWorld since Qizmo release. MVDSV is also the best
server to use with KTeams Pro deathmatch mod, and in fact is required
for latter's full functionality.
-WWW: http://rxr.quakeworld.nu/ktpro/
+WWW: http://mvdsv.sourceforge.net/