aboutsummaryrefslogtreecommitdiffstats
path: root/games/nazghul/Makefile
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2006-08-04 06:04:33 +0800
committeracm <acm@FreeBSD.org>2006-08-04 06:04:33 +0800
commita413c9f971c59a5350b3a209297bc63e64972ab4 (patch)
tree617ace3e4db44e5a09be94b6984e4ced074f4cf2 /games/nazghul/Makefile
parentf7e34cb66d9f5a538ce59f69d0bb32dc665b1c67 (diff)
downloadfreebsd-ports-gnome-a413c9f971c59a5350b3a209297bc63e64972ab4.tar.gz
freebsd-ports-gnome-a413c9f971c59a5350b3a209297bc63e64972ab4.tar.zst
freebsd-ports-gnome-a413c9f971c59a5350b3a209297bc63e64972ab4.zip
New port: games/nazghul
Nazghul is a computer role-playing game (CRPG) engine. Obviously, the emphasis is not on graphics or first-person squad-based stealth action. If you like roguelikes or the top-down, 2d, turn-based CRPG's that disappeared in the early 90's then this is for you. WWW: http://myweb.cableone.net/gmcnutt/nazghul.html Approved by: garga (mentor)
Diffstat (limited to 'games/nazghul/Makefile')
-rw-r--r--games/nazghul/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/games/nazghul/Makefile b/games/nazghul/Makefile
new file mode 100644
index 000000000000..54162d0eb6f5
--- /dev/null
+++ b/games/nazghul/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: nazghul
+# Date created: 2006-08-02
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nazghul
+PORTVERSION= 0.5.4
+CATEGORIES= games
+MASTER_SITES= SF
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= A computer role-playing game engine
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+
+USE_GCC= 3.4+
+USE_SDL= sdl image
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+post-patch:
+ ${REINPLACE_CMD} -i "" 's|malloc.h|stdlib.h|g' ${WRKSRC}/src/scheme.c
+
+.include <bsd.port.mk>