aboutsummaryrefslogtreecommitdiffstats
path: root/games/nethack34/Makefile
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2009-07-25 08:25:21 +0800
committerwxs <wxs@FreeBSD.org>2009-07-25 08:25:21 +0800
commit3442a73a291f9cfd8103bce1b7e1f3edf3c70e67 (patch)
treebc97de5d37ff70ed023db5b8d521e526bf9e14af /games/nethack34/Makefile
parent2cafd262a8b4f21b64b94f19fa804f0162fad11c (diff)
downloadfreebsd-ports-gnome-3442a73a291f9cfd8103bce1b7e1f3edf3c70e67.tar.gz
freebsd-ports-gnome-3442a73a291f9cfd8103bce1b7e1f3edf3c70e67.tar.zst
freebsd-ports-gnome-3442a73a291f9cfd8103bce1b7e1f3edf3c70e67.zip
- Add support for WITH_STATUSCOLORS.
- While here move to my distfile mirror instead of old one. PR: ports/136220 Submitted by: Jeremy Chadwick <jdc@parodius.com>
Diffstat (limited to 'games/nethack34/Makefile')
-rw-r--r--games/nethack34/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/games/nethack34/Makefile b/games/nethack34/Makefile
index 338f696345e9..468d6111997a 100644
--- a/games/nethack34/Makefile
+++ b/games/nethack34/Makefile
@@ -45,16 +45,30 @@ MAKE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
GRAPHICS= GNOME_GRAPHICS
.elif ${PKGNAMESUFFIX} == "-nox11"
GRAPHICS= # none
+#
+# Patch notes:
+# 1) hpmon and statuscolors conflict with one another
+# 2) menucolors patch must be applied before statuscolors
+#
+.if defined(WITH_HPMON) && defined(WITH_STATUSCOLORS)
+IGNORE= you cannot enable both HPMON and STATUSCOLORS
+.endif
.if defined(WITH_MENUCOLORS)
PATCHFILES+= nh343-menucolor.diff
PATCH_SITES+= http://bilious.homelinux.org/~paxed/nethack/
PATCH_DIST_STRIP= -p1
CFLAGS+= -DMENU_COLOR_REGEX_POSIX
.endif
+.if defined(WITH_STATUSCOLORS)
+PATCHFILES+= nh343-statuscolors.fixed.patch
+PATCH_SITES+= http://jdc.parodius.com/nethack/ \
+ ${MASTER_SITE_LOCAL:S|%SUBDIR%|wxs|}
+PATCH_DIST_STRIP= -p1
+.endif
.if defined(WITH_HPMON)
PATCHFILES+= hpmon.diff
PATCH_SITES+= http://www.netsonic.fi/~walker/nh/ \
- ${MASTER_SITE_LOCAL:S|%SUBDIR%|koitsu|}
+ ${MASTER_SITE_LOCAL:S|%SUBDIR%|wxs|}
PATCH_DIST_STRIP= -p1
CFLAGS+= -DHPMON
.endif