aboutsummaryrefslogtreecommitdiffstats
path: root/games/netrek-COW3-bin/Makefile
diff options
context:
space:
mode:
authordburr <dburr@FreeBSD.org>1999-03-16 06:40:27 +0800
committerdburr <dburr@FreeBSD.org>1999-03-16 06:40:27 +0800
commit0641f76d6578c24a88e223ad5ea91da0356b2666 (patch)
tree1090df0cd9f3e27ba81792b6d5a1a2cae6288901 /games/netrek-COW3-bin/Makefile
parent65a602a4ea7dd43cf35851fb3037f96de65ad882 (diff)
downloadfreebsd-ports-gnome-0641f76d6578c24a88e223ad5ea91da0356b2666.tar.gz
freebsd-ports-gnome-0641f76d6578c24a88e223ad5ea91da0356b2666.tar.zst
freebsd-ports-gnome-0641f76d6578c24a88e223ad5ea91da0356b2666.zip
Submitted by: Donald Burr <dburr@FreeBSD.ORG>
Obtained from: the net Import of new port games/netrek-COW3-bin, a multiplayer space battle type game with a Star Trek theme. This is the 'COW3' client, which has all the whiz-bang features that everyone seems to want nowadays, like a nifty 256-color mode, sound, etc. It's probably not a wise choice if you have a slower machine; use the BRMH client instead.
Diffstat (limited to 'games/netrek-COW3-bin/Makefile')
-rw-r--r--games/netrek-COW3-bin/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/games/netrek-COW3-bin/Makefile b/games/netrek-COW3-bin/Makefile
new file mode 100644
index 000000000000..3046b1bf37e8
--- /dev/null
+++ b/games/netrek-COW3-bin/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: netrek
+# Version required: COW 3.00pl0
+# Date created: 15 Mar 1999
+# Whom: Donald Burr <dburr@FreeBSD.ORG>
+#
+# $Id$
+#
+
+DISTNAME= COW.3.00pl0.FreeBSD
+PKGNAME= netrek-COW-3.00p0
+CATEGORIES= games
+MASTER_SITES= ftp://bigbang.astro.indiana.edu/pub/netrek/COW/COW-bin/
+EXTRACT_SUFX= .gz
+
+MAINTAINER= dburr@FreeBSD.ORG
+
+USE_X_PREFIX= YES
+NO_BUILD= YES
+NO_WRKSUBDIR= YES
+
+do-extract:
+ ${MKDIR} ${WRKDIR}
+ ${GUNZIP_CMD} < ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} > ${WRKDIR}/netrek
+
+do-install:
+ ${INSTALL} -c -o root -g wheel -m 555 ${WRKDIR}/netrek ${PREFIX}/bin
+ @${CAT} ${PKGDIR}/MESSAGE
+
+.include <bsd.port.mk>