aboutsummaryrefslogtreecommitdiffstats
path: root/games/newkind
diff options
context:
space:
mode:
authorwjv <wjv@FreeBSD.org>2002-09-16 23:09:40 +0800
committerwjv <wjv@FreeBSD.org>2002-09-16 23:09:40 +0800
commitc4dde2681499caf67d7ce68d04f1c03f3c32a3c9 (patch)
tree5e9c273421a93bb66bcb06574da03adb88a3f749 /games/newkind
parent0622ac4bb28b93f236c9f73cfe0968b6259bbfb1 (diff)
downloadfreebsd-ports-gnome-c4dde2681499caf67d7ce68d04f1c03f3c32a3c9.tar.gz
freebsd-ports-gnome-c4dde2681499caf67d7ce68d04f1c03f3c32a3c9.tar.zst
freebsd-ports-gnome-c4dde2681499caf67d7ce68d04f1c03f3c32a3c9.zip
- Mark BROKEN; this port does not build with the version of devel/allegro
currently in ports. - Relinquish maintainership. - Commit few minor style fixes, in the hope that this port may one day be revived.
Diffstat (limited to 'games/newkind')
-rw-r--r--games/newkind/Makefile28
-rw-r--r--games/newkind/files/patch-makefile20
2 files changed, 24 insertions, 24 deletions
diff --git a/games/newkind/Makefile b/games/newkind/Makefile
index c8958b509510..a22b44fe1943 100644
--- a/games/newkind/Makefile
+++ b/games/newkind/Makefile
@@ -12,13 +12,11 @@ MASTER_SITES= http://home.clara.net/cjpinder/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTFILES= ${PORTNAME}${EXTRACT_SUFX} ${PORTNAME}b${EXTRACT_SUFX}
-MAINTAINER= wjv@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
-# It doesn't seem possible to construct a LIB_DEPENDS for Allegro(?)
-# The dependence on the version number is also sub-optimal.
-BUILD_DEPENDS= allegro-config:${PORTSDIR}/devel/allegro
-RUN_DEPENDS= allegro-config:${PORTSDIR}/devel/allegro
+LIB_DEPENDS= alleg.4:${PORTSDIR}/devel/allegro
+BROKEN= Does not build with version of devel/allegro currently in ports
NO_CDROM= Reverse-engineered version of copyrighted abandonware
NO_PACKAGE= ${NO_CDROM}
USE_ZIP= yes
@@ -27,25 +25,25 @@ NO_WRKSUBDIR= yes
USE_GMAKE= yes
MAKEFILE= makefile
ALL_TARGET=
-SHAREDIR= ${PREFIX}/share/${PORTNAME}
+NK_SCRIPT= ${WRKSRC}/newkind
# Currently, everything required to run newkind (including the binary) is
-# installed to ${SHAREDIR}. A shell script wrapper is then installed to
+# installed to ${DATADIR}. A shell script wrapper is then installed to
# ${PREFIX}/bin. A more elegant installation to the standard directory
# hierarchy under ${PREFIX} would require extensive patching of source files,
# which will have to be maintained across future versions. If anyone feels
# up to it, you're more than welcome... :-)
do-install:
- @ ${MKDIR} ${SHAREDIR}/data
- @ ${INSTALL_PROGRAM} ${WRKSRC}/newkind.exe ${SHAREDIR}
+ @ ${MKDIR} ${DATADIR}/data
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/newkind.exe ${DATADIR}
@ ${INSTALL_DATA} ${WRKSRC}/elite.dat ${WRKSRC}/*.cfg \
- ${WRKSRC}/*.bmp ${WRKSRC}/*.wav ${SHAREDIR}
- @ ${INSTALL_DATA} ${WRKSRC}/data/* ${SHAREDIR}/data
+ ${WRKSRC}/*.bmp ${WRKSRC}/*.wav ${DATADIR}
+ @ ${INSTALL_DATA} ${WRKSRC}/data/* ${DATADIR}/data
@ ${MKDIR} ${PREFIX}/bin
- @ ${ECHO_CMD} "#!${SH}" > ${WRKSRC}/newkind
- @ ${ECHO_CMD} "cd ${SHAREDIR} && exec \"./newkind.exe\" \"\$$@\"" \
- >> ${WRKSRC}/newkind
- @ ${INSTALL_SCRIPT} ${WRKSRC}/newkind ${PREFIX}/bin
+ @ ${ECHO_CMD} "#!${SH}" > ${NK_SCRIPT}
+ @ ${ECHO_CMD} "cd ${DATADIR} && exec \"./newkind.exe\" \"\$$@\"" \
+ >> ${NK_SCRIPT}
+ @ ${INSTALL_SCRIPT} ${NK_SCRIPT} ${PREFIX}/bin
post-install:
.if !defined(NOPORTDOCS)
diff --git a/games/newkind/files/patch-makefile b/games/newkind/files/patch-makefile
index af05f834facb..2a8727651d42 100644
--- a/games/newkind/files/patch-makefile
+++ b/games/newkind/files/patch-makefile
@@ -1,17 +1,18 @@
--- makefile.orig Fri Jul 6 21:29:04 2001
-+++ makefile Tue Oct 23 17:40:09 2001
-@@ -2,25 +2,20 @@
++++ makefile Mon Sep 16 17:03:26 2002
+@@ -2,26 +2,24 @@
# Makefile for Elite - The New Kind.
#
-CC = gcc
--WRES = windres
--
--LIBS = -s -mwindows -lalleg_s -lkernel32 -lgdi32 -lcomdlg32 -luser32 -lole32 -lddraw -ldxguid -lwinmm -ldsound -ldinput
--CFLAGS = -mpentium -O2 -funroll-loops -Wall -DALLEGRO_STATICLINK
+CC ?= gcc
-+LIBS = -L/usr/local/lib -lalleg-3.9.34 -lalleg_unsharable
-+CFLAGS += -mpentium -O2 -funroll-loops -Wall -DALLEGRO_STATICLINK -I/usr/local/include
+ WRES = windres
+
+-LIBS = -s -mwindows -lalleg_s -lkernel32 -lgdi32 -lcomdlg32 -luser32 -lole32 -lddraw -ldxguid -lwinmm -ldsound -ldinput
++LOCALBASE ?= /usr/local
++LIBS = -L$(LOCALBASE)/lib -L$(LOCALBASE)/lib/allegro/4.0 -lalleg
+ CFLAGS = -mpentium -O2 -funroll-loops -Wall -DALLEGRO_STATICLINK
++CFLAGS += -I$(LOCALBASE)/include -I$(LOCALBASE)/include/allegro
OBJS = alg_gfx.o alg_main.o docked.o elite.o\
intro.o planet.o shipdata.o shipface.o sound.o space.o\
@@ -27,6 +28,7 @@
-
-nkres.o: nkres.rc
- $(WRES) nkres.rc nkres.o
-
+-
alg_gfx.o: alg_gfx.c alg_data.h config.h elite.h planet.h gfx.h
+