aboutsummaryrefslogtreecommitdiffstats
path: root/games/nextgo
diff options
context:
space:
mode:
authortheraven <theraven@FreeBSD.org>2017-08-21 21:26:28 +0800
committertheraven <theraven@FreeBSD.org>2017-08-21 21:26:28 +0800
commitb979cb2ebddb0a2733e9a38fb66d4229500c7113 (patch)
tree1818a753b93ff1ef78365147f674b9e83bcf0048 /games/nextgo
parent0f34c5b91d625d06b13a8b457ca91d2a821387a4 (diff)
downloadfreebsd-ports-gnome-b979cb2ebddb0a2733e9a38fb66d4229500c7113.tar.gz
freebsd-ports-gnome-b979cb2ebddb0a2733e9a38fb66d4229500c7113.tar.zst
freebsd-ports-gnome-b979cb2ebddb0a2733e9a38fb66d4229500c7113.zip
Update GNUstep core libraries.
Update the default Objective-C compiler. Fix various build failures in GNUstep ports from newer versions of the GNUstep core libraries and from changes to GNUstep Make. Update various ports that use GNUstep and bump the portrevision of the ones that haven't had a new release.
Diffstat (limited to 'games/nextgo')
-rw-r--r--games/nextgo/Makefile2
-rw-r--r--games/nextgo/files/patch-GNUmakefile11
-rw-r--r--games/nextgo/files/patch-smartgo.h8
3 files changed, 16 insertions, 5 deletions
diff --git a/games/nextgo/Makefile b/games/nextgo/Makefile
index 45b42fcdc174..9fcc251f7def 100644
--- a/games/nextgo/Makefile
+++ b/games/nextgo/Makefile
@@ -2,7 +2,7 @@
PORTNAME= nextgo
PORTVERSION= 3.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= games gnustep
MASTER_SITES= SAVANNAH/gap
DISTNAME= NeXTGo-${PORTVERSION}
diff --git a/games/nextgo/files/patch-GNUmakefile b/games/nextgo/files/patch-GNUmakefile
new file mode 100644
index 000000000000..6798d5aff6d6
--- /dev/null
+++ b/games/nextgo/files/patch-GNUmakefile
@@ -0,0 +1,11 @@
+--- GNUmakefile.orig 2017-08-13 18:43:49 UTC
++++ GNUmakefile
+@@ -28,8 +28,6 @@
+
+ #GNUSTEP_INSTALLATION_DIR = $(GNUSTEP_SYSTEM_ROOT)
+
+-GNUSTEP_MAKEFILES = $(GNUSTEP_SYSTEM_ROOT)/Library/Makefiles
+-
+ NeXTGo_MAIN_MODEL_FILE = NeXTGo.gorm
+
+ include $(GNUSTEP_MAKEFILES)/common.make
diff --git a/games/nextgo/files/patch-smartgo.h b/games/nextgo/files/patch-smartgo.h
index 77e08ff5e3b8..729b20aaf459 100644
--- a/games/nextgo/files/patch-smartgo.h
+++ b/games/nextgo/files/patch-smartgo.h
@@ -1,6 +1,6 @@
---- smartgo.h.orig Sun Jan 12 05:01:52 2003
-+++ smartgo.h Sat Nov 18 17:18:57 2006
-@@ -122,7 +122,7 @@
+--- smartgo.h.orig 2003-01-12 04:01:52 UTC
++++ smartgo.h
+@@ -122,7 +122,7 @@ typedef struct _node {
extern node* parse_tree(char* inputBuffer);
/* Routines from smartgoeval.c needed by other routines. */
@@ -9,7 +9,7 @@
/* Routines from smartgotree.c needed by other routines. */
-@@ -134,7 +134,7 @@
+@@ -134,7 +134,7 @@ extern node* findLast0(node* currentNode
extern node* forwardOneVariant(node* currentNode);
extern node* backOneVariant(node* currentNode);
extern void clearNodeFlags(node* currentNode);