aboutsummaryrefslogtreecommitdiffstats
path: root/games/nexuiz
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2009-10-09 00:23:32 +0800
committerdanfe <danfe@FreeBSD.org>2009-10-09 00:23:32 +0800
commite2ac99e957f7405e708a950200423212e841bc00 (patch)
tree90089b070ede40042d12e110b0df2d94a4e7a064 /games/nexuiz
parentd7184f7c117f0ae026e44c1d5ba2e0933cce2959 (diff)
downloadfreebsd-ports-gnome-e2ac99e957f7405e708a950200423212e841bc00.tar.gz
freebsd-ports-gnome-e2ac99e957f7405e708a950200423212e841bc00.tar.zst
freebsd-ports-gnome-e2ac99e957f7405e708a950200423212e841bc00.zip
Drop the patch that changed DarkPlaces' jpeg.h definitions to jpeg7's --
there is a knob (DP_LINK_TO_LIBJPEG) to disable offending code automatically. This allows to link against system-provided libjpeg, whether it is jpeg62 or jpeg7. That way it will continue to work, even if e.g. a new libjpeg71 with incompatible ABI comes out. Submitted by: Rudolf Polzer, one of the developers of Nexuiz
Diffstat (limited to 'games/nexuiz')
-rw-r--r--games/nexuiz/Makefile3
-rw-r--r--games/nexuiz/files/patch-libjpeg7-fix58
2 files changed, 2 insertions, 59 deletions
diff --git a/games/nexuiz/Makefile b/games/nexuiz/Makefile
index cead9392ef06..e620a87e9d77 100644
--- a/games/nexuiz/Makefile
+++ b/games/nexuiz/Makefile
@@ -23,7 +23,8 @@ USE_ZIP= yes
WRKSRC= ${WRKDIR}/Nexuiz/sources/darkplaces
MAKEFILE= BSDmakefile
MAKE_ARGS= DP_FS_BASEDIR="${DATADIR}" CC="${CC}" \
- DP_PRELOAD_DEPENDENCIES=yes \
+ DP_PRELOAD_DEPENDENCIES=yes DP_LINK_TO_LIBJPEG=yes \
+ CFLAGS_LIBJPEG="-I${LOCALBASE}/include" \
OPTIM_RELEASE="${CFLAGS} -fno-strict-aliasing -funroll-loops"
ALL_TARGET= #
diff --git a/games/nexuiz/files/patch-libjpeg7-fix b/games/nexuiz/files/patch-libjpeg7-fix
deleted file mode 100644
index c4e734926f0f..000000000000
--- a/games/nexuiz/files/patch-libjpeg7-fix
+++ /dev/null
@@ -1,58 +0,0 @@
---- jpeg.c.orig
-+++ jpeg.c
-@@ -46,7 +46,7 @@ typedef unsigned char jboolean;
- typedef int jboolean;
- #endif
-
--#define JPEG_LIB_VERSION 62 // Version 6b
-+#define JPEG_LIB_VERSION 70 // Version 7
-
- typedef void *j_common_ptr;
- typedef struct jpeg_compress_struct *j_compress_ptr;
-@@ -161,12 +161,13 @@ typedef struct {
- * Values of 1,2,4,8 are likely to be supported. Note that different
- * components may receive different IDCT scalings.
- */
-- int DCT_scaled_size;
-+ int DCT_h_scaled_size;
-+ int DCT_v_scaled_size;
- /* The downsampled dimensions are the component's actual, unpadded number
-- * of samples at the main buffer (preprocessing/compression interface), thus
-- * downsampled_width = ceil(image_width * Hi/Hmax)
-- * and similarly for height. For decompression, IDCT scaling is included, so
-- * downsampled_width = ceil(image_width * Hi/Hmax * DCT_scaled_size/DCTSIZE)
-+ * of samples at the main buffer (preprocessing/compression interface);
-+ * DCT scaling is included, so
-+ * downsampled_width = ceil(image_width * Hi/Hmax * DCT_h_scaled_size/DCTSIZE)
-+ * and similarly for height.
- */
- JDIMENSION downsampled_width; /* actual width in samples */
- JDIMENSION downsampled_height; /* actual height in samples */
-@@ -268,7 +269,8 @@ struct jpeg_decompress_struct
- void *marker_list;
- int max_h_samp_factor;
- int max_v_samp_factor;
-- int min_DCT_scaled_size;
-+ int min_DCT_h_scaled_size; /* smallest DCT_h_scaled_size of any component */
-+ int min_DCT_v_scaled_size; /* smallest DCT_v_scaled_size of any component */
- JDIMENSION total_iMCU_rows;
- void *sample_range_limit;
- int comps_in_scan;
-@@ -344,6 +346,8 @@ struct jpeg_compress_struct
- jboolean progressive_mode;
- int max_h_samp_factor;
- int max_v_samp_factor;
-+ int min_DCT_h_scaled_size; /* smallest DCT_h_scaled_size of any component */
-+ int min_DCT_v_scaled_size; /* smallest DCT_v_scaled_size of any component */
- JDIMENSION total_iMCU_rows;
- int comps_in_scan;
- jpeg_component_info *cur_comp_info[MAX_COMPS_IN_SCAN];
-@@ -473,7 +477,7 @@ qboolean JPEG_OpenLibrary (void)
- #elif defined(MACOSX)
- "libjpeg.62.dylib",
- #else
-- "libjpeg.so.62",
-+ "libjpeg.so.10",
- "libjpeg.so",
- #endif
- NULL