aboutsummaryrefslogtreecommitdiffstats
path: root/games/nil
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2003-11-13 22:45:08 +0800
committertrevor <trevor@FreeBSD.org>2003-11-13 22:45:08 +0800
commit98d7950e05980253d33259a6aafcd5e3b6547fdb (patch)
tree1cbd7ce2d9411420b33e9f045481bd24f68ef920 /games/nil
parenta959d36850b787f6723176962c2985587b2936cb (diff)
downloadfreebsd-ports-gnome-98d7950e05980253d33259a6aafcd5e3b6547fdb.tar.gz
freebsd-ports-gnome-98d7950e05980253d33259a6aafcd5e3b6547fdb.tar.zst
freebsd-ports-gnome-98d7950e05980253d33259a6aafcd5e3b6547fdb.zip
Use the FIND and XARGS macros introduced in bsd.port.mk 1.391.
Diffstat (limited to 'games/nil')
-rw-r--r--games/nil/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/games/nil/Makefile b/games/nil/Makefile
index 80242f560720..c6cfde611ee8 100644
--- a/games/nil/Makefile
+++ b/games/nil/Makefile
@@ -32,9 +32,9 @@ BROKEN= "Does not compile (bad C++ code)"
.endif
pre-patch:
- @find ${WRKSRC} \( -name "*.[ch]" -or -name "*.cpp" \) | \
- xargs ${PERL} -pi -e 's|"SDL/|"|g ; s|<SDL/|<|g'
- @find ${WRKSRC}/.. -type d -name CVS | xargs ${RM} -rf
+ @${FIND} ${WRKSRC} \( -name "*.[ch]" -or -name "*.cpp" \) | \
+ ${XARGS} ${PERL} -pi -e 's|"SDL/|"|g ; s|<SDL/|<|g'
+ @${FIND} ${WRKSRC}/.. -type d -name CVS | ${XARGS} ${RM} -rf
post-configure:
@${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/nil/configuration.cpp