aboutsummaryrefslogtreecommitdiffstats
path: root/games/ninix-aya/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-05-02 07:17:53 +0800
committermiwi <miwi@FreeBSD.org>2007-05-02 07:17:53 +0800
commit68611150ad3ea87c8aff08707724c91beed5e2dd (patch)
treec77acfdcc7870d4375ff698ea162afbe33d7072b /games/ninix-aya/Makefile
parentd9d6dd2bd9a2ceb428107917cfbb904e0a8ce0c5 (diff)
downloadfreebsd-ports-gnome-68611150ad3ea87c8aff08707724c91beed5e2dd.tar.gz
freebsd-ports-gnome-68611150ad3ea87c8aff08707724c91beed5e2dd.tar.zst
freebsd-ports-gnome-68611150ad3ea87c8aff08707724c91beed5e2dd.zip
- Update to 3.9.4
PR: 112308 Submitted by: UMENO Takashi<umeno@rr.iij4u.or.jp> (maintainer)
Diffstat (limited to 'games/ninix-aya/Makefile')
-rw-r--r--games/ninix-aya/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/games/ninix-aya/Makefile b/games/ninix-aya/Makefile
index 99f98e70ba84..8075c151748d 100644
--- a/games/ninix-aya/Makefile
+++ b/games/ninix-aya/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= ninix-aya
-PORTVERSION= 3.9.3
+PORTVERSION= 3.9.4
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_JP}
-MASTER_SITE_SUBDIR= ninix-aya/23064
+MASTER_SITE_SUBDIR= ninix-aya/25158
DISTNAME= ninix-aya-${PORTVERSION}
EXTRACT_SUFX= .tgz
171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259
/*
 * libusb synchronization on Microsoft Windows
 *
 * Copyright © 2010 Michael Plante <michael.plante@gmail.com>
 *
 * This library is free software; you can redistribute it and/or
 * modify it under the terms of the GNU Lesser General Public
 * License as published by the Free Software Foundation; either
 * version 2.1 of the License, or (at your option) any later version.
 *
 * This library is distributed in the hope that it will be useful,
 * but WITHOUT ANY WARRANTY; without even the implied warranty of
 * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU
 * Lesser General Public License for more details.
 *
 * You should have received a copy of the GNU Lesser General Public
 * License along with this library; if not, write to the Free Software
 * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
 */

#include <config.h>

#include <objbase.h>
#include <errno.h>

#include "libusbi.h"

struct usbi_cond_perthread {
    struct list_head list;
    DWORD tid;
    HANDLE event;
};

int usbi_mutex_static_lock(usbi_mutex_static_t *mutex)
{
    if (!mutex)
        return EINVAL;
    while (InterlockedExchange(mutex, 1) == 1)
        SleepEx(0, TRUE);
    return 0;
}

int usbi_mutex_static_unlock(usbi_mutex_static_t *mutex)
{
    if (!mutex)
        return EINVAL;
    InterlockedExchange(mutex, 0);
    return 0;
}

int usbi_mutex_init(usbi_mutex_t *mutex)
{
    if (!mutex)
        return EINVAL;
    *mutex = CreateMutex(NULL, FALSE, NULL);
    if (!*mutex)
        return ENOMEM;