aboutsummaryrefslogtreecommitdiffstats
path: root/games/noegnud-nethack-deet
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-02-18 21:12:51 +0800
committerpav <pav@FreeBSD.org>2005-02-18 21:12:51 +0800
commit6c204da6adb8e1c00d2517b2d0971dc83bd07375 (patch)
tree3ea5c7ab8b4bbcd0bcaf38565fcdbfb31384623b /games/noegnud-nethack-deet
parent79fb6f7736efc2d5707e062334aa3b4ff6a1321e (diff)
downloadfreebsd-ports-gnome-6c204da6adb8e1c00d2517b2d0971dc83bd07375.tar.gz
freebsd-ports-gnome-6c204da6adb8e1c00d2517b2d0971dc83bd07375.tar.zst
freebsd-ports-gnome-6c204da6adb8e1c00d2517b2d0971dc83bd07375.zip
noeGNUd aims to be the ultimate User Interface ( UI ) for nethack. comibining
character mode, 2D tilesets and 3d graphics, all interchangeable at runtime to allow the serious nethack player ultimate freedom of interface to the game that allows ultimate freedom of gameplay and imagination. noegnud-data is the foundamental data for noeGNUd which all noeGNUd games depend on it. noegnud-nethack, noegnud-nethack-deet, noegnud-slashem, and noegnud-littlehack are the four variant games that noeGNUd support. noegnud-addons installs tilesets and sound themes. PR: ports/65318 Submitted by: Leland Wang <llwang@infor.org>
Diffstat (limited to 'games/noegnud-nethack-deet')
-rw-r--r--games/noegnud-nethack-deet/Makefile65
-rw-r--r--games/noegnud-nethack-deet/distinfo4
-rw-r--r--games/noegnud-nethack-deet/files/noegnud-nethack-deet.patch164
-rw-r--r--games/noegnud-nethack-deet/files/patch-noegnud::noegnud_glfuncs.h13
-rw-r--r--games/noegnud-nethack-deet/files/patch-noegnud::noegnud_interface.h13
-rw-r--r--games/noegnud-nethack-deet/files/patch-variants::Makefile51
-rw-r--r--games/noegnud-nethack-deet/pkg-descr10
-rw-r--r--games/noegnud-nethack-deet/pkg-plist14
8 files changed, 334 insertions, 0 deletions
diff --git a/games/noegnud-nethack-deet/Makefile b/games/noegnud-nethack-deet/Makefile
new file mode 100644
index 000000000000..ace203ef9030
--- /dev/null
+++ b/games/noegnud-nethack-deet/Makefile
@@ -0,0 +1,65 @@
+# New ports collection makefile for: noegnud-nethack-deet
+# Date created: 7 April 2004
+# Whom: Leland Wang <llwang@infor.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= noegnud
+PORTVERSION= 0.8.3
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}:noegnud,nethack
+MASTER_SITE_SUBDIR= ${PORTNAME}/:noegnud \
+ nethack/:nethack
+PKGNAMESUFFIX= -nethack-deet
+DISTFILES= ${DISTNAME}_linux_src-minimal${EXTRACT_SUFX}:noegnud \
+ nethack-342.tgz:nethack
+EXTRACT_ONLY= ${DISTNAME}_linux_src-minimal${EXTRACT_SUFX}
+
+MAINTAINER= llwang@infor.org
+COMMENT= The noeGNUd UI for Nethack with DeeT's hack font patch
+
+RUN_DEPENDS= ${LOCALBASE}/share/${NOEGNUDVERSION}/data/gui:${PORTSDIR}/games/noegnud-data
+
+NOEGNUDVERSION= ${PORTNAME}-0.8.0
+USE_BISON= yes
+USE_GL= yes
+WANT_SDL= yes
+USE_SDL= sdl image mixer
+WRKSRC= ${WRKDIR}/${DISTNAME}/variants
+PATCH_WRKSRC= ${WRKDIR}/${DISTNAME}
+ALL_TARGET= nh342-dt
+INSTALL_TARGET= install_nh342-dt
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 502103
+USE_REINPLACE= yes
+.endif
+
+pre-everything::
+.if ${HAVE_SDL}
+ @${ECHO_MSG} "This port depends on SDL with OpenGL support."
+ @${ECHO_MSG} "If your SDL does not support OpenGL, hit ^C now and reinstall SDL"
+ @${ECHO_MSG} "with OpenGL support turned on."
+.endif
+
+post-extract:
+ @${CP} ${DISTDIR}/nethack-342.tgz ${WRKSRC}/tarballs
+ (cd ${WRKSRC} && ${MAKE} nethack-3.4.2-deet)
+
+post-patch:
+ (cd ${WRKSRC} && ${MAKE} ${NOEGNUDVERSION}-nethack-3.4.2-deet)
+ @(${PATCH} ${PATCH_ARGS} < ${FILESDIR}/noegnud-nethack-deet.patch)
+.if ${OSVERSION} < 502103
+ @${REINPLACE_CMD} -e 's/regex\.h/gnuregex\.h/' \
+ ${WRKSRC}/nethack-3.4.2-deet/src/sounds.c \
+ ${PATCH_WRKSRC}/noegnud/noegnud_textcolour.c \
+ ${PATCH_WRKSRC}/noegnud/noegnud_textcolour.h \
+ ${PATCH_WRKSRC}/noegnud/noegnud_textcolouring.c
+.endif
+
+do-configure:
+ (cd ${WRKSRC} && ${MAKE} ${NOEGNUDVERSION}-nethack-3.4.2-deet/Makefile)
+
+.include <bsd.port.post.mk>
diff --git a/games/noegnud-nethack-deet/distinfo b/games/noegnud-nethack-deet/distinfo
new file mode 100644
index 000000000000..eceef6ab7646
--- /dev/null
+++ b/games/noegnud-nethack-deet/distinfo
@@ -0,0 +1,4 @@
+MD5 (noegnud-0.8.3_linux_src-minimal.tar.gz) = d89827082e11059a5cdbef39314ca623
+SIZE (noegnud-0.8.3_linux_src-minimal.tar.gz) = 4882014
+MD5 (nethack-342.tgz) = 90e971dbaee2f05f6a2ed3454851903a
+SIZE (nethack-342.tgz) = 3475583
diff --git a/games/noegnud-nethack-deet/files/noegnud-nethack-deet.patch b/games/noegnud-nethack-deet/files/noegnud-nethack-deet.patch
new file mode 100644
index 000000000000..9d2c6a36a620
--- /dev/null
+++ b/games/noegnud-nethack-deet/files/noegnud-nethack-deet.patch
@@ -0,0 +1,164 @@
+diff -urN variants/nethack-3.4.2-deet.orig/include/config.h variants/nethack-3.4.2-deet/include/config.h
+--- variants/nethack-3.4.2-deet.orig/include/config.h Sun Nov 21 00:09:45 2004
++++ variants/nethack-3.4.2-deet/include/config.h Sun Nov 21 00:10:51 2004
+@@ -178,7 +178,7 @@
+ /* #define COMPRESS "/usr/bin/compress" */ /* Lempel-Ziv compression */
+ /* #define COMPRESS_EXTENSION ".Z" */ /* compress's extension */
+ /* An example of one alternative you might want to use: */
+-#define COMPRESS "/bin/gzip" /* FSF gzip compression */
++#define COMPRESS "/usr/bin/gzip" /* FSF gzip compression */
+ #define COMPRESS_EXTENSION ".gz" /* normal gzip extension */
+ #endif
+
+diff -urN variants/nethack-3.4.2-deet.orig/include/unixconf.h variants/nethack-3.4.2-deet/include/unixconf.h
+--- variants/nethack-3.4.2-deet.orig/include/unixconf.h Sun Nov 21 00:09:41 2004
++++ variants/nethack-3.4.2-deet/include/unixconf.h Sun Nov 21 00:11:32 2004
+@@ -19,13 +19,13 @@
+ */
+
+ /* define exactly one of the following four choices */
+-/* #define BSD 1 */ /* define for 4.n/Free/Open/Net BSD */
++#define BSD 1 /* define for 4.n/Free/Open/Net BSD */
+ /* also for relatives like SunOS 4.x, DG/UX, and */
+ /* older versions of Linux */
+ /* #define ULTRIX */ /* define for Ultrix v3.0 or higher (but not lower) */
+ /* Use BSD for < v3.0 */
+ /* "ULTRIX" not to be confused with "ultrix" */
+-#define SYSV /* define for System V, Solaris 2.x, newer versions */
++/* #define SYSV */ /* define for System V, Solaris 2.x, newer versions */
+ /* of Linux */
+ /* #define HPUX */ /* Hewlett-Packard's Unix, version 6.5 or higher */
+ /* use SYSV for < v6.5 */
+@@ -37,7 +37,7 @@
+ /* #define NETWORK */ /* if running on a networked system */
+ /* e.g. Suns sharing a playground through NFS */
+ /* #define SUNOS4 */ /* SunOS 4.x */
+-#define LINUX /* Another Unix clone */
++/* #define LINUX */ /* Another Unix clone */
+ /* #define CYGWIN32 */ /* Unix on Win32 -- use with case sensitive defines */
+ /* #define GENIX */ /* Yet Another Unix Clone */
+ /* #define HISX */ /* Bull Unix for XPS Machines */
+@@ -86,7 +86,7 @@
+ /* #define VPIX_MUSIC */ /* play real music through speaker on systems
+ with built-in VPIX support */
+
+-#define LINUXFONT /* include "linuxfont" option to use
++/* #define LINUXFONT */ /* include "linuxfont" option to use
+ special linux console font (tty, not X11) */
+ #ifdef LINUXFONT
+ #define LINUXFONT_NAME "linuxhack.font" /* installed in HACKDIR */
+diff -urN variants/nethack-3.4.2-deet.orig/sys/unix/Makefile.src variants/nethack-3.4.2-deet/sys/unix/Makefile.src
+--- variants/nethack-3.4.2-deet.orig/sys/unix/Makefile.src Sun Nov 21 00:09:45 2004
++++ variants/nethack-3.4.2-deet/sys/unix/Makefile.src Sun Nov 21 00:15:30 2004
+@@ -31,7 +31,7 @@
+ # For Systos users compiling on the ST, you'll either need a bourne shell
+ # clone or you'll need to do make depend, etc. by hand. In either case,
+ # the line below probably needs changing
+-SHELL=/bin/sh
++# SHELL=/bin/sh
+ # for Atari
+ # SHELL=E:/GEMINI2/MUPFEL.TTP
+
+@@ -61,7 +61,7 @@
+ # if you get setcgtty() warnings during execution, you are feeding gcc
+ # a non-ANSI <sys/ioctl.h> -- either run fixincludes on it or use
+ # -traditional in CFLAGS
+-CC = gcc
++# CC = gcc
+ #
+ # For Bull DPX/2 systems at B.O.S. 2.0 or higher use the following:
+ #
+@@ -125,14 +125,14 @@
+ # flags for Linux
+ # compile normally
+
+-COMMON_CFLAGS = -DNETHACK_3_4_2_DEET -fomit-frame-pointer -I../include `sdl-config --cflags`
++COMMON_CFLAGS = -DNETHACK_3_4_2_DEET -fomit-frame-pointer -I../include -I/usr/include/gnu `${SDL_CONFIG} --cflags` -I/usr/X11R6/include
+
+ STD_CFLAGS = -O2 -ffast-math $(COMMON_CFLAGS)
+ DBG_CFLAGS = -g -Wall -DNOEGNUDDEBUG $(COMMON_CFLAGS)
+
+-CFLAGS = $(STD_CFLAGS)
++CFLAGS += $(STD_CFLAGS)
+
+-LFLAGS = -L/usr/X11R6/lib
++LFLAGS = -L/usr/X11R6/lib -lgnuregex
+
+ # OR compile backwards compatible a.out format
+ # CFLAGS = -O2 -b i486-linuxaout -fomit-frame-pointer -I../include
+@@ -165,8 +165,8 @@
+ # The Qt and Be window systems are written in C++, while the rest of
+ # NetHack is standard C. If using Qt, uncomment the LINK line here to get
+ # the C++ libraries linked in.
+-CXXFLAGS = $(CFLAGS) -I. -I$(QTDIR)/include
+-CXX=g++
++CXXFLAGS += $(CFLAGS) -I. -I$(QTDIR)/include
++#CXX=g++
+ #LINK=g++
+ # For cross-compiling, eg. with gcc on Linux (see also CC further up):
+ #CXX=arm-linux-g++
+@@ -222,7 +222,10 @@
+
+ # Files for Entro-P's OpenGL 3D interface :: noeGNUd
+
+-WINNOEGNUDLIB = `sdl-config --libs` -lSDL_image -lSDL_mixer -lGL -lGLU
++WINNOEGNUDLIB = `${SDL_CONFIG} --libs` -lSDL_image -lSDL_mixer -lGL -lGLU
++
++.c.o:
++ ${CC} ${CFLAGS} -c $< -o $@
+
+ NOEGNUD = ../win/noegnud/noegnud
+
+diff -urN variants/nethack-3.4.2-deet.orig/sys/unix/Makefile.top variants/nethack-3.4.2-deet/sys/unix/Makefile.top
+--- variants/nethack-3.4.2-deet.orig/sys/unix/Makefile.top Sun Nov 21 00:09:45 2004
++++ variants/nethack-3.4.2-deet/sys/unix/Makefile.top Sun Nov 21 00:15:58 2004
+@@ -14,7 +14,7 @@
+ # MAKE = make
+
+ # make NetHack
+-PREFIX = /usr/local
++#PREFIX = /usr/local
+ GAMEUI = noegnud-0.8.0
+ GAMEVARIANT = nethack-3.4.2-deet
+ GAMESHORT = noegnud-$(GAMEVARIANT)
+@@ -38,7 +38,7 @@
+ # therefore there should not be anything in GAMEDIR that you want to keep
+ # (if there is, you'll have to do the installation by hand or modify the
+ # instructions)
+-GAMEDIR = $(PREFIX)/lib/$(GAMEUI)/$(GAMEVARIANT)
++GAMEDIR = $(PREFIX)/share/$(GAMEUI)/$(GAMEVARIANT)
+ VARDIR = $(GAMEDIR)
+ SHELLDIR = $(PREFIX)/bin
+
+diff -urN variants/nethack-3.4.2-deet.orig/sys/unix/Makefile.utl variants/nethack-3.4.2-deet/sys/unix/Makefile.utl
+--- variants/nethack-3.4.2-deet.orig/sys/unix/Makefile.utl Sun Nov 21 00:09:45 2004
++++ variants/nethack-3.4.2-deet/sys/unix/Makefile.utl Sun Nov 21 00:16:28 2004
+@@ -15,7 +15,7 @@
+
+ # if you are using gcc as your compiler,
+ # uncomment the CC definition below if it's not in your environment
+-CC = gcc
++# CC = gcc
+ #
+ # For Bull DPX/2 systems at B.O.S. 2.0 or higher use the following:
+ #
+@@ -72,8 +72,8 @@
+
+ # flags for Linux
+ # compile normally
+-CFLAGS = -O2 -fomit-frame-pointer -I../include
+-LFLAGS = -L/usr/X11R6/lib
++#CFLAGS = -O2 -fomit-frame-pointer -I../include
++#LFLAGS = -L/usr/X11R6/lib
+ # OR compile backwards compatible a.out format
+ # CFLAGS = -O2 -b i486-linuxaout -fomit-frame-pointer -I../include
+ # LFLAGS = -b i486-linuxaout -L/usr/X11R6/lib
+@@ -89,7 +89,7 @@
+ # flags for debugging:
+ # CFLAGS = -g -I../include
+
+-CFLAGS = -O -I../include
++CFLAGS += -O -I../include
+ LFLAGS =
+
+ LIBS =
diff --git a/games/noegnud-nethack-deet/files/patch-noegnud::noegnud_glfuncs.h b/games/noegnud-nethack-deet/files/patch-noegnud::noegnud_glfuncs.h
new file mode 100644
index 000000000000..147e9b0736e1
--- /dev/null
+++ b/games/noegnud-nethack-deet/files/patch-noegnud::noegnud_glfuncs.h
@@ -0,0 +1,13 @@
+--- noegnud/noegnud_glfuncs.h.orig Wed Apr 7 13:46:11 2004
++++ noegnud/noegnud_glfuncs.h Wed Apr 7 13:46:27 2004
+@@ -2,8 +2,8 @@
+ #define _GLFUNCS_H_
+
+ #include <GL/gl.h>
+-#include <SDL/SDL.h>
+-#include <SDL/SDL_image.h>
++#include <SDL.h>
++#include <SDL_image.h>
+
+ typedef struct {
+ int width,height;
diff --git a/games/noegnud-nethack-deet/files/patch-noegnud::noegnud_interface.h b/games/noegnud-nethack-deet/files/patch-noegnud::noegnud_interface.h
new file mode 100644
index 000000000000..05b1a944199a
--- /dev/null
+++ b/games/noegnud-nethack-deet/files/patch-noegnud::noegnud_interface.h
@@ -0,0 +1,13 @@
+--- noegnud/noegnud_interface.h.orig Wed Apr 7 13:47:53 2004
++++ noegnud/noegnud_interface.h Wed Apr 7 13:48:07 2004
+@@ -1,8 +1,8 @@
+ #ifndef _NOEGNUD_INTERFACE_H_
+ #define _NOEGNUD_INTERFACE_H_
+
+-#include <SDL/SDL.h>
+-#include <SDL/SDL_image.h>
++#include <SDL.h>
++#include <SDL_image.h>
+ #include <GL/gl.h>
+ #include <GL/glu.h>
+
diff --git a/games/noegnud-nethack-deet/files/patch-variants::Makefile b/games/noegnud-nethack-deet/files/patch-variants::Makefile
new file mode 100644
index 000000000000..64a0919d8c0d
--- /dev/null
+++ b/games/noegnud-nethack-deet/files/patch-variants::Makefile
@@ -0,0 +1,51 @@
+--- variants/Makefile.orig Mon Nov 15 03:02:30 2004
++++ variants/Makefile Mon Nov 15 03:03:25 2004
+@@ -1,7 +1,6 @@
+ NOEGNUDVERSION=noegnud-0.8.0
+ # you __MUST__ change this if you change the prefix for any variants' install !!!!!!!!!!!!!
+ # although ..... " make -e foo " also works :O ;)
+-PREFIX = /usr/local
+ GAMEUID = games
+ GAMEGRP = bin
+ CHOWN = chown
+@@ -62,31 +61,31 @@
+ install: install_all
+
+ install_nh342: nh342
+- make -e -C $(NOEGNUDVERSION)-nethack-3.4.2 install
++ make -EPREFIX -C $(NOEGNUDVERSION)-nethack-3.4.2 install
+
+ install_nh343: nh343
+- make -e -C $(NOEGNUDVERSION)-nethack-3.4.3 install
++ make -EPREFIX -C $(NOEGNUDVERSION)-nethack-3.4.3 install
+
+ install_se006e4f8: se006e4f8
+- make -e -C $(NOEGNUDVERSION)-slashem-0.0.6E4F8 install
++ make -EPREFIX -C $(NOEGNUDVERSION)-slashem-0.0.6E4F8 install
+
+ install_se007e2: se007e2
+- make -e -C $(NOEGNUDVERSION)-slashem-0.0.7E2 install
++ make -EPREFIX -C $(NOEGNUDVERSION)-slashem-0.0.7E2 install
+
+ install_se007e5: se007e5
+- make -e -C $(NOEGNUDVERSION)-slashem-0.0.7E5 install
++ make -EPREFIX -C $(NOEGNUDVERSION)-slashem-0.0.7E5 install
+
+ install_se007e6: se007e6
+- make -e -C $(NOEGNUDVERSION)-slashem-0.0.7E6 install
++ make -EPREFIX -C $(NOEGNUDVERSION)-slashem-0.0.7E6 install
+
+ install_se007e6f2: se007e6f2
+- make -e -C $(NOEGNUDVERSION)-slashem-0.0.7E6F2 install
++ make -EPREFIX -C $(NOEGNUDVERSION)-slashem-0.0.7E6F2 install
+
+ install_lh001: lh001
+- make -e -C $(NOEGNUDVERSION)-littlehack-0.0.1 install
++ make -EPREFIX -C $(NOEGNUDVERSION)-littlehack-0.0.1 install
+
+ install_nh342-dt: nh342-dt
+- make -e -C $(NOEGNUDVERSION)-nethack-3.4.2-deet install
++ make -EPREFIX -C $(NOEGNUDVERSION)-nethack-3.4.2-deet install
+
+ # data
+
diff --git a/games/noegnud-nethack-deet/pkg-descr b/games/noegnud-nethack-deet/pkg-descr
new file mode 100644
index 000000000000..cd1279def639
--- /dev/null
+++ b/games/noegnud-nethack-deet/pkg-descr
@@ -0,0 +1,10 @@
+noeGNUd is an alternate ascii/2D/3D User-Interface for the roguelike
+RPG "Nethack" and its Variants. Its difference to many other Interfaces
+lies in the utilisation of OpenGL to display the whole game. You can
+rotate the scenery as much as you like. It provides dynamic lightning
+and an outstanding 3D-Mode.
+
+This port installs noeGNUd for NetHack with DeeT's hack font patch.
+
+Author: Clive Crous
+WWW: http://noegnud.sourceforge.net/
diff --git a/games/noegnud-nethack-deet/pkg-plist b/games/noegnud-nethack-deet/pkg-plist
new file mode 100644
index 000000000000..3b050bc6f0e3
--- /dev/null
+++ b/games/noegnud-nethack-deet/pkg-plist
@@ -0,0 +1,14 @@
+bin/noegnud-0.8.0-nethack-3.4.2-deet
+bin/noegnud-nethack-3.4.2-deet
+share/noegnud-0.8.0/nethack-3.4.2-deet/license
+share/noegnud-0.8.0/nethack-3.4.2-deet/logfile
+share/noegnud-0.8.0/nethack-3.4.2-deet/nhdat
+share/noegnud-0.8.0/nethack-3.4.2-deet/noegnud-0.8.0-nethack-3.4.2-deet
+share/noegnud-0.8.0/nethack-3.4.2-deet/perm
+share/noegnud-0.8.0/nethack-3.4.2-deet/record
+share/noegnud-0.8.0/nethack-3.4.2-deet/recover
+@exec chown games:bin %D/share/noegnud-0.8.0/nethack-3.4.2-deet
+@exec chmod 775 %D/share/noegnud-0.8.0/nethack-3.4.2-deet
+@unexec rmdir %D/share/noegnud-0.8.0/nethack-3.4.2-deet/save 2>/dev/null || true
+@unexec rmdir %D/share/noegnud-0.8.0/nethack-3.4.2-deet 2>/dev/null || true
+@unexec rmdir %D/share/noegnud-0.8.0 2>/dev/null || true