aboutsummaryrefslogtreecommitdiffstats
path: root/games/noegnud-slashem/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-02-18 21:12:51 +0800
committerpav <pav@FreeBSD.org>2005-02-18 21:12:51 +0800
commit6c204da6adb8e1c00d2517b2d0971dc83bd07375 (patch)
tree3ea5c7ab8b4bbcd0bcaf38565fcdbfb31384623b /games/noegnud-slashem/Makefile
parent79fb6f7736efc2d5707e062334aa3b4ff6a1321e (diff)
downloadfreebsd-ports-gnome-6c204da6adb8e1c00d2517b2d0971dc83bd07375.tar.gz
freebsd-ports-gnome-6c204da6adb8e1c00d2517b2d0971dc83bd07375.tar.zst
freebsd-ports-gnome-6c204da6adb8e1c00d2517b2d0971dc83bd07375.zip
noeGNUd aims to be the ultimate User Interface ( UI ) for nethack. comibining
character mode, 2D tilesets and 3d graphics, all interchangeable at runtime to allow the serious nethack player ultimate freedom of interface to the game that allows ultimate freedom of gameplay and imagination. noegnud-data is the foundamental data for noeGNUd which all noeGNUd games depend on it. noegnud-nethack, noegnud-nethack-deet, noegnud-slashem, and noegnud-littlehack are the four variant games that noeGNUd support. noegnud-addons installs tilesets and sound themes. PR: ports/65318 Submitted by: Leland Wang <llwang@infor.org>
Diffstat (limited to 'games/noegnud-slashem/Makefile')
-rw-r--r--games/noegnud-slashem/Makefile65
1 files changed, 65 insertions, 0 deletions
diff --git a/games/noegnud-slashem/Makefile b/games/noegnud-slashem/Makefile
new file mode 100644
index 000000000000..19cbf0054cdf
--- /dev/null
+++ b/games/noegnud-slashem/Makefile
@@ -0,0 +1,65 @@
+# New ports collection makefile for: noegnud-slashem
+# Date created: 7 April 2004
+# Whom: Leland Wang <llwang@infor.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= noegnud
+PORTVERSION= 0.8.3
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}:noegnud,slashem
+MASTER_SITE_SUBDIR= ${PORTNAME}/:noegnud \
+ slashem/:slashem
+PKGNAMESUFFIX= -slashem
+DISTFILES= ${DISTNAME}_linux_src-minimal${EXTRACT_SUFX}:noegnud \
+ se006e4f8${EXTRACT_SUFX}:slashem
+EXTRACT_ONLY= ${DISTNAME}_linux_src-minimal${EXTRACT_SUFX}
+
+MAINTAINER= llwang@infor.org
+COMMENT= The noeGNUd UI for the SLASH'EM variant of Nethack
+
+RUN_DEPENDS= ${LOCALBASE}/share/${NOEGNUDVERSION}/data/gui:${PORTSDIR}/games/noegnud-data
+
+NOEGNUDVERSION= ${PORTNAME}-0.8.0
+USE_BISON= yes
+USE_GL= yes
+WANT_SDL= yes
+USE_SDL= sdl image mixer
+WRKSRC= ${WRKDIR}/${DISTNAME}/variants
+PATCH_WRKSRC= ${WRKDIR}/${DISTNAME}
+ALL_TARGET= se006e4f8
+INSTALL_TARGET= install_se006e4f8
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 502103
+USE_REINPLACE= yes
+.endif
+
+pre-everything::
+.if ${HAVE_SDL}
+ @${ECHO_MSG} "This port depends on SDL with OpenGL support."
+ @${ECHO_MSG} "If your SDL does not support OpenGL, hit ^C now and reinstall SDL"
+ @${ECHO_MSG} "with OpenGL support turned on."
+.endif
+
+post-extract:
+ @${CP} ${DISTDIR}/se006e4f8${EXTRACT_SUFX} ${WRKSRC}/tarballs
+ (cd ${WRKSRC} && ${MAKE} slashem-0.0.6E4F8)
+
+post-patch:
+ (cd ${WRKSRC} && ${MAKE} ${NOEGNUDVERSION}-slashem-0.0.6E4F8)
+ @(${PATCH} ${PATCH_ARGS} < ${FILESDIR}/noegnud-slashem.patch)
+.if ${OSVERSION} < 502103
+ @${REINPLACE_CMD} -e 's/regex\.h/gnuregex\.h/' \
+ ${WRKSRC}/slashem-0.0.6E4F8/src/sounds.c \
+ ${PATCH_WRKSRC}/noegnud/noegnud_textcolour.c \
+ ${PATCH_WRKSRC}/noegnud/noegnud_textcolour.h \
+ ${PATCH_WRKSRC}/noegnud/noegnud_textcolouring.c
+.endif
+
+do-configure:
+ (cd ${WRKSRC} && ${MAKE} ${NOEGNUDVERSION}-slashem-0.0.6E4F8/Makefile)
+
+.include <bsd.port.post.mk>