aboutsummaryrefslogtreecommitdiffstats
path: root/games/nonsense/Makefile
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2001-03-06 18:56:55 +0800
committerroam <roam@FreeBSD.org>2001-03-06 18:56:55 +0800
commitf88c0ca451546d087ff5fd878faf4128f4bf3846 (patch)
tree77e179d01e50a0557259b3f910bfb35451e0d292 /games/nonsense/Makefile
parentd78c28431f62a561caf1e9a03c78aa43f30e0da9 (diff)
downloadfreebsd-ports-gnome-f88c0ca451546d087ff5fd878faf4128f4bf3846.tar.gz
freebsd-ports-gnome-f88c0ca451546d087ff5fd878faf4128f4bf3846.tar.zst
freebsd-ports-gnome-f88c0ca451546d087ff5fd878faf4128f4bf3846.zip
Update to 0.6. Include manpage submitted by Dave Chapeskie.
Submitted by: Dave Chapeskie <dchapes@ddm.crosswinds.net>
Diffstat (limited to 'games/nonsense/Makefile')
-rw-r--r--games/nonsense/Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/games/nonsense/Makefile b/games/nonsense/Makefile
index cec33a7fcfb0..8f2edccd2405 100644
--- a/games/nonsense/Makefile
+++ b/games/nonsense/Makefile
@@ -6,16 +6,21 @@
#
PORTNAME= nonsense
-PORTVERSION= 0.5
+PORTVERSION= 0.6
CATEGORIES= games
-MASTER_SITES= http://i-want-a-website.com/about-linux/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= roam@FreeBSD.org
NO_BUILD= defined
+MAN6= nonsense.6
+
post-configure:
${PERL} -pi -e "s,/usr/local,${PREFIX}," ${WRKSRC}/nonsense
+ ${SED} -e "s^%%PREFIX%%^${PREFIX}^g" \
+ < ${FILESDIR}/${MAN6} > ${WRKSRC}/${MAN6}
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/nonsense ${PREFIX}/bin
@@ -23,5 +28,10 @@ do-install:
${MKDIR} ${PREFIX}/share/nonsense/template
${INSTALL_DATA} ${WRKSRC}/*.data ${PREFIX}/share/nonsense/data
${INSTALL_DATA} ${WRKSRC}/*.template ${PREFIX}/share/nonsense/template
+ ${INSTALL_MAN} ${WRKSRC}/${MAN6} ${PREFIX}/man/man6/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/nonsense
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/nonsense/
+.endif
.include <bsd.port.mk>