aboutsummaryrefslogtreecommitdiffstats
path: root/games/nonsense
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2000-12-23 02:16:39 +0800
committerroam <roam@FreeBSD.org>2000-12-23 02:16:39 +0800
commitbe2e881d33beee55eb928f78cdc242684e78a622 (patch)
tree000b462efdd82abc5647bd4b7245165c84ce708e /games/nonsense
parent6cfafc27e13392c7e0ba649cd659a0508ec3b292 (diff)
downloadfreebsd-ports-gnome-be2e881d33beee55eb928f78cdc242684e78a622.tar.gz
freebsd-ports-gnome-be2e881d33beee55eb928f78cdc242684e78a622.tar.zst
freebsd-ports-gnome-be2e881d33beee55eb928f78cdc242684e78a622.zip
Update to 0.5.
Diffstat (limited to 'games/nonsense')
-rw-r--r--games/nonsense/Makefile2
-rw-r--r--games/nonsense/distinfo2
-rw-r--r--games/nonsense/files/patch-aa16
3 files changed, 7 insertions, 13 deletions
diff --git a/games/nonsense/Makefile b/games/nonsense/Makefile
index 6a107e0527d1..cec33a7fcfb0 100644
--- a/games/nonsense/Makefile
+++ b/games/nonsense/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nonsense
-PORTVERSION= 0.4
+PORTVERSION= 0.5
CATEGORIES= games
MASTER_SITES= http://i-want-a-website.com/about-linux/
diff --git a/games/nonsense/distinfo b/games/nonsense/distinfo
index 4572d3f504a6..94aaa9f0d818 100644
--- a/games/nonsense/distinfo
+++ b/games/nonsense/distinfo
@@ -1 +1 @@
-MD5 (nonsense-0.4.tar.gz) = 4913fd46d6b93a62eb26cf96586721b8
+MD5 (nonsense-0.5.tar.gz) = 5749a6e4623e64b9929822e07c2a5512
diff --git a/games/nonsense/files/patch-aa b/games/nonsense/files/patch-aa
index 6b5d2d5eba7d..b676817893e1 100644
--- a/games/nonsense/files/patch-aa
+++ b/games/nonsense/files/patch-aa
@@ -1,5 +1,5 @@
---- nonsense 2000/12/15 13:26:57 1.1.1.3
-+++ nonsense 2000/12/15 13:54:30 1.6
+--- nonsense 2000/12/22 17:29:22 1.1.1.4
++++ nonsense 2000/12/22 17:31:00 1.7
@@ -40,6 +40,10 @@
use POSIX qw( strftime ); # Just in case somebody needs the date
use CGI;
@@ -11,7 +11,7 @@
my %pool; # Where the datafiles are slurped into
my %static; # Hash of persistent data (to maintain state)
-@@ -328,7 +332,8 @@
+@@ -332,7 +336,8 @@
sub LoadDataFile {
my $file = shift;
$file = SafeFile( $file ) if $cgi_mode;
@@ -21,7 +21,7 @@
local $/ = '';
SECTION: while( <IN> ) {
-@@ -344,7 +349,8 @@
+@@ -348,7 +353,8 @@
my $file = shift;
my $m = '';
$file = SafeFile( $file ) if $cgi_mode;
@@ -31,13 +31,7 @@
local $/; undef $/; my $t = <IN>;
close IN;
if( $t =~ /__BEGIN__/ ) { # Check for a header
-@@ -356,15 +362,29 @@
- ### Remove special characters from a filename to prevent maliciousness
- sub SafeFile {
- my( $file ) = shift;
-- $file =~ s/([|<>])//g;
-+ $file =~ s/([|<>\0]|\.\.\/)//g;
- warn("[" . localtime() . "] [warning] [client $ENV{REMOTE_ADDR}] Attempt to override filename safety feature!") if $1;
+@@ -365,10 +371,24 @@
return $file;
}