aboutsummaryrefslogtreecommitdiffstats
path: root/games/nwndata/Makefile
diff options
context:
space:
mode:
authordes <des@FreeBSD.org>2004-03-01 20:46:39 +0800
committerdes <des@FreeBSD.org>2004-03-01 20:46:39 +0800
commit14d2122c3d21fa57c5f8e288429ba94cdea7e164 (patch)
treec4413d05c74989c3aa225086e1abd149687f1734 /games/nwndata/Makefile
parent68375b7508cfe993708a6bfbd31d9aea484264e1 (diff)
downloadfreebsd-ports-gnome-14d2122c3d21fa57c5f8e288429ba94cdea7e164.tar.gz
freebsd-ports-gnome-14d2122c3d21fa57c5f8e288429ba94cdea7e164.tar.zst
freebsd-ports-gnome-14d2122c3d21fa57c5f8e288429ba94cdea7e164.zip
Instead of extracting directly to the installation directory, extract to
${WRKDIR} first, then copy the files over. This is necessary because some files need to be renamed to all-lowercase names.
Diffstat (limited to 'games/nwndata/Makefile')
-rw-r--r--games/nwndata/Makefile24
1 files changed, 13 insertions, 11 deletions
diff --git a/games/nwndata/Makefile b/games/nwndata/Makefile
index 11e98a8fe7a3..b13a08092911 100644
--- a/games/nwndata/Makefile
+++ b/games/nwndata/Makefile
@@ -5,26 +5,28 @@
# $FreeBSD$
#
-PORTNAME= linux_nwndata
+PORTNAME= nwndata
PORTVERSION= 1.29
-PORTREVISION= 1
-CATEGORIES= games linux
+PORTREVISION= 2
+CATEGORIES= games
MASTER_SITES= ftp://jeuxlinux.com/bioware/Neverwinter_Nights/
DISTNAME= nwresources${PORTVERSION:S/.//}
-EXTRACT_ONLY= # Don't extract anything
MAINTAINER= des@FreeBSD.org
COMMENT= Neverwinter Nights Data Files
ONLY_FOR_ARCHS= i386
-USE_LINUX_PREFIX= yes
-NO_BUILD= yes
-
-GAMEDIR= ${PREFIX}/usr/games/
-PLIST_SUB+= NWNDIR="usr/games/nwn"
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/nwn
+TOLOWER= ${TR} '[:upper:]' '[:lower:]'
do-install:
- (cd ${GAMEDIR} && ${TAR} zxf ${DISTDIR}/${DISTFILES})
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${GAMEDIR}/nwn
+ ${MKDIR} ${DATADIR}
+ (cd ${WRKSRC} && ${FIND} * -type d | while read d ; do \
+ ${MKDIR} "${DATADIR}/$${d}" ; \
+ done)
+ (cd ${WRKSRC} && ${FIND} * -type f -or -type l | while read f ; do \
+ ${CP} -v "$${f}" "${DATADIR}/$$(echo $${f} | ${TOLOWER})" ; \
+ done)
.include <bsd.port.mk>