aboutsummaryrefslogtreecommitdiffstats
path: root/games/nwndata/Makefile
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-09-28 20:49:38 +0800
committeredwin <edwin@FreeBSD.org>2003-09-28 20:49:38 +0800
commit2a947147abf473dd91b59bcc6a149700ec675d29 (patch)
tree6e738b53d582fb2adf94df16819f9a0d49beb348 /games/nwndata/Makefile
parent663873f0b913f6f35f0f8bbe2b16c096c43ad77e (diff)
downloadfreebsd-ports-gnome-2a947147abf473dd91b59bcc6a149700ec675d29.tar.gz
freebsd-ports-gnome-2a947147abf473dd91b59bcc6a149700ec675d29.tar.zst
freebsd-ports-gnome-2a947147abf473dd91b59bcc6a149700ec675d29.zip
[NEW PORT] games/linux_nwndata: Neverwinter Nights Data Files
This is the Neverwinter Nights data used by the Linux client. It runs under FreeBSD using the Linux emulation mode. In order to play this game, you will need the game resources, along with a license key from the retail version of this game. WWW: http://nwn.bioware.com/ Note: I have disabled the automatic fetching for this port since it is 1.2Gb in size. PR: ports/53915 Submitted by: Erik Olson <erikolson@olsonexpress.com>
Diffstat (limited to 'games/nwndata/Makefile')
-rw-r--r--games/nwndata/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/games/nwndata/Makefile b/games/nwndata/Makefile
new file mode 100644
index 000000000000..165a527695ff
--- /dev/null
+++ b/games/nwndata/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: Neverwinter Nights Data
+# Date created: 4 April 2003
+# Whom: Erik Olson <erikolson@olsonexpress.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= linux_nwndata
+PORTVERSION= 1.29
+CATEGORIES= games linux
+MASTER_SITES= # ftp://jeuxlinux.com/bioware/Neverwinter_Nights/
+DISTNAME= nwresources${PORTVERSION:S/.//}
+EXTRACT_ONLY= # Don't extract anything
+
+MAINTAINER= erikolson@olsonexpress.com
+COMMENT= Neverwinter Nights Data Files
+
+ONLY_FOR_ARCHS= i386
+USE_LINUX_PREFIX= yes
+NO_BUILD= yes
+STRIP=
+
+GAMEDIR= ${PREFIX}/usr/games/
+PLIST_SUB+= NWNDIR="/usr/games/nwn/"
+DISTDIRS= ambient data dmvault hak localvault docs \
+ modules music nwm override portraits saves \
+ servervault texturepacks \
+ chitin.key patch.key dialog.tlk nwnplayer.ini nwncdkey.ini
+
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+IGNORE= You need to download the data files manually. They are big++: 1.2 gigabyte. You can find them at ftp://jeuxlinux.com/bioware/Neverwinter_Nights/ as ${DISTFILES}. Copy them to ${DISTDIR} and run "make" again there.
+.endif
+
+.include <bsd.port.pre.mk>
+
+# Do nothing for the build. Don't set NO_BUILD because of the earlier
+# BUILD_DEPENDS
+do-build:
+
+do-install:
+ cd ${GAMEDIR}; tar xvfz ${DISTDIR}/${DISTNAME}.tar.gz
+
+.include <bsd.port.post.mk>