aboutsummaryrefslogtreecommitdiffstats
path: root/games/oolite/files
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2005-11-24 12:11:15 +0800
committeredwin <edwin@FreeBSD.org>2005-11-24 12:11:15 +0800
commitd7f19c421a192dbe65b5f067be32212bc12a0159 (patch)
tree92870d6a5b7619411cfa7623e602a0c7e57f9838 /games/oolite/files
parentf7b6d79f7473a4a76c542fda77ee5cee1f31eb41 (diff)
downloadfreebsd-ports-gnome-d7f19c421a192dbe65b5f067be32212bc12a0159.tar.gz
freebsd-ports-gnome-d7f19c421a192dbe65b5f067be32212bc12a0159.tar.zst
freebsd-ports-gnome-d7f19c421a192dbe65b5f067be32212bc12a0159.zip
New port: games/oolite - clone of Elite space simulator game for GNUstep
Oolite is an independent interpretation and recreation of the classic game, Elite. Oolite is a space trading and combat game, with the dangers of pirates, police, bounty hunters, and various other hazards. The player's role is open ended: there is no set goal other than perhaps to reach the Elite combat rating, but the players may choose their own path through the universe. The game is expandable, and numerous expansion packs already exist. New ships and new missions are available for download. You can find a first-flight tutorial here: http://oolite.aegidian.org/tutorial/ WWW: http://oolite-linux.berlios.de/ PR: ports/86997 Submitted by: Andriy Gapon <avg@icyb.net.ua>
Diffstat (limited to 'games/oolite/files')
-rw-r--r--games/oolite/files/patch-JoystickHandler.h11
-rw-r--r--games/oolite/files/patch-OOFileManager.h11
-rw-r--r--games/oolite/files/patch-main.m14
-rw-r--r--games/oolite/files/patch-makefile16
-rw-r--r--games/oolite/files/pkg-message.in16
5 files changed, 68 insertions, 0 deletions
diff --git a/games/oolite/files/patch-JoystickHandler.h b/games/oolite/files/patch-JoystickHandler.h
new file mode 100644
index 000000000000..fc0a83dce741
--- /dev/null
+++ b/games/oolite/files/patch-JoystickHandler.h
@@ -0,0 +1,11 @@
+--- JoystickHandler.h.orig Mon Oct 17 16:30:19 2005
++++ JoystickHandler.h Mon Oct 17 16:30:52 2005
+@@ -91,7 +91,7 @@
+ #define ENUMKEY(x) [NSString stringWithFormat: @"%d", x]
+
+ #import <Foundation/Foundation.h>
+-#import <SDL/SDL.h>
++#import <SDL.h>
+
+ @interface JoystickHandler : NSObject
+ {
diff --git a/games/oolite/files/patch-OOFileManager.h b/games/oolite/files/patch-OOFileManager.h
new file mode 100644
index 000000000000..f6b369c22a74
--- /dev/null
+++ b/games/oolite/files/patch-OOFileManager.h
@@ -0,0 +1,11 @@
+--- OOFileManager.h.orig Mon Oct 17 16:42:31 2005
++++ OOFileManager.h Mon Oct 17 16:43:14 2005
+@@ -16,7 +16,7 @@
+ //
+ #import <Foundation/Foundation.h>
+
+-#define SAVEDIR "oolite-saves"
++#define SAVEDIR ".oolite-saves"
+
+ @interface NSFileManager ( OOFileManager )
+
diff --git a/games/oolite/files/patch-main.m b/games/oolite/files/patch-main.m
new file mode 100644
index 000000000000..e98fe0dd923a
--- /dev/null
+++ b/games/oolite/files/patch-main.m
@@ -0,0 +1,14 @@
+--- main.m.orig Fri Oct 14 00:32:51 2005
++++ main.m Wed Oct 19 14:08:21 2005
+@@ -23,6 +23,11 @@
+ // pool.
+ NSAutoreleasePool *pool = [[NSAutoreleasePool alloc] init];
+
++ NSString *gstepdir = [NSHomeDirectory() stringByAppendingPathComponent:@"GNUstep"];
++ NSString *libdir = [gstepdir stringByAppendingPathComponent:@"Library"];
++ [[NSFileManager defaultManager] createDirectoryAtPath:gstepdir attributes:nil];
++ [[NSFileManager defaultManager] createDirectoryAtPath:libdir attributes:nil];
++
+ // dajt: allocate and set the NSApplication delegate manually because not
+ // using NIB to do this
+ controller = [[GameController alloc] init];
diff --git a/games/oolite/files/patch-makefile b/games/oolite/files/patch-makefile
new file mode 100644
index 000000000000..1af104f74aed
--- /dev/null
+++ b/games/oolite/files/patch-makefile
@@ -0,0 +1,16 @@
+--- GNUmakefile.orig Tue Oct 4 14:56:57 2005
++++ GNUmakefile Tue Oct 4 15:03:47 2005
+@@ -1,9 +1,9 @@
+ include $(GNUSTEP_MAKEFILES)/common.make
+ CP = cp
+-GNUSTEP_INSTALLATION_DIR = $(GNUSTEP_USER_ROOT)
+-ADDITIONAL_GUI_LIBS = -lGLU -lGL -lSDL -lpthread -lSDL_mixer -lSDL_image -lSDL_gfx
+-ADDITIONAL_CFLAGS = -DLINUX `sdl-config --cflags`
+-ADDITIONAL_OBJCFLAGS = -DLOADSAVEGUI -DLINUX -DHAVE_SOUND -Wno-import `sdl-config --cflags`
++GNUSTEP_INSTALLATION_DIR = $(GNUSTEP_LOCAL_ROOT)
++ADDITIONAL_GUI_LIBS = -lGLU -lGL -lSDL_mixer -lSDL_image -lSDL_gfx `sdl-config --libs`
++ADDITIONAL_CFLAGS = -I/usr/X11R6/include -DLINUX `sdl-config --cflags`
++ADDITIONAL_OBJCFLAGS = -I/usr/X11R6/include -DLOADSAVEGUI -DLINUX -DHAVE_SOUND -Wno-import `sdl-config --cflags`
+ APP_NAME = oolite
+ oolite_LIB_DIRS += -L/usr/X11R6/lib/
+
diff --git a/games/oolite/files/pkg-message.in b/games/oolite/files/pkg-message.in
new file mode 100644
index 000000000000..985cbb04d71f
--- /dev/null
+++ b/games/oolite/files/pkg-message.in
@@ -0,0 +1,16 @@
+************************************ NOTE *************************************
+
+If you are not a regular user of GNUstep environment, please follow these
+advice to run oolite:
+
+1. Make sure that necessary GNUstep daemons are running before starting oolite.
+ Usually they are started at boot-time by %%LOCALBASE%%/etc/rc.d/GNUstep.sh
+
+2. To start the game first setup GNUstep environment and then execute
+ "openapp oolite" command.
+ The environment is set by doing (depending on your shell) either
+ . %%PREFIX%%/System/Library/Makefiles/GNUstep.sh
+ or
+ source %%PREFIX%%/System/Library/Makefiles/GNUstep.csh
+
+*******************************************************************************