aboutsummaryrefslogtreecommitdiffstats
path: root/games/openarena
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2010-01-26 03:15:18 +0800
committerpav <pav@FreeBSD.org>2010-01-26 03:15:18 +0800
commitdfee6d5c62ab6b269042d70b16ee7a2529db951e (patch)
treebe83fbf870c86e4040bbca6fff53505cd1e7c8e2 /games/openarena
parent4c40a810f99571b1f539a6fbd7c3a13147bb82c0 (diff)
downloadfreebsd-ports-gnome-dfee6d5c62ab6b269042d70b16ee7a2529db951e.tar.gz
freebsd-ports-gnome-dfee6d5c62ab6b269042d70b16ee7a2529db951e.tar.zst
freebsd-ports-gnome-dfee6d5c62ab6b269042d70b16ee7a2529db951e.zip
- Introduce USE_OPENAL variable for OpenAL consumers
- Switch to openal-soft as a default OpenAL implementation PR: ports/142123 Submitted by: mva Tested by: pointyhat exp-run Approved by: portmgr (hat)
Diffstat (limited to 'games/openarena')
-rw-r--r--games/openarena/Makefile4
-rw-r--r--games/openarena/files/patch-code_client_snd_openal.c11
2 files changed, 13 insertions, 2 deletions
diff --git a/games/openarena/Makefile b/games/openarena/Makefile
index aeff19584311..35f03d5c594c 100644
--- a/games/openarena/Makefile
+++ b/games/openarena/Makefile
@@ -7,7 +7,7 @@
PORTNAME= openarena
PORTVERSION= 0.7.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= games
MASTER_SITES= http://openarena.ws/rel/070/:src \
http://download.tuxfamily.net/cooker/openarena/rel070/:data \
@@ -66,7 +66,7 @@ MAKE_ENV+= HAVE_VM_COMPILED=true
.if !defined(WITHOUT_CLIENT) || !defined(WITHOUT_SMP)
# OpenAL
. if defined(WITH_OPENAL)
-LIB_DEPENDS+= openal.0:${PORTSDIR}/audio/openal
+USE_OPENAL= al
MAKE_ENV+= USE_OPENAL=1
. if defined(WITH_OPENAL_DLOPEN)
MAKE_ENV+= USE_OPENAL_DLOPEN=1
diff --git a/games/openarena/files/patch-code_client_snd_openal.c b/games/openarena/files/patch-code_client_snd_openal.c
new file mode 100644
index 000000000000..4aaf9f885242
--- /dev/null
+++ b/games/openarena/files/patch-code_client_snd_openal.c
@@ -0,0 +1,11 @@
+--- code/client/snd_openal.c.orig 2009-12-26 18:20:08.000000000 +0100
++++ code/client/snd_openal.c 2009-12-26 18:20:27.000000000 +0100
+@@ -1676,7 +1676,7 @@
+ #elif defined(MACOS_X)
+ #define ALDRIVER_DEFAULT "/System/Library/Frameworks/OpenAL.framework/OpenAL"
+ #else
+-#define ALDRIVER_DEFAULT "libopenal.so.0"
++#define ALDRIVER_DEFAULT "libopenal.so"
+ #endif
+
+ /*
'>* Update maintainer's email address.linimon2007-03-076-6/+6 * Really normalize Aspell dictionaries ports PKGVERSION...thierry2007-02-151-0/+1 * Add Aspell Arabic dictionaries.thierry2007-02-135-0/+32 * Update to KDE 3.5.5 / KOffice 1.6.1lofi2006-12-202-6/+6 * - Updated email address in my portsnivit2006-12-101-1/+1 * Chase the GNOME X11BASE to LOCALBASE move, and fix the build with themarcus2006-10-142-3/+6 * Run ttmkfdir in a writable directory and unbreak.thierry2006-10-031-8/+4 * Run ttmkfdir in a writable directory and unbreak.thierry2006-10-031-7/+3 * KDE 3.5.4 / KOffice 1.5.2lofi2006-09-136-16/+10 * Schedule these broken ports for termination on 2006-12-01kris2006-09-032-0/+4 * BROKEN: Does not buildkris2006-08-182-0/+4 * Update to KDE 3.5.3lofi2006-06-062-6/+6 * Update to KOffice 1.5.1lofi2006-05-272-4/+4 * Fix categorieslofi2006-04-301-1/+1 * Update to KOffice 1.5.0lofi2006-04-293-27/+10 * Change maintainer email address.cperciva2006-04-166-6/+6 * Update to KDE 3.5.2lofi2006-03-312-6/+6 * Conversion to a single libtool environment.ade2006-02-231-5/+5 * Update to KDE 3.5.1.lofi2006-02-012-6/+6 * Update to KDE 3.5.0lofi2006-01-094-66/+8 * Add SHA256 message digest to distinfo fileedwin2005-12-271-0/+1 * update: arabic/kde3-i18nedwin2005-12-272-0/+2 * Add SHA256 message digest to distinfo fileedwin2005-12-271-0/+1 * Add SHA256 message digest to distinfo fileedwin2005-12-271-0/+1 * Add SHA256 message digest to distinfo fileedwin2005-12-271-0/+1 * Add SHA256 message digest to distinfo fileedwin2005-12-271-0/+1 * Add SHA256 message digest to distinfo fileedwin2005-12-271-0/+1 * Add SHA256 message digest to distinfo fileedwin2005-12-271-0/+1 * Mass-conversion to the USE_AUTOTOOLS New World Order. The code presentade2005-11-151-1/+1 * Update to KDE 3.4.3 / KOffice 1.4.2lofi2005-11-055-8/+6 * Bump PORTREVISION to chase the glib20 shared library update.marcus2005-11-051-1/+1 * Update to KDE 3.4.2 / KOffice 1.4.1lofi2005-08-014-7/+11 * - Update to 1.5 [1]jylefort2005-07-255-18/+21 * This LaTeX package extends the capabilities of TeX/LaTeX to generatepav2005-07-205-0/+250 * Remove openoffice.org localized ports as I announced:maho2005-06-292-16/+0 * Update to KDE 3.4.1lofi2005-06-265-9/+4 * Added slave port of lang/php_doc for the Arabic language.edwin2005-05-232-0/+14 * Update to KDE 3.4lofi2005-03-216-41/+14 * Bump PORTREVISION to chase the glib20 shared lib version change.marcus2005-03-121-1/+1 * The Islamic Tools and Libraries (ITL) is a project to provide a plethora ofpav2005-01-166-0/+83 * Tweak IGNORE string to give a better-worded error message.kris2004-12-191-1/+1 * Fix kde3-i18n ports.lofi2004-12-162-4/+4 * Update to KDE 3.3.2lofi2004-12-145-7/+7 * Update to KDE 3.3.1lofi2004-11-082-4/+4 * Bump PORTREVISIONS for all ports that depend on atk or pango to ease in themarcus2004-11-081-1/+1 * Update to KDE 3.3lofi2004-08-318-91/+15 * Chase libaspell to aspell.16.thierry2004-08-291-3/+3 * - Update to 1.1vs2004-08-273-48/+49 * - Add the X_WINDOW_SYSTEM={xorg,xfree86-4,xfree86-3} variable to bsd.port.mk,anholt2004-07-241-9/+3 * Pet portlint.lofi2004-07-112-1/+3 * Apply a big libtool patch to allow porters to use the libtool installed bymarcus2004-07-101-1/+1 * Update to version 3.2.3lofi2004-06-106-62/+210 * - Fix crash in search and replacepav2004-05-253-1/+25 * - Fix build with latest gtkkrion2004-05-212-3/+15 * BROKEN: Does not compilekris2004-04-191-0/+2 * Chase the glib20 update, and bump all affected ports' PORTREVISIONs.marcus2004-04-051-1/+1 * Remove category pkg/COMMENT files in favour of a COMMENT variable in thekris2004-04-022-1/+3 * Add size data, approved by maintainers.trevor2004-03-214-0/+4 * Whoa there, boy, that's a mighty big commit y'all have there...ade2004-03-141-1/+1 * Update to KDE 3.2.1 / QT 3.3.1lofi2004-03-104-1/+3 * Depend on gettext instead of non-existent gettext-old.lofi2004-02-051-1/+2 * Update to KDE 3.2.0lofi2004-02-058-13/+15 * Bump PORTREVISION on all ports that depend on gettext to aid with upgrading.marcus2004-02-041-0/+1 * Add USE_GETTEXT and bump PORTREVISION.marcus2004-02-043-6/+6 * Now gettext 0.12.1 is gettext-old.trevor2004-01-243-3/+3 * Add the pkg directory with COMMENT for arabic.marcus2003-11-251-0/+1 * Move these ports to the new arabic category after the repocopies. Fixwill2003-11-168-10/+16 * Add katoob 0.3.5, a light-weight, bidirectional editor for arabicwill2003-11-106-0/+85 * OpenOffice -> OpenOffice.orgmaho2003-11-091-1/+1 * Add OpenOffice.org 1.1 of Arabic versionmaho2003-11-092-0/+16 * Add the new real category, arabic. This is not tied to the build as theremarcus2003-11-082-0/+8 * New arabic port: khototedwin2003-10-034-0/+83 * New arabic port: kacst_fontsedwin2003-10-035-0/+67 * New arabic port: ae_fonts_ttfedwin2003-10-035-0/+153 * New arabic port: ae_fonts_monoedwin2003-10-035-0/+61 * Catch up with a couple more doc updates.will2003-09-212-2/+2 * Upgrade to Qt 3.2.1 / KDE 3.1.4. See x11/kde3/Makefile rev 1.64 for details.will2003-09-182-2/+2