aboutsummaryrefslogtreecommitdiffstats
path: root/games/openarena
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-06-01 23:28:29 +0800
committermarino <marino@FreeBSD.org>2014-06-01 23:28:29 +0800
commit609349d09e283b36d3ff627f7ab815cb5394b6e3 (patch)
treea60835aa71b563cea376eaa0213f34f52f978511 /games/openarena
parentf76656b9cc16c2c85581dc019c8f0e343e7f24b9 (diff)
downloadfreebsd-ports-gnome-609349d09e283b36d3ff627f7ab815cb5394b6e3.tar.gz
freebsd-ports-gnome-609349d09e283b36d3ff627f7ab815cb5394b6e3.tar.zst
freebsd-ports-gnome-609349d09e283b36d3ff627f7ab815cb5394b6e3.zip
games: ioquak3* iourbanterror* openarena*: Update and stage support
The patch applied without incident. Tested on DragonFly poudriere, everything built fine. It include an i386 fix, which is why the previous commit was reverted. The only modification was to change EXTRACT_CMD to TAR in a couple of places. PR: ports/187859 submitted by; maintainer (Dominic Fandrey)
Diffstat (limited to 'games/openarena')
-rw-r--r--games/openarena/Makefile1
-rw-r--r--games/openarena/files/patch-code-qcommon-vm_x86.c14
2 files changed, 14 insertions, 1 deletions
diff --git a/games/openarena/Makefile b/games/openarena/Makefile
index 102ac5f1cfbc..29b03a46cea1 100644
--- a/games/openarena/Makefile
+++ b/games/openarena/Makefile
@@ -38,5 +38,4 @@ Q3DIR= ${DATADIR}
# No icon included with OpenArena
Q3ICON=
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/games/openarena/files/patch-code-qcommon-vm_x86.c b/games/openarena/files/patch-code-qcommon-vm_x86.c
new file mode 100644
index 000000000000..546ec986ef99
--- /dev/null
+++ b/games/openarena/files/patch-code-qcommon-vm_x86.c
@@ -0,0 +1,14 @@
+--- code/qcommon/vm_x86.c.orig 2014-03-23 14:53:59.000000000 +0100
++++ code/qcommon/vm_x86.c 2014-03-23 14:55:33.000000000 +0100
+@@ -91,7 +91,11 @@
+ static void (*const asmCallPtr)(void) = AsmCall;
+
+
++#ifdef __clang__
++ int callMask = 0;
++#else
+ static int callMask = 0;
++#endif
+
+ static int instruction, pass;
+ static int lastConst = 0;