aboutsummaryrefslogtreecommitdiffstats
path: root/games/openmortal
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2006-09-20 19:21:59 +0800
committerstas <stas@FreeBSD.org>2006-09-20 19:21:59 +0800
commit690719e4d56669840ac4b9264f949634ed10d1c1 (patch)
treef8a62d437d458241263339bd8d7a8582056207da /games/openmortal
parent5cbdf409c7db9b9d115b500f9084c97595f61719 (diff)
downloadfreebsd-ports-gnome-690719e4d56669840ac4b9264f949634ed10d1c1.tar.gz
freebsd-ports-gnome-690719e4d56669840ac4b9264f949634ed10d1c1.tar.zst
freebsd-ports-gnome-690719e4d56669840ac4b9264f949634ed10d1c1.zip
- Update devel/sdl12 to version 1.2.11. Now we employ stock SDL directory
structure (i.e. include/SDL for includes and sdl-config for configuration binary) - Update graphics/sdl_ttf to version 2.0.8 - Update graphics/sdl_image to version 1.2.5 - Update audio/sdl_mixer to version 1.2.7 - Update net/sdl_net to version 1.2.6 - Update Mk/bsd.sdl.mk accordingly - Fix dependent ports to fit the new directory structure and avoid several API breakages - Bump up portrevisions for all dependent ports to allow them to be upgraded by portupgrade/portmaster etc tools Approved by: kris (portmgr), sem (mentor)
Diffstat (limited to 'games/openmortal')
-rw-r--r--games/openmortal/Makefile6
-rw-r--r--games/openmortal/files/patch-src_gfx.cpp11
-rw-r--r--games/openmortal/files/patch-src_sge_tt_text.cpp10
3 files changed, 22 insertions, 5 deletions
diff --git a/games/openmortal/Makefile b/games/openmortal/Makefile
index f187be3c2ad0..0993676b806d 100644
--- a/games/openmortal/Makefile
+++ b/games/openmortal/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openmortal
PORTVERSION= 0.7
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -25,11 +26,6 @@ CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
post-patch:
- @${REINPLACE_CMD} -e 's|sdl-config|sdl11-config|g' ${WRKSRC}/configure
- @${FIND} ${WRKSRC}/src -name "*.cpp" | ${XARGS} \
- ${REINPLACE_CMD} -e 's|SDL/|SDL11/|g' -e 's|<malloc.h>|<stdlib.h>|g'
- @${FIND} ${WRKSRC} -name "*.h" | ${XARGS} \
- ${REINPLACE_CMD} -e 's|SDL/|SDL11/|g' -e 's|<malloc.h>|<stdlib.h>|g'
.include <bsd.port.pre.mk>
diff --git a/games/openmortal/files/patch-src_gfx.cpp b/games/openmortal/files/patch-src_gfx.cpp
new file mode 100644
index 000000000000..c1c21476c0a1
--- /dev/null
+++ b/games/openmortal/files/patch-src_gfx.cpp
@@ -0,0 +1,11 @@
+--- src/gfx.cpp.orig Tue Sep 12 18:28:52 2006
++++ src/gfx.cpp Tue Sep 12 18:29:04 2006
+@@ -7,7 +7,7 @@
+ ***************************************************************************/
+
+ #include <string.h>
+-#include <malloc.h>
++#include <stdlib.h>
+
+
+ #include "SDL.h"
diff --git a/games/openmortal/files/patch-src_sge_tt_text.cpp b/games/openmortal/files/patch-src_sge_tt_text.cpp
new file mode 100644
index 000000000000..0df428b3db45
--- /dev/null
+++ b/games/openmortal/files/patch-src_sge_tt_text.cpp
@@ -0,0 +1,10 @@
+--- src/sge_tt_text.cpp.orig Tue Sep 12 18:29:07 2006
++++ src/sge_tt_text.cpp Tue Sep 12 18:29:12 2006
+@@ -26,7 +26,6 @@
+
+ #include "SDL.h"
+ #include <stdlib.h>
+-#include <malloc.h>
+ #include <memory.h>
+ #include <string.h>
+ #include <stdarg.h>