aboutsummaryrefslogtreecommitdiffstats
path: root/games/openra/Makefile
diff options
context:
space:
mode:
authordbn <dbn@FreeBSD.org>2016-11-28 01:00:08 +0800
committerdbn <dbn@FreeBSD.org>2016-11-28 01:00:08 +0800
commitde8be9930a39a62799c90cfbe165ac5495074746 (patch)
treed47ccdb7a554ac0b8b8399fa8a240b8f4abf36ad /games/openra/Makefile
parent15f0e3bb987368438da100ecc38eabd8352189be (diff)
downloadfreebsd-ports-gnome-de8be9930a39a62799c90cfbe165ac5495074746.tar.gz
freebsd-ports-gnome-de8be9930a39a62799c90cfbe165ac5495074746.tar.zst
freebsd-ports-gnome-de8be9930a39a62799c90cfbe165ac5495074746.zip
USES=mono: simplify EXTRACT_ONLY, fix nuget-extract [1]
- Instead of excluding the specific packages added to DISTFILES (but only for FreeBSD 9+), exclude all files with a '.nupkg' extension. - Move the nuget-extract command to be before post-extract, to allow the port's post-extract command to move packages around audio/libgpod-sharp: add port for mono bindings for libgpod - audio/libgpod: [2] - USE_GNOME: add missing dependency - Remove mono files from pkg-plist (now in audio/libgpod-sharp) - Allow relevant variables to be overridden - Fix MONO options - Patch source to allow building with modern mono - Avoid post-install target for slave ports. devel/monodevelop: update to 4.6.2.7 - Update nuget package Fantomas to 2.4.0 (latest at time of monodevelop's release). - Downgrade nuget package FSharp.Compiler.CodeDom (per paket's specification) - LICENSE: Add license of LGPL21 - LICENSE_FILE: Add license file from source - PORTSCOUT: Avoid checking alpha releases (aka x.y.0.z releases) games/openra: simplify post-extract [3] - USES=mono:nuget allow overridding of NUGET_PACKAGEDIR - Set NUGET_PACKAGEDIR to correct location, fix patching accordingly lang/fsharp: update to 4.6.2.7 ChangeLog: - Fix #639: Problems with F# scripts on Mono - Fix FSharp.Compiler.Tools targets for .NET Core usage - Fix FSharp.Compiler.Tools package dependencies lang/mono: update to 4.6.2.7 Mono 4.6.2 is the 1st service release to the 4.6 series. Changes: - LICENSE: Add license of MIT - LICENSE_FILE: Add license file from source - PORTSCOUT: Avoid checking alpha releases (aka x.y.0.z releases) Bug fixes: - #44708 - "TrustFailure (The authentication or decryption has failed.) ... Invalid certificate received from server." with "Error code: 0x5" or "Error code: 0xffffffff800b010f" when attempting to access HTTPS servers on ports other than 443 - #39832 - SIGSEGV when running roslyn multimedia/banshee: bump port revision. - Update missing port dependencies - Convert to use option helpers - OPTIONS: Add APPLEDEV (missing dependency added) - LICENSE: Add MIT license - LICENSE_FILE: Add license file from source - PORTSCOUT: Skip alpha release (2.9.1) x11-toolkits/gnome-sharp20: fix port dependencies - Add missing dependencies - Convert post-patch to shebangfix - LICENSE: add LGPL21 license - LICENSE_FILE: use license file from source - MKAE_JOBS_UNSAFE: remove, does appear to work x11-toolkits/gtk-sharp20: update to 2.12.42. PR: 214680 [2] PR: 214681 Suggested by: jbeich [1] Submitted by: jbeich [3] Approved by: avilla (maintainer; timeout) [2]
Diffstat (limited to 'games/openra/Makefile')
-rw-r--r--games/openra/Makefile22
1 files changed, 8 insertions, 14 deletions
diff --git a/games/openra/Makefile b/games/openra/Makefile
index 229afe98ccd9..d8fce0719d06 100644
--- a/games/openra/Makefile
+++ b/games/openra/Makefile
@@ -44,10 +44,11 @@ NO_ARCH= yes
USES= desktop-file-utils gmake lua:51,run mono:nuget openal:soft \
shared-mime-info shebangfix
USE_SDL= sdl2
-TARGET_ORDER_OVERRIDE= 520:nuget-extract
+NUGET_PACKAGEDIR=${WRKSRC}/thirdparty/download
SHEBANG_FILES= launch-dedicated.sh
MAKE_ENV= prefix="${PREFIX}" mandir="${PREFIX}/man"
MAKE_ARGS= VERSION="${GH_TAGNAME}"
+ALL_TARGET= all
INSTALL_TARGET= install-all install-man-page \
install-linux-mime install-linux-shortcuts
DATADIR= ${PREFIX}/lib/${PORTNAME}
@@ -68,25 +69,18 @@ ZENITY_RUN_DEPENDS=xdg-open:devel/xdg-utils \
ZENITY_DESC= Use native crash dialog
post-extract:
- @${MKDIR} ${WRKSRC}/thirdparty/download
- @${CP} -v ${DISTFILES:C/:.*//:N*.nupkg:N*.tar*:N*.zip:S,^,${_DISTDIR}/,} \
- ${WRKSRC}/thirdparty/download
- @for f in $$(${SED} -n 's/\.$$//; s,cp \./,,p' \
- ${WRKSRC}/thirdparty/fetch-thirdparty-deps.sh); do \
- ${MV} -v ${NUGET_PACKAGEDIR}/$$f ${WRKSRC}/thirdparty/download; \
- done
+ ${CP} ${DISTFILES:C/:.*//:N*.nupkg:N*.tar*:S,^,${_DISTDIR}/,} \
+ ${NUGET_PACKAGEDIR}
post-patch:
${REINPLACE_CMD} \
- -e '\,thirdparty/.*\.sh,d' \
-e '/echo/!s/ @/ /' \
-e '/^mods:/s/$$/ version/' \
- -e '/^docs:/s/$$/ all/' \
- -e '/^test:/s/$$/ all/' \
${WRKSRC}/Makefile
- ${REINPLACE_CMD} -e '/linux/{ p; s//${OPSYS:tl}/; }' \
- ${WRKSRC}/thirdparty/download/*.config \
- ${WRKSRC}/thirdparty/*.config*
+ ${REINPLACE_CMD} -e '/[[:<:]]get[[:blank:]]/d' \
+ ${WRKSRC}/thirdparty/fetch-thirdparty-deps.sh
+ ${FIND} ${WRKSRC}/thirdparty -name '*.config*' -exec ${REINPLACE_CMD} \
+ -i '.bak.os' -e '/linux/{ p; s//${OPSYS:tl}/; }' {} +
${SED} 's/@LIBLUA51@/liblua-${LUA_VER}.so/' \
${WRKSRC}/thirdparty/Eluant.dll.config.in \
>${WRKSRC}/Eluant.dll.config