aboutsummaryrefslogtreecommitdiffstats
path: root/games/openttd/Makefile
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2010-02-16 20:35:40 +0800
committerdanfe <danfe@FreeBSD.org>2010-02-16 20:35:40 +0800
commit9d420352dddb0df77844654cc7ff17c8123ffdc3 (patch)
tree419666a8474f240ecdcd71318866cdeb990bbf3d /games/openttd/Makefile
parent1ac811a8f1bd1cfda582a4c82a21d3440dfae734 (diff)
downloadfreebsd-ports-gnome-9d420352dddb0df77844654cc7ff17c8123ffdc3.tar.gz
freebsd-ports-gnome-9d420352dddb0df77844654cc7ff17c8123ffdc3.tar.zst
freebsd-ports-gnome-9d420352dddb0df77844654cc7ff17c8123ffdc3.zip
- Update to version 0.7.5
- Disable SF mirror since it does not carry new distfile - Utilize PORTDOCS macro and offload pkg-plist - Optimize away `.for .. .endfor' loop in Makefile Reminded by: pav Feature safe: yes
Diffstat (limited to 'games/openttd/Makefile')
-rw-r--r--games/openttd/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/games/openttd/Makefile b/games/openttd/Makefile
index 2e73400ddafb..4ab987409d37 100644
--- a/games/openttd/Makefile
+++ b/games/openttd/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= openttd
-PORTVERSION= 0.7.3
+PORTVERSION= 0.7.5
CATEGORIES= games
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION} \
- http://binaries.openttd.org/releases/${PORTVERSION}/
+MASTER_SITES= http://gb.binaries.openttd.org/binaries/releases/${PORTVERSION}/ \
+ #SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= danfe@FreeBSD.org
COMMENT= An open source clone of Microprose Transport Tycoon Deluxe
@@ -47,10 +47,11 @@ MAN6= openttd.6
DESKTOP_ENTRIES="OpenTTD" "${COMMENT}" "openttd" "openttd" \
"Game;Simulation;StrategyGame;" false
-DOCS= 32bpp.txt HOWTO_compile_lang_files.txt Manual.txt elrail.svg \
+PORTDOCS= 32bpp.txt HOWTO_compile_lang_files.txt Manual.txt elrail.svg \
elrail_tile.png elrail_track.png landscape.html \
landscape_externals.html landscape_grid.html multiplayer.txt \
- ottd-colour-palette.gif ottd-colourtext-palette.png tileh.png
+ obg_format.txt ottd-colour-palette.gif \
+ ottd-colourtext-palette.png tileh.png
pre-everything::
.if !defined(WITH_MIDI_PLAYER)
@@ -65,7 +66,7 @@ pre-everything::
post-patch:
# Remove extra (vendor) CFLAGS, we set our own
- @${REINPLACE_CMD} '1096,1097d' ${WRKSRC}/config.lib
+ @${REINPLACE_CMD} '1102,1103d' ${WRKSRC}/config.lib
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${PREFIX}/bin
@@ -81,9 +82,7 @@ do-install:
.endfor
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-. for f in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/docs/${f} ${DOCSDIR}
-. endfor
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/docs/,} ${DOCSDIR}
.endif
post-install: