aboutsummaryrefslogtreecommitdiffstats
path: root/games/openttd
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-11-30 06:56:41 +0800
committerpav <pav@FreeBSD.org>2006-11-30 06:56:41 +0800
commit3522ba4ff8f5342544c46b40bc2858b5ddbbb9be (patch)
tree34d63c66017fe5159d2c0bbf7676d3f80480f926 /games/openttd
parentfb214d41faac15d65ec086f82ffbcb94dc249a6d (diff)
downloadfreebsd-ports-gnome-3522ba4ff8f5342544c46b40bc2858b5ddbbb9be.tar.gz
freebsd-ports-gnome-3522ba4ff8f5342544c46b40bc2858b5ddbbb9be.tar.zst
freebsd-ports-gnome-3522ba4ff8f5342544c46b40bc2858b5ddbbb9be.zip
- Fix WITH_MIDI_PLAYER option (mixing of variable assignments and targets)
PR: ports/100928 Submitted by: Ed Schouten <ed@fxq.nl> Approved by: maintainer timeout (4 months) - Add desktop entry PR: ports/104069 Submitted by: Pawel Pekala <c0rn@o2.pl> Approved by: maintainer timeout (1,5 month) - Modernize pkg-message handling, style
Diffstat (limited to 'games/openttd')
-rw-r--r--games/openttd/Makefile39
-rw-r--r--games/openttd/files/pkg-message.in (renamed from games/openttd/pkg-message)2
2 files changed, 23 insertions, 18 deletions
diff --git a/games/openttd/Makefile b/games/openttd/Makefile
index 440ad1b9d701..7b08ae2f08b0 100644
--- a/games/openttd/Makefile
+++ b/games/openttd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= openttd
PORTVERSION= 0.4.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,23 +15,37 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= danfe@FreeBSD.org
COMMENT= An open source clone of Microprose Transport Tycoon Deluxe
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+
+USE_GMAKE= yes
+
+.if defined(WITH_MIDI_PLAYER)
+MAKE_ARGS+= MIDI=${WITH_MIDI_PLAYER}
+.endif
+.if defined(WITH_DEDICATED_SERVER_ONLY)
+MAKE_ARGS+= DEDICATED=1
+.else
+USE_SDL= sdl
+.endif
+
+MAKE_ARGS+= RELEASE=${PORTVERSION} DATA_DIR="share/openttd" \
+ USE_HOMEDIR=1 PERSONAL_DIR=.openttd INSTALL=1 VERBOSE=1
+
DISTVERSIONSUFFIX= -source
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
+SUB_FILES= pkg-message
-USE_GMAKE= yes
+MAN6= openttd.6
+
+DESKTOP_ENTRIES="OpenTTD" "${COMMENT}" "" "openttd" "" false
pre-everything::
.if !defined(WITH_MIDI_PLAYER)
@${ECHO_MSG} "Define WITH_MIDI_PLAYER=/path/to/player to build with external MIDI player"
-.else
-MAKE_ARGS+= MIDI=${WITH_MIDI_PLAYER}
.endif
.if !defined(WITH_DEDICATED_SERVER_ONLY)
@${ECHO_MSG} "Define WITH_DEDICATED_SERVER_ONLY to build CLI-based dedicated server"
-USE_SDL= sdl
-.else
-MAKE_ARGS+= DEDICATED=1
.endif
post-extract:
@@ -39,14 +53,6 @@ post-extract:
@${REINPLACE_CMD} -e 's|^WITH_SDL|#WITH_SDL|' ${WRKSRC}/makefiledir/Makefile.libdetection
.endif
-MAKE_ARGS+= RELEASE=${PORTVERSION} DATA_DIR="share/openttd" \
- USE_HOMEDIR=1 PERSONAL_DIR=.openttd INSTALL=1 VERBOSE=1
-
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-PKGMESSAGE= ${WRKDIR}/pkg-message
-
-MAN6= openttd.6
-
do-install:
@${MKDIR} ${DATADIR}/data ${DATADIR}/lang
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
@@ -63,7 +69,6 @@ do-install:
.endif
post-install:
- @${SED} -e 's|$${DATADIR}|${DATADIR}|' ${.CURDIR}/pkg-message >${PKGMESSAGE}
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/games/openttd/pkg-message b/games/openttd/files/pkg-message.in
index d6fad80077ec..d5d11266ed46 100644
--- a/games/openttd/pkg-message
+++ b/games/openttd/files/pkg-message.in
@@ -2,7 +2,7 @@
OpenTTD requires the original Windows version of "Transport Tycoon
Deluxe" data files in order to function. Copy the following files
- to ${DATADIR}/data/ directory:
+ to %%DATADIR%%/data/ directory:
sample.cat
trg1r.grf