aboutsummaryrefslogtreecommitdiffstats
path: root/games/p5-Games-Bingo-Bot/Makefile
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2003-09-01 22:07:24 +0800
committermat <mat@FreeBSD.org>2003-09-01 22:07:24 +0800
commit6659ef77874f06ca1fd2f5d6b35ec73cd05b8ced (patch)
treec694d09e7537f92ab4cf3dd2755be84a19add9e3 /games/p5-Games-Bingo-Bot/Makefile
parentb1efd52ad2be3dc5c43d0641547181d66cf19b39 (diff)
downloadfreebsd-ports-gnome-6659ef77874f06ca1fd2f5d6b35ec73cd05b8ced.tar.gz
freebsd-ports-gnome-6659ef77874f06ca1fd2f5d6b35ec73cd05b8ced.tar.zst
freebsd-ports-gnome-6659ef77874f06ca1fd2f5d6b35ec73cd05b8ced.zip
Add p5-Games-Bingo-Bot 0.01,
a simple class holding IRC related methods for bingo. PR: 55820 Submitted by: Lars Thegler <lars@thegler.dk>
Diffstat (limited to 'games/p5-Games-Bingo-Bot/Makefile')
-rw-r--r--games/p5-Games-Bingo-Bot/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/games/p5-Games-Bingo-Bot/Makefile b/games/p5-Games-Bingo-Bot/Makefile
new file mode 100644
index 000000000000..2ba03e158548
--- /dev/null
+++ b/games/p5-Games-Bingo-Bot/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-Games-Bingo-Bot
+# Date created: 20. August 2003
+# Whom: Lars Thegler <lars@thegler.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Games-Bingo-Bot
+PORTVERSION= 0.01
+CATEGORIES= games perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Games
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@thegler.dk
+COMMENT= A simple class holding IRC related methods for bingo
+
+BUILD_DEPENDS= ${SITE_PERL}/Games/Bingo.pm:${PORTSDIR}/games/p5-Games-Bingo
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Games::Bingo::Bot.3
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${ECHO_MSG} "===> Installing example for ${PKGNAME}"
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/bingobot.pl ${EXAMPLESDIR}
+.endif
+
+test:
+ @cd ${WRKSRC}; make test
+
+.include <bsd.port.mk>