aboutsummaryrefslogtreecommitdiffstats
path: root/games/p5-Games-Dice
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-06-02 20:26:10 +0800
committerjylefort <jylefort@FreeBSD.org>2005-06-02 20:26:10 +0800
commit1e3b7d0744efefcb4932c8d7ec51c15247d64dd6 (patch)
treebbc96572ba7745de06ac12e17c501ba38ab56792 /games/p5-Games-Dice
parent8fb93fbbab0956572f15d997278bf605fbcb0f43 (diff)
downloadfreebsd-ports-gnome-1e3b7d0744efefcb4932c8d7ec51c15247d64dd6.tar.gz
freebsd-ports-gnome-1e3b7d0744efefcb4932c8d7ec51c15247d64dd6.tar.zst
freebsd-ports-gnome-1e3b7d0744efefcb4932c8d7ec51c15247d64dd6.zip
Add p5-Games-Dice.
Games::Dice simulates die rolls. It uses a function-oriented (not object-oriented) interface. No functions are exported by default. The number and type of dice to roll is given in a style which should be familiar to players of popular role-playing games: adb[+-*/b]c. a is optional and defaults to 1; it gives the number of dice to roll. b indicates the number of sides to each die. % can be used instead of 100 for b; hence, rolling 2d% and 2d100 is equivalent. roll simulates a rolls of b-sided dice and adds together the results. The optional end, consisting of one of +-*/b and a number c, can modify the sum of the individual dice. +-*/ are similar in that they take the sum of the rolls and add or subtract c, or multiply or divide the sum by c. (x can also be used instead of *.) Using b in this slot is a little different: it's short for "best" and indicates "roll a number of dice, but add together only the best few". For example, 5d6b3 rolls five six- sided dice and adds together the three best rolls. Author: Philip Newton <pne@cpan.org> WWW: http://search.cpan.org/dist/Games-Dice/ PR: ports/81612 Submitted by: Aaron Dalton <aaron@daltons.ca>
Diffstat (limited to 'games/p5-Games-Dice')
-rw-r--r--games/p5-Games-Dice/Makefile22
-rw-r--r--games/p5-Games-Dice/distinfo2
-rw-r--r--games/p5-Games-Dice/pkg-descr22
-rw-r--r--games/p5-Games-Dice/pkg-plist5
4 files changed, 51 insertions, 0 deletions
diff --git a/games/p5-Games-Dice/Makefile b/games/p5-Games-Dice/Makefile
new file mode 100644
index 000000000000..71b980eb1992
--- /dev/null
+++ b/games/p5-Games-Dice/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: Games-Dice
+# Date created: 28 May 2005
+# Whom: Aaron Dalton <aaron@daltons.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Games-Dice
+PORTVERSION= 0.02
+CATEGORIES= games perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Games
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@daltons.ca
+COMMENT= Perl module to simulate die rolls
+
+MAN3= Games::Dice.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/games/p5-Games-Dice/distinfo b/games/p5-Games-Dice/distinfo
new file mode 100644
index 000000000000..d9dd7d8baa3a
--- /dev/null
+++ b/games/p5-Games-Dice/distinfo
@@ -0,0 +1,2 @@
+MD5 (Games-Dice-0.02.tar.gz) = 69585be0bdf4875a0c80d046f22a3ab0
+SIZE (Games-Dice-0.02.tar.gz) = 3884
diff --git a/games/p5-Games-Dice/pkg-descr b/games/p5-Games-Dice/pkg-descr
new file mode 100644
index 000000000000..c5d5747ab071
--- /dev/null
+++ b/games/p5-Games-Dice/pkg-descr
@@ -0,0 +1,22 @@
+Games::Dice simulates die rolls. It uses a function-oriented (not
+object-oriented) interface. No functions are exported by default.
+
+The number and type of dice to roll is given in a style which should be
+familiar to players of popular role-playing games: adb[+-*/b]c. a is optional
+and defaults to 1; it gives the number of dice to roll. b indicates the number
+of sides to each die. % can be used instead of 100 for b; hence, rolling 2d%
+and 2d100 is equivalent. roll simulates a rolls of b-sided dice and adds
+together the results. The optional end, consisting of one of +-*/b and a
+number c, can modify the sum of the individual dice. +-*/ are similar in that
+they take the sum of the rolls and add or subtract c, or multiply or divide
+the sum by c. (x can also be used instead of *.) Using b in this slot is a
+little different: it's short for "best" and indicates "roll a number of dice,
+but add together only the best few". For example, 5d6b3 rolls five six- sided
+dice and adds together the three best rolls.
+
+Author: Philip Newton <pne@cpan.org>
+
+WWW: http://search.cpan.org/dist/Games-Dice/
+
+- Aaron Dalton
+aaron@daltons.ca
diff --git a/games/p5-Games-Dice/pkg-plist b/games/p5-Games-Dice/pkg-plist
new file mode 100644
index 000000000000..c1d04eb8a7a3
--- /dev/null
+++ b/games/p5-Games-Dice/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Games/Dice.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Games/Dice/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Games/Dice
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Games 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Games 2>/dev/null || true