aboutsummaryrefslogtreecommitdiffstats
path: root/games/palapeli
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-03-27 19:55:25 +0800
committermakc <makc@FreeBSD.org>2013-03-27 19:55:25 +0800
commit4071ff71b938de957201b333e5ab5b90c718c7a6 (patch)
treebcb09269855487369fcfd28040255e86e37e1362 /games/palapeli
parente847a9821369a4907e8956149272623bd60baa79 (diff)
downloadfreebsd-ports-gnome-4071ff71b938de957201b333e5ab5b90c718c7a6.tar.gz
freebsd-ports-gnome-4071ff71b938de957201b333e5ab5b90c718c7a6.tar.zst
freebsd-ports-gnome-4071ff71b938de957201b333e5ab5b90c718c7a6.zip
KDE/FreeBSD team presents KDE SC 4.10.1 ports!
- kdegames4 port has been split. - kdeutils4-printer-applet and system-config-printer-kde have been replaced by print/kde4-print-manager. - Recover misc/kde4-l10n-mr from attic. - New USE_KDE4 components: kactivities, libkdegames, nepomuk-core, and nepomuk-widgets. - Provide sharedmime component with magic: ports don't need to run update-mime-database themselves now. - Switch some ports to out-of-source build. - Update port comments. - Adjust dependence on Qt4 components. - x11/kde4 installs modern kdepim4 now. - Remove redundant aspell and hspell from kdelibs4, both can be enabled in textproc/enchant if needed. - Remove stale bits from bsd.kde4.mk The area51 repository features commits by Schaich Alonso and myself. Contributors: - Tobias Berner
Diffstat (limited to 'games/palapeli')
-rw-r--r--games/palapeli/Makefile28
-rw-r--r--games/palapeli/distinfo2
-rw-r--r--games/palapeli/pkg-descr7
-rw-r--r--games/palapeli/pkg-plist73
4 files changed, 110 insertions, 0 deletions
diff --git a/games/palapeli/Makefile b/games/palapeli/Makefile
new file mode 100644
index 000000000000..5ef84bd1eb4f
--- /dev/null
+++ b/games/palapeli/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= palapeli
+PORTVERSION= ${KDE4_VERSION}
+CATEGORIES= games kde
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
+DIST_SUBDIR= KDE/${PORTVERSION}
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= ${${PORTNAME}_DESC}
+
+CONFLICTS_INSTALL= kdegames-4.[0-9].*
+
+USE_KDE4= kdehier kdelibs kdeprefix libkdegames automoc4 sharedmime
+USES= cmake:outsource
+USE_QT4= corelib gui gui \
+ moc_build qmake_build rcc_build uic_build
+USE_XZ= yes
+USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
+
+post-patch:
+ ${REINPLACE_CMD} -e '/^update_xdg_mimetypes/ d' \
+ ${WRKSRC}/mime/CMakeLists.txt
+
+.include <${.CURDIR}/../kdegames4/Makefile.common>
+.include <bsd.port.mk>
diff --git a/games/palapeli/distinfo b/games/palapeli/distinfo
new file mode 100644
index 000000000000..3428b3dc0024
--- /dev/null
+++ b/games/palapeli/distinfo
@@ -0,0 +1,2 @@
+SHA256 (KDE/4.10.1/palapeli-4.10.1.tar.xz) = 6c70ed74242b21291420b859de8694fe14f99db7a6f13b86cc026818e2d87ec2
+SIZE (KDE/4.10.1/palapeli-4.10.1.tar.xz) = 1737580
diff --git a/games/palapeli/pkg-descr b/games/palapeli/pkg-descr
new file mode 100644
index 000000000000..1700a27bbe5d
--- /dev/null
+++ b/games/palapeli/pkg-descr
@@ -0,0 +1,7 @@
+Palapeli is a single-player jigsaw puzzle game. Unlike other games
+in that genre, you are not limited to aligning pieces on imaginary
+grids. The pieces are freely moveable. Also, Palapeli features
+real persistency, i.e. everything you do is saved on your disk
+immediately.
+
+WWW: http://www.kde.org/applications/games/palapeli/
diff --git a/games/palapeli/pkg-plist b/games/palapeli/pkg-plist
new file mode 100644
index 000000000000..86faafe95cfa
--- /dev/null
+++ b/games/palapeli/pkg-plist
@@ -0,0 +1,73 @@
+bin/palapeli
+include/Pala/Slicer
+include/Pala/SlicerJob
+include/Pala/SlicerMode
+include/Pala/SlicerProperty
+include/Pala/SlicerPropertySet
+include/libpala/libpalamacros.h
+include/libpala/slicer.h
+include/libpala/slicerjob.h
+include/libpala/slicermode.h
+include/libpala/slicerproperty.h
+include/libpala/slicerpropertyset.h
+lib/kde4/palapeli_goldbergslicer.so
+lib/kde4/palapeli_jigsawslicer.so
+lib/kde4/palapeli_rectslicer.so
+lib/kde4/palathumbcreator.so
+lib/libpala.so
+lib/libpala.so.0
+lib/libpala.so.0.2.0
+lib/libpala/libpala-config.cmake
+lib/libpala/pala-targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/libpala/pala-targets.cmake
+share/applications/kde4/palapeli.desktop
+share/apps/palapeli/backgrounds/Eliminator-Funk-2.jpg
+share/apps/palapeli/backgrounds/Rear-Admiral-Diplomat-1.jpg
+share/apps/palapeli/backgrounds/Time-For-Lunch-2.jpg
+share/apps/palapeli/backgrounds/background.svg
+share/apps/palapeli/backgrounds/gon-defends-the-critters-1.jpg
+share/apps/palapeli/backgrounds/mahogany-handjob-1.jpg
+share/apps/palapeli/collection/castle-maintenon.desktop
+share/apps/palapeli/collection/castle-maintenon.jpg
+share/apps/palapeli/collection/cincinnati-bridge.desktop
+share/apps/palapeli/collection/cincinnati-bridge.jpg
+share/apps/palapeli/collection/citrus-fruits.desktop
+share/apps/palapeli/collection/citrus-fruits.jpg
+share/apps/palapeli/collection/european-honey-bee.desktop
+share/apps/palapeli/collection/european-honey-bee.jpg
+share/apps/palapeli/collection/panther-chameleon-female.desktop
+share/apps/palapeli/collection/panther-chameleon-female.jpg
+share/apps/palapeli/palapeli.kcfg
+share/apps/palapeli/palapeli.notifyrc
+share/apps/palapeli/palapeliui.rc
+share/config/palapeli-collectionrc
+share/doc/HTML/en/palapeli/common
+share/doc/HTML/en/palapeli/index.cache.bz2
+share/doc/HTML/en/palapeli/index.docbook
+share/doc/HTML/en/palapeli/puzzletable1.png
+share/icons/hicolor/128x128/apps/palapeli.png
+share/icons/hicolor/128x128/mimetypes/application-x-palapeli.png
+share/icons/hicolor/16x16/apps/palapeli.png
+share/icons/hicolor/16x16/mimetypes/application-x-palapeli.png
+share/icons/hicolor/24x24/apps/palapeli.png
+share/icons/hicolor/24x24/mimetypes/application-x-palapeli.png
+share/icons/hicolor/32x32/apps/palapeli.png
+share/icons/hicolor/32x32/mimetypes/application-x-palapeli.png
+share/icons/hicolor/48x48/apps/palapeli.png
+share/icons/hicolor/48x48/mimetypes/application-x-palapeli.png
+share/icons/hicolor/64x64/apps/palapeli.png
+share/icons/hicolor/64x64/mimetypes/application-x-palapeli.png
+share/kde4/services/ServiceMenus/palapeli_servicemenu.desktop
+share/kde4/services/palapeli_goldbergslicer.desktop
+share/kde4/services/palapeli_jigsawslicer.desktop
+share/kde4/services/palapeli_rectslicer.desktop
+share/kde4/services/palathumbcreator.desktop
+share/kde4/servicetypes/libpala-slicerplugin.desktop
+share/mime/packages/palapeli-mimetypes.xml
+@dirrm share/doc/HTML/en/palapeli
+@dirrm share/apps/palapeli/collection
+@dirrm share/apps/palapeli/backgrounds
+@dirrm share/apps/palapeli
+@dirrm lib/libpala
+@dirrm include/libpala
+@dirrm include/Pala