aboutsummaryrefslogtreecommitdiffstats
path: root/games/passage/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-04-27 16:45:15 +0800
committermiwi <miwi@FreeBSD.org>2008-04-27 16:45:15 +0800
commit49e3941a233849f67266bac6746f546a31035919 (patch)
tree10e592a12b5b4fe604a0d6eba2b20d5bb8ee05e1 /games/passage/Makefile
parent3e7053999c7fe9fd7f145a6e6fc48010ec1bce3e (diff)
downloadfreebsd-ports-gnome-49e3941a233849f67266bac6746f546a31035919.tar.gz
freebsd-ports-gnome-49e3941a233849f67266bac6746f546a31035919.tar.zst
freebsd-ports-gnome-49e3941a233849f67266bac6746f546a31035919.zip
Passage is meant to be a memento mori game. It presents an entire
life, from young adulthood through old age and death, in the span of five minutes. Of course, it's a game, not a painting or a film, so the choices that you make as the player are crucial. There's no "right" way to play Passage, just as there's no right way to interpret it. WWW: http://hcsoftware.sourceforge.net/passage PR: ports/123031 Submitted by: Dmitry Marakasov <amdmi3 at amdmi3.ru>
Diffstat (limited to 'games/passage/Makefile')
-rw-r--r--games/passage/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/games/passage/Makefile b/games/passage/Makefile
new file mode 100644
index 000000000000..e4a88cb7ab2a
--- /dev/null
+++ b/games/passage/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: passage
+# Date created: 23 Apr 2008
+# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= passage
+PORTVERSION= 3
+CATEGORIES= games
+MASTER_SITES= SF/hcsoftware
+DISTNAME= Passage_v${PORTVERSION}_UnixSource
+
+MAINTAINER= amdmi3@amdmi3.ru
+COMMENT= An experimental video game by Jason Rohrer
+
+USE_SDL= sdl
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/gamma256/gameSource
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lSDL||' ${WRKSRC}/Makefile.GnuLinux
+ @${REINPLACE_CMD} -e 's|"graphics"|"${DATADIR}/graphics"|' \
+ ${WRKSRC}/common.cpp
+ @${REINPLACE_CMD} -e 's|"music"|"${DATADIR}/music"|' \
+ ${WRKSRC}/musicPlayer.cpp
+ @${REINPLACE_CMD} -e 's|"settings"|"${DATADIR}/settings"|' \
+ ${WRKDIR}/${DISTNAME}/minorGems/util/SettingsManager.cpp
+
+do-configure:
+ cd ${WRKSRC} && ${CAT} Makefile.GnuLinux Makefile.all > Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/Passage ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+.for d in graphics music settings
+ cd ${WRKSRC} && ${COPYTREE_SHARE} ${d} ${DATADIR}
+.endfor
+
+.include <bsd.port.mk>