aboutsummaryrefslogtreecommitdiffstats
path: root/games/pcgen/Makefile
diff options
context:
space:
mode:
authorhq <hq@FreeBSD.org>2005-09-08 21:46:23 +0800
committerhq <hq@FreeBSD.org>2005-09-08 21:46:23 +0800
commit833c609d7c13aefbf3499237556e684cb709a476 (patch)
tree1f0fa1edcb680c5be53cc4724310315592442fa7 /games/pcgen/Makefile
parent0ed9d8b94fa3838931277f751bdd5cf55ff950e0 (diff)
downloadfreebsd-ports-gnome-833c609d7c13aefbf3499237556e684cb709a476.tar.gz
freebsd-ports-gnome-833c609d7c13aefbf3499237556e684cb709a476.tar.zst
freebsd-ports-gnome-833c609d7c13aefbf3499237556e684cb709a476.zip
- Update to 5.8.0 (latest release from stable branch)
- Add a FreeBSD-specific launcher shell script. It allows the user to specify Java VM args using PCGEN_OPTS
Diffstat (limited to 'games/pcgen/Makefile')
-rw-r--r--games/pcgen/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/games/pcgen/Makefile b/games/pcgen/Makefile
index 15f199291fc6..5c74b841d712 100644
--- a/games/pcgen/Makefile
+++ b/games/pcgen/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= pcgen
-PORTVERSION= 5.7.15
+PORTVERSION= 5.8.0
CATEGORIES= games java
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= pcgen
@@ -26,6 +26,8 @@ DATADIR= ${JAVASHAREDIR}/${PORTNAME}
DATAFILES= characters data filepaths.ini lib outputsheets pcgen.jar plugins system
PLIST_FILES+= bin/pcgen
+SUB_FILES= pcgen.sh
+
.if !defined(NOPORTDOCS)
PORTDOCS= acknowledgments faqpages gmgen greetings.html images \
index.html installationpages listfilepages menupages \
@@ -38,10 +40,6 @@ post-extract:
do-configure:
@${ECHO_CMD} "pcgen.filepaths=user" > ${WRKSRC}/filepaths.ini
- @${SED} \
- -e 's|^java|JAVA_VERSION="1.4+" "${LOCALBASE}/bin/java"|' \
- -e 's|`dirname $$0`|"${DATADIR}"|' \
- ${WRKSRC}/pcgen.sh > ${WRKSRC}/pcgen.sh.bsd
do-install:
@${ECHO_MSG} -n ">> Installing in ${DATADIR}..."
@@ -49,7 +47,7 @@ do-install:
@cd ${WRKSRC} && ${FIND} ${DATAFILES} -type f -exec ${INSTALL_DATA} {} ${DATADIR}/{} ";"
@${ECHO_MSG} " [ DONE ]"
@${ECHO_MSG} -n ">> Installing launcher script as ${PREFIX}/bin/pcgen..."
- @${INSTALL_SCRIPT} ${WRKSRC}/pcgen.sh.bsd ${PREFIX}/bin/pcgen
+ @${INSTALL_SCRIPT} ${WRKDIR}/pcgen.sh ${PREFIX}/bin/pcgen
@${ECHO_MSG} " [ DONE ]"
.if !defined(NOPORTDOCS)
@${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."