aboutsummaryrefslogtreecommitdiffstats
path: root/games/penguin-command
diff options
context:
space:
mode:
authormarkp <markp@FreeBSD.org>2003-02-10 21:21:21 +0800
committermarkp <markp@FreeBSD.org>2003-02-10 21:21:21 +0800
commit08b11f16c7fe0b3d1baf8c89405ef91df773cf39 (patch)
treeb2f82ac1f744af64e50832519a2ae33ff96ddfe1 /games/penguin-command
parentcb6b357005e8ed6d35d1e29d02f0fbf2eddc72c1 (diff)
downloadfreebsd-ports-gnome-08b11f16c7fe0b3d1baf8c89405ef91df773cf39.tar.gz
freebsd-ports-gnome-08b11f16c7fe0b3d1baf8c89405ef91df773cf39.tar.zst
freebsd-ports-gnome-08b11f16c7fe0b3d1baf8c89405ef91df773cf39.zip
Changed to use REINPLACE.
Diffstat (limited to 'games/penguin-command')
-rw-r--r--games/penguin-command/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/games/penguin-command/Makefile b/games/penguin-command/Makefile
index a345eb3c8569..f512966e5872 100644
--- a/games/penguin-command/Makefile
+++ b/games/penguin-command/Makefile
@@ -19,14 +19,15 @@ LIB_DEPENDS= SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer \
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
MAN6= penguin-command.6
post-patch:
- ${PERL} -pi -e 's|"SDL/SDL|"SDL|g ; s|<SDL/SDL|<SDL|g' \
+ ${REINPLACE_CMD} 's|"SDL/SDL|"SDL|g ; s|<SDL/SDL|<SDL|g' \
${WRKSRC}/configure ${WRKSRC}/src/*.[ch]
- ${PERL} -pi -e "s/ -lz -lSDL -lm/ -lz -lm/g" ${WRKSRC}/configure
+ ${REINPLACE_CMD} 's/ -lz -lSDL -lm/ -lz -lm/g' ${WRKSRC}/configure
.include <bsd.port.mk>