aboutsummaryrefslogtreecommitdiffstats
path: root/games/phpua-engine/Makefile
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2009-04-13 05:36:22 +0800
committerpgollucci <pgollucci@FreeBSD.org>2009-04-13 05:36:22 +0800
commit9ce27410670e21f6ebe61817480dc9ab7071c928 (patch)
treefe24602c981c80693ba458901c5452d55d8ce501 /games/phpua-engine/Makefile
parent97f1b5aa0a3d22b244a54a474d810e1cc1c001db (diff)
downloadfreebsd-ports-gnome-9ce27410670e21f6ebe61817480dc9ab7071c928.tar.gz
freebsd-ports-gnome-9ce27410670e21f6ebe61817480dc9ab7071c928.tar.zst
freebsd-ports-gnome-9ce27410670e21f6ebe61817480dc9ab7071c928.zip
- USE_APACHE=yes is deprecated
- Use SF Macro - Make use of SUB_LIST for pkg-message - Bump PORTREVISION
Diffstat (limited to 'games/phpua-engine/Makefile')
-rw-r--r--games/phpua-engine/Makefile18
1 files changed, 8 insertions, 10 deletions
diff --git a/games/phpua-engine/Makefile b/games/phpua-engine/Makefile
index ed6f0c66bd60..7063bf92aa5b 100644
--- a/games/phpua-engine/Makefile
+++ b/games/phpua-engine/Makefile
@@ -7,19 +7,22 @@
PORTNAME= phpua-engine
PORTVERSION= 1.1.0b
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games www
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= phpua
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= ${PORTNAME:S/-.*//}
MAINTAINER= ports@FreeBSD.org
COMMENT= Game server monitor & admin tool
NO_BUILD= yes
-USE_APACHE= yes
+USE_APACHE= 1.3
USE_PHP= yes
-PLIST_SUB+= PHPUADIR=${PHPUADIR} PHPUA_USER=${PHPUA_USER} PHPUA_GROUP=${PHPUA_GROUP}
+_subs=PHPUADIR=${PHPUADIR} PHPUA_USER=${PHPUA_USER} PHPUA_GROUP=${PHPUA_GROUP} APNAME=${APNAME}
+
+PLIST_SUB+= ${_subs}
+SUB_LIST+= ${_subs}
# Dynamic custom variables
PHPUA_USER?= ${WWWOWN}
@@ -44,11 +47,6 @@ pre-everything::
${ECHO_MSG} '-------------------------------------------------------------------------')
.endif
-post-patch:
- @${CAT} ${FILESDIR}/pkg-message.in | ${SED} -e \
- 's|%%PREFIX%%|${PREFIX}| ; s|%%PHPUADIR%%|${PHPUADIR}| ; s|%%APPNAME%%|${APPNAME}|' \
- > ${PKGMESSAGE}
-
do-extract:
@ ${MKDIR} ${WRKSRC}
@ cd ${WRKSRC} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/${DISTNAME}${EXTRACT_SUFX} ${EXTRACT_AFTER_ARGS}