aboutsummaryrefslogtreecommitdiffstats
path: root/games/phpua-q3
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-04-10 20:19:41 +0800
committerpav <pav@FreeBSD.org>2004-04-10 20:19:41 +0800
commit3e251fbc2bf461f6c39a3ebfb860b63d26c8abc6 (patch)
treeec99bcd36a79166dabe6aa3ad0216b72030d5c92 /games/phpua-q3
parent6c2b58bc6e903cf2d41a0bb839e99c4414d93b8f (diff)
downloadfreebsd-ports-gnome-3e251fbc2bf461f6c39a3ebfb860b63d26c8abc6.tar.gz
freebsd-ports-gnome-3e251fbc2bf461f6c39a3ebfb860b63d26c8abc6.tar.zst
freebsd-ports-gnome-3e251fbc2bf461f6c39a3ebfb860b63d26c8abc6.zip
Add phpua-q3, Quake 3 plug-in for phpUA.
PR: ports/65188 Submitted by: Hideki Machida <hido@neojapangz.com>
Diffstat (limited to 'games/phpua-q3')
-rw-r--r--games/phpua-q3/Makefile53
-rw-r--r--games/phpua-q3/distinfo2
-rw-r--r--games/phpua-q3/files/pkg-opts10
-rw-r--r--games/phpua-q3/pkg-descr11
-rw-r--r--games/phpua-q3/pkg-plist75
5 files changed, 151 insertions, 0 deletions
diff --git a/games/phpua-q3/Makefile b/games/phpua-q3/Makefile
new file mode 100644
index 000000000000..50524445373e
--- /dev/null
+++ b/games/phpua-q3/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: phpua-plugin_q3
+# Date created: 11 March 2003
+# Whom: hideki
+#
+# $FreeBSD$
+#
+
+PORTNAME= phpua-plugin_q3
+PORTVERSION= 1.1.0b
+CATEGORIES= games www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= phpua
+
+MAINTAINER= hido@neojapangz.com
+COMMENT= A Quake 3 plugin for phpUA
+
+RUN_DEPENDS= ${LOCALBASE}/${PHPUA}/index.php:${PORTSDIR}/games/phpua-engine
+
+# Some variables you can change
+PHPUA?= www/data/phpua
+USER?= www
+GROUP?= www
+
+# Static Variables
+PKGOPTS= ${FILESDIR}/pkg-opts
+
+NO_BUILD= yes
+
+PLIST_SUB+= PHPUA=${PHPUA}
+
+options:
+ @ ${ECHO_MSG} "===> Build options for ${PKGNAME}:"
+ @ ${CAT} ${PKGOPTS}
+
+pre-everything::
+.if !defined(BATCH)
+ @ ${TEST} -r ${PKGOPTS} && \
+ (${ECHO_MSG} '-------------------------------------------------------------------------'; \
+ ${ECHO_MSG} 'Perform a "make options" to see a list of available installation options.'; \
+ ${ECHO_MSG} '-------------------------------------------------------------------------')
+.endif
+
+do-install:
+ @ ${CP} -R ${WRKDIR}/plugins ${PREFIX}/${PHPUA}/
+ @ ${CP} -R ${WRKDIR}/templates ${PREFIX}/${PHPUA}/
+ @ ${CP} -R ${WRKDIR}/images ${PREFIX}/${PHPUA}/
+ @ ${CHOWN} -R ${USER}:${GROUP} ${PREFIX}/${PHPUA}
+ @ ${ECHO_MSG} ""
+ @ ${ECHO_MSG} "* Files have been installed in"
+ @ ${ECHO_MSG} "* ${PREFIX}/${PHPUA}"
+ @ ${ECHO_MSG} "*"
+
+.include <bsd.port.mk>
diff --git a/games/phpua-q3/distinfo b/games/phpua-q3/distinfo
new file mode 100644
index 000000000000..ef265fe90a95
--- /dev/null
+++ b/games/phpua-q3/distinfo
@@ -0,0 +1,2 @@
+MD5 (phpua-plugin_q3-1.1.0b.tar.gz) = 1d13cc88ffc58a6b13d38f30d15ff117
+SIZE (phpua-plugin_q3-1.1.0b.tar.gz) = 1980651
diff --git a/games/phpua-q3/files/pkg-opts b/games/phpua-q3/files/pkg-opts
new file mode 100644
index 000000000000..60e0b3999572
--- /dev/null
+++ b/games/phpua-q3/files/pkg-opts
@@ -0,0 +1,10 @@
+
+> PHPUA [www/data/phpua]
+ The DocumentRoot for your webserver under ${PREFIX}
+
+> USER [www]
+ The user ID under which your webserver runs
+
+> GROUP [www]
+ The group ID under which your webserver runs
+
diff --git a/games/phpua-q3/pkg-descr b/games/phpua-q3/pkg-descr
new file mode 100644
index 000000000000..17306701fdb6
--- /dev/null
+++ b/games/phpua-q3/pkg-descr
@@ -0,0 +1,11 @@
+phpUA is a PHP script that enables gaming server administrators
+to manage their servers via a website interface and to display
+server information including live statistics to the public.
+Plug-ins allow for game, language and website design compatibility.
+
+This is a plug-in for Quake 3.
+
+WWW: http://phpua.sourceforge.net/
+
+- Hideki
+hido@neojapangz.com
diff --git a/games/phpua-q3/pkg-plist b/games/phpua-q3/pkg-plist
new file mode 100644
index 000000000000..ff957ae0d0fb
--- /dev/null
+++ b/games/phpua-q3/pkg-plist
@@ -0,0 +1,75 @@
+%%PHPUA%%/images/plugin_q3/maps/pro-q3dm13.jpg
+%%PHPUA%%/images/plugin_q3/maps/pro-q3dm6.jpg
+%%PHPUA%%/images/plugin_q3/maps/pro-q3tourney2.jpg
+%%PHPUA%%/images/plugin_q3/maps/pro-q3tourney4.jpg
+%%PHPUA%%/images/plugin_q3/maps/q3ctf1.jpg
+%%PHPUA%%/images/plugin_q3/maps/q3ctf2.jpg
+%%PHPUA%%/images/plugin_q3/maps/q3ctf3.jpg
+%%PHPUA%%/images/plugin_q3/maps/q3ctf4.jpg
+%%PHPUA%%/images/plugin_q3/maps/q3dm0.jpg
+%%PHPUA%%/images/plugin_q3/maps/q3dm1.jpg
+%%PHPUA%%/images/plugin_q3/maps/q3dm10.jpg
+%%PHPUA%%/images/plugin_q3/maps/q3dm11.jpg
+%%PHPUA%%/images/plugin_q3/maps/q3dm12.jpg
+%%PHPUA%%/images/plugin_q3/maps/q3dm13.jpg
+%%PHPUA%%/images/plugin_q3/maps/q3dm14.jpg
+%%PHPUA%%/images/plugin_q3/maps/q3dm15.jpg
+%%PHPUA%%/images/plugin_q3/maps/q3dm16.jpg
+%%PHPUA%%/images/plugin_q3/maps/q3dm17.jpg
+%%PHPUA%%/images/plugin_q3/maps/q3dm18.jpg
+%%PHPUA%%/images/plugin_q3/maps/q3dm19.jpg
+%%PHPUA%%/images/plugin_q3/maps/q3dm2.jpg
+%%PHPUA%%/images/plugin_q3/maps/q3dm3.jpg
+%%PHPUA%%/images/plugin_q3/maps/q3dm4.jpg
+%%PHPUA%%/images/plugin_q3/maps/q3dm5.jpg
+%%PHPUA%%/images/plugin_q3/maps/q3dm6.jpg
+%%PHPUA%%/images/plugin_q3/maps/q3dm7.jpg
+%%PHPUA%%/images/plugin_q3/maps/q3dm8.jpg
+%%PHPUA%%/images/plugin_q3/maps/q3dm9.jpg
+%%PHPUA%%/images/plugin_q3/maps/q3tourney1.jpg
+%%PHPUA%%/images/plugin_q3/maps/q3tourney2.jpg
+%%PHPUA%%/images/plugin_q3/maps/q3tourney3.jpg
+%%PHPUA%%/images/plugin_q3/maps/q3tourney4.jpg
+%%PHPUA%%/images/plugin_q3/maps/q3tourney5.jpg
+%%PHPUA%%/images/plugin_q3/maps/q3tourney6.jpg
+%%PHPUA%%/images/plugin_q3/maps/q3tourney6_ctf.jpg
+%%PHPUA%%/images/plugin_q3/maps/ra3map1.jpg
+%%PHPUA%%/images/plugin_q3/maps/ra3map10.jpg
+%%PHPUA%%/images/plugin_q3/maps/ra3map11.jpg
+%%PHPUA%%/images/plugin_q3/maps/ra3map12.jpg
+%%PHPUA%%/images/plugin_q3/maps/ra3map13.jpg
+%%PHPUA%%/images/plugin_q3/maps/ra3map14.jpg
+%%PHPUA%%/images/plugin_q3/maps/ra3map15.jpg
+%%PHPUA%%/images/plugin_q3/maps/ra3map16.jpg
+%%PHPUA%%/images/plugin_q3/maps/ra3map17.jpg
+%%PHPUA%%/images/plugin_q3/maps/ra3map18.jpg
+%%PHPUA%%/images/plugin_q3/maps/ra3map19.jpg
+%%PHPUA%%/images/plugin_q3/maps/ra3map2.jpg
+%%PHPUA%%/images/plugin_q3/maps/ra3map3.jpg
+%%PHPUA%%/images/plugin_q3/maps/ra3map4.jpg
+%%PHPUA%%/images/plugin_q3/maps/ra3map5.jpg
+%%PHPUA%%/images/plugin_q3/maps/ra3map6.jpg
+%%PHPUA%%/images/plugin_q3/maps/ra3map7.jpg
+%%PHPUA%%/images/plugin_q3/maps/ra3map8.jpg
+%%PHPUA%%/images/plugin_q3/maps/ra3map9.jpg
+%%PHPUA%%/images/templates/default/plugin_q3/unavailable.jpg
+%%PHPUA%%/images/templates/wap/plugin_q3/unavailable.jpg
+%%PHPUA%%/plugins/plugin_q3/plugin_q3.inc
+%%PHPUA%%/plugins/plugin_q3/plugin_q3_mode_info.inc
+%%PHPUA%%/plugins/plugin_q3/plugin_q3_mode_rules.inc
+%%PHPUA%%/plugins/plugin_q3/plugin_q3_mode_watch.inc
+%%PHPUA%%/templates/default/plugin_q3/info.tpl
+%%PHPUA%%/templates/default/plugin_q3/rules.tpl
+%%PHPUA%%/templates/default/plugin_q3/watch.js
+%%PHPUA%%/templates/default/plugin_q3/watch.tpl
+%%PHPUA%%/templates/default/plugin_q3/x.js
+%%PHPUA%%/templates/javascript/plugin_q3/info.tpl
+%%PHPUA%%/templates/wap/plugin_q3/info.tpl
+@dirrm %%PHPUA%%/templates/wap/plugin_q3
+@dirrm %%PHPUA%%/templates/javascript/plugin_q3
+@dirrm %%PHPUA%%/templates/default/plugin_q3
+@dirrm %%PHPUA%%/plugins/plugin_q3
+@dirrm %%PHPUA%%/images/templates/wap/plugin_q3
+@dirrm %%PHPUA%%/images/templates/default/plugin_q3
+@dirrm %%PHPUA%%/images/plugin_q3/maps
+@dirrm %%PHPUA%%/images/plugin_q3