aboutsummaryrefslogtreecommitdiffstats
path: root/games/phpua-ut/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-04-10 20:33:58 +0800
committerpav <pav@FreeBSD.org>2004-04-10 20:33:58 +0800
commit1ca72e9f268924058db64f330f4fc59a5e81c7d9 (patch)
tree708696b77af2efd7be79a27dc11e06149644e2e8 /games/phpua-ut/Makefile
parent8ccf9ed7f8b12fa04f32e81a87dbdf6bb0ebde77 (diff)
downloadfreebsd-ports-gnome-1ca72e9f268924058db64f330f4fc59a5e81c7d9.tar.gz
freebsd-ports-gnome-1ca72e9f268924058db64f330f4fc59a5e81c7d9.tar.zst
freebsd-ports-gnome-1ca72e9f268924058db64f330f4fc59a5e81c7d9.zip
Add phpua-ut, Unreal Tournament plug-in for phpUA.
PR: ports/65190 Submitted by: Hideki Machida <hido@neojapangz.com>
Diffstat (limited to 'games/phpua-ut/Makefile')
-rw-r--r--games/phpua-ut/Makefile53
1 files changed, 53 insertions, 0 deletions
diff --git a/games/phpua-ut/Makefile b/games/phpua-ut/Makefile
new file mode 100644
index 000000000000..bc16a92a0595
--- /dev/null
+++ b/games/phpua-ut/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: phpua-plugin_ut
+# Date created: 29 March 2003
+# Whom: hideki
+#
+# $FreeBSD$
+#
+
+PORTNAME= phpua-plugin_ut
+PORTVERSION= 1.1.0b
+CATEGORIES= games www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= phpua
+
+MAINTAINER= hido@neojapangz.com
+COMMENT= An Unreal Tournament plugin for phpUA
+
+RUN_DEPENDS= ${LOCALBASE}/${PHPUA}/index.php:${PORTSDIR}/games/phpua-engine
+
+# Some variables you can change
+PHPUA?= www/data/phpua
+USER?= www
+GROUP?= www
+
+# Static Variables
+PKGOPTS= ${FILESDIR}/pkg-opts
+
+NO_BUILD= yes
+
+PLIST_SUB+= PHPUA=${PHPUA}
+
+options:
+ @ ${ECHO_MSG} "===> Build options for ${PKGNAME}:"
+ @ ${CAT} ${PKGOPTS}
+
+pre-everything::
+.if !defined(BATCH)
+ @ ${TEST} -r ${PKGOPTS} && \
+ (${ECHO_MSG} '-------------------------------------------------------------------------'; \
+ ${ECHO_MSG} 'Perform a "make options" to see a list of available installation options.'; \
+ ${ECHO_MSG} '-------------------------------------------------------------------------')
+.endif
+
+do-install:
+ @ ${CP} -R ${WRKDIR}/images ${PREFIX}/${PHPUA}/
+ @ ${CP} -R ${WRKDIR}/plugins ${PREFIX}/${PHPUA}/
+ @ ${CP} -R ${WRKDIR}/templates ${PREFIX}/${PHPUA}/
+ @ ${CHOWN} -R ${USER}:${GROUP} ${PREFIX}/${PHPUA}
+ @ ${ECHO_MSG} ""
+ @ ${ECHO_MSG} "* Files have been installed in"
+ @ ${ECHO_MSG} "* ${PREFIX}/${PHPUA}"
+ @ ${ECHO_MSG} "*"
+
+.include <bsd.port.mk>