aboutsummaryrefslogtreecommitdiffstats
path: root/games/phpua-ut2003/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-07-22 18:23:48 +0800
committermiwi <miwi@FreeBSD.org>2006-07-22 18:23:48 +0800
commit57ed7bbf3c9b8757ffc5a019f8eba18c79735fbb (patch)
treefec6de0225620319ec89db2c5011730ec2f0a3dc /games/phpua-ut2003/Makefile
parent35b7698d613ff9a9d95c45a45844ea7ffeba145a (diff)
downloadfreebsd-ports-gnome-57ed7bbf3c9b8757ffc5a019f8eba18c79735fbb.tar.gz
freebsd-ports-gnome-57ed7bbf3c9b8757ffc5a019f8eba18c79735fbb.tar.zst
freebsd-ports-gnome-57ed7bbf3c9b8757ffc5a019f8eba18c79735fbb.zip
- Mark unbroken
- Pass maintainership to submitter - Fix plist PR: ports/99744 Submitted by: Babak Farrokhi <babak(at)farrokhi.net> Approved by: krion (mentor)
Diffstat (limited to 'games/phpua-ut2003/Makefile')
-rw-r--r--games/phpua-ut2003/Makefile22
1 files changed, 12 insertions, 10 deletions
diff --git a/games/phpua-ut2003/Makefile b/games/phpua-ut2003/Makefile
index 51f1ab423f6c..15d5da493934 100644
--- a/games/phpua-ut2003/Makefile
+++ b/games/phpua-ut2003/Makefile
@@ -7,21 +7,19 @@
PORTNAME= phpua-plugin_ut2003
PORTVERSION= 1.1.0b
+PORTREVISION= 1
CATEGORIES= games www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= phpua
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= babak@farrokhi.net
COMMENT= An Unreal Tournament 2003 plugin for phpUA
-RUN_DEPENDS= ${LOCALBASE}/${PHPUA}/index.php:${PORTSDIR}/games/phpua-engine
-
-BROKEN= does not install due to dependency problem in games/phpua-engine
-DEPRECATED= ${BROKEN}
-EXPIRATION_DATE=2006-09-03
+BUILD_DEPENDS= ${LOCALBASE}/${PHPUA}/index.php:${PORTSDIR}/games/phpua-engine
+RUN_DEPENDS= ${BUILD_DEPENDS}
# Some variables you can change
-PHPUA?= www/data/phpua
+PHPUA?= www/phpua
PHPUA_USER?= ${WWWOWN}
PHPUA_GROUP?= ${WWWGRP}
@@ -44,12 +42,16 @@ pre-everything::
${ECHO_MSG} '-------------------------------------------------------------------------')
.endif
+do-extract:
+ @ ${MKDIR} ${WRKSRC}
+ @ cd ${WRKSRC} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/${DISTNAME}${EXTRACT_SUFX} ${EXTRACT_AFTER_ARGS}
+
do-install:
- @ ${CP} -R ${WRKDIR}/plugins ${PREFIX}/${PHPUA}/
- @ ${CP} -R ${WRKDIR}/templates ${PREFIX}/${PHPUA}/
- @ ${CHOWN} -R ${PHPUA_USER}:${PHPUA_GROUP} ${PREFIX}/${PHPUA}
+ @ ${CHOWN} -R ${PHPUA_USER}:${PHPUA_GROUP} ${WRKSRC}
+ @ ${CP} -R ${WRKSRC}/ ${PREFIX}/${PHPUA}/
@ ${ECHO_MSG} ""
@ ${ECHO_MSG} "* Files have been installed in"
@ ${ECHO_MSG} "* ${PREFIX}/${PHPUA}"
@ ${ECHO_MSG} "*"
+
.include <bsd.port.mk>