aboutsummaryrefslogtreecommitdiffstats
path: root/games/pinball/Makefile
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2003-12-17 17:31:35 +0800
committerlinimon <linimon@FreeBSD.org>2003-12-17 17:31:35 +0800
commitd717afe08f81480947876c1b7d7b8bd4b92acd63 (patch)
treec3f92257275613f999fc6f0065d5a8d12a52dec9 /games/pinball/Makefile
parenta666d0246729f1706aac91701ff34d57bb47ead9 (diff)
downloadfreebsd-ports-gnome-d717afe08f81480947876c1b7d7b8bd4b92acd63.tar.gz
freebsd-ports-gnome-d717afe08f81480947876c1b7d7b8bd4b92acd63.tar.zst
freebsd-ports-gnome-d717afe08f81480947876c1b7d7b8bd4b92acd63.zip
Update to 0.3.1. Changes:
* Menu disappear" and other bugs fixed. * Additions to the Tux-table. * Ogg files instead of midi files as midi had compability problems. * Some tools and bug fixes in table editor. Also, mark as BROKEN for the Allegro case. The website says that the Allegro version is always a bit behind in development and has more bugs than the SDL/OpenGL version; the maintainer adds that it's just completely broken now. If you're using Allegro, you will want to avoid upgrading. PR: ports/60192 Submitted by: Thierry Thomas <thierry@pompo.net> (maintainer)
Diffstat (limited to 'games/pinball/Makefile')
-rw-r--r--games/pinball/Makefile14
1 files changed, 3 insertions, 11 deletions
diff --git a/games/pinball/Makefile b/games/pinball/Makefile
index d28144b4aeed..5d4c99e15217 100644
--- a/games/pinball/Makefile
+++ b/games/pinball/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pinball
-PORTVERSION= 0.3.0
+PORTVERSION= 0.3.1
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,12 +14,12 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= thierry@pompo.net
COMMENT= Emilia Pinball is a free pinball game
-PATCH_DEPENDS= ${DOS2UNIX}:${PORTSDIR}/converters/unix2dos
.if !defined(WITH_ALLEGRO)
BUILD_DEPENDS= ${SDL_CONFIG}:${PORTSDIR}/devel/sdl12
LIB_DEPENDS= SDL_image.10:${PORTSDIR}/graphics/sdl_image \
SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer
.else
+BROKEN= "support with Allegro is (temporarily) broken as of version 0.31"
BUILD_DEPENDS= ${ALLEGRO_CONFIG}:${PORTSDIR}/devel/allegro
LIB_DEPENDS= alleg.41:${PORTSDIR}/devel/allegro
.endif
@@ -31,7 +31,7 @@ USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
-CONFIGURE_ARGS= --prefix=${PREFIX}
+CONFIGURE_ARGS= --prefix=${PREFIX} --without-debug
.if defined(WITH_ALLEGRO)
CONFIGURE_ARGS+= --with-allegro
EXTRA_LIBS= -lGL -lGLU
@@ -41,17 +41,9 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${X11BASE}/include
SDL_CONFIG="${SDL_CONFIG}"
SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
ALLEGRO_CONFIG= ${LOCALBASE}/bin/allegro-config
-DOS2UNIX= ${LOCALBASE}/bin/dos2unix
DOCS= README
-DOS2TR= base/Private.h
-
-post-patch:
-.for FILE in ${DOS2TR}
- @${DOS2UNIX} ${WRKSRC}/${FILE}
-.endfor
-
post-install:
@${MV} ${PREFIX}/bin/${MACHINE_ARCH}-unknown-freebsd${OSREL}-pinball \
${PREFIX}/bin/pinball