aboutsummaryrefslogtreecommitdiffstats
path: root/games/pingus
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2013-10-19 19:19:35 +0800
committertijl <tijl@FreeBSD.org>2013-10-19 19:19:35 +0800
commit2ca3f19ce4d9e4ff2e1fbc7a9268bfc0496afb45 (patch)
tree602d34b71c285783d4a999bb86b46a19cc261876 /games/pingus
parent6c7c46104f1fe84fab13cad72b679b766c6c85eb (diff)
downloadfreebsd-ports-gnome-2ca3f19ce4d9e4ff2e1fbc7a9268bfc0496afb45.tar.gz
freebsd-ports-gnome-2ca3f19ce4d9e4ff2e1fbc7a9268bfc0496afb45.tar.zst
freebsd-ports-gnome-2ca3f19ce4d9e4ff2e1fbc7a9268bfc0496afb45.zip
- Fix build with clang with two new patches
- Install icon and use it in a .desktop file - While here, use space in WWW: and use new style LIB_DEPENDS PR: ports/181498 Submitted by: amdmi3 Approved by: maintainer timeout (8 weeks)
Diffstat (limited to 'games/pingus')
-rw-r--r--games/pingus/Makefile15
-rw-r--r--games/pingus/files/patch-src-editor-editor__screen.hpp11
-rw-r--r--games/pingus/files/patch-src-lisp-getters.hpp11
-rw-r--r--games/pingus/pkg-descr2
4 files changed, 32 insertions, 7 deletions
diff --git a/games/pingus/Makefile b/games/pingus/Makefile
index 494445ecdb0d..a8607efc0080 100644
--- a/games/pingus/Makefile
+++ b/games/pingus/Makefile
@@ -3,16 +3,16 @@
PORTNAME= pingus
PORTVERSION= 0.7.2
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= games
MASTER_SITES= http://pingus.seul.org/files/
MAINTAINER= acm@FreeBSD.org
COMMENT= Free Lemmings-like game
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- boost_regex:${PORTSDIR}/devel/boost-libs \
- physfs.1:${PORTSDIR}/devel/physfs
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
+ libboost_regex.so:${PORTSDIR}/devel/boost-libs \
+ libphysfs.so:${PORTSDIR}/devel/physfs
USE_BZIP2= yes
USES= iconv
@@ -21,8 +21,9 @@ SCONS_ARGS= with_linuxusbmouse=0 \
with_linuxevdev=0
USE_SDL= sdl image mixer
-DESKTOP_ENTRIES= "Pingus" "${COMMENT}" "" \
- "pingus" "" false
+DESKTOP_ENTRIES="Pingus" "${COMMENT}" \
+ "${PREFIX}/share/pixmaps/${PORTNAME}.ico" \
+ "pingus" "" "false"
PLIST= ${WRKDIR}/pkg-plist
@@ -34,6 +35,7 @@ post-patch:
pre-install:
@${RM} -f ${PLIST}
@${ECHO_CMD} "bin/${PORTNAME}" >> ${PLIST}
+ @${ECHO_CMD} "share/pixmaps/${PORTNAME}.ico" >> ${PLIST}
@cd ${WRKSRC}/data && \
${FIND} * -type f | ${SORT} | ${SED} -e 's|^|%%DATADIR%%/|' >> ${PLIST} && \
${FIND} * -type d | ${SORT} -r | ${SED} -e 's|^|@dirrm %%DATADIR%%/|' >> ${PLIST}
@@ -45,5 +47,6 @@ do-install:
${FIND} * -type d -exec ${MKDIR} "${DATADIR}/{}" \; && \
${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/src/win32/icon1.ico ${PREFIX}/share/pixmaps/${PORTNAME}.ico
.include <bsd.port.mk>
diff --git a/games/pingus/files/patch-src-editor-editor__screen.hpp b/games/pingus/files/patch-src-editor-editor__screen.hpp
new file mode 100644
index 000000000000..c607fe21ec98
--- /dev/null
+++ b/games/pingus/files/patch-src-editor-editor__screen.hpp
@@ -0,0 +1,11 @@
+--- src/editor/editor_screen.hpp.orig 2007-09-30 20:07:08.000000000 +0400
++++ src/editor/editor_screen.hpp 2013-08-23 23:08:40.689231327 +0400
+@@ -27,7 +27,7 @@
+
+ class DrawingContext;
+ class FileDialog;
+-class GUI::GUIManager;
++namespace GUI { class GUIManager; }
+ class Pathname;
+
+ namespace Editor {
diff --git a/games/pingus/files/patch-src-lisp-getters.hpp b/games/pingus/files/patch-src-lisp-getters.hpp
new file mode 100644
index 000000000000..ec0260523983
--- /dev/null
+++ b/games/pingus/files/patch-src-lisp-getters.hpp
@@ -0,0 +1,11 @@
+--- src/lisp/getters.hpp.orig 2007-08-17 20:20:09.000000000 +0400
++++ src/lisp/getters.hpp 2013-08-09 13:42:19.551761882 +0400
+@@ -30,7 +30,7 @@
+ if(lisp->get_list_size() != 2)
+ return false;
+
+- const Lisp* el = lisp->get_list_elem(1);
++ const Lisp* el = lisp->get_list_elem(1).get();
+ return get(el, val);
+ }
+
diff --git a/games/pingus/pkg-descr b/games/pingus/pkg-descr
index 4c813635cda2..ff643b80c2c9 100644
--- a/games/pingus/pkg-descr
+++ b/games/pingus/pkg-descr
@@ -2,4 +2,4 @@ Pingus is a free Lemmings-like game covered under the GNU GPL. It features
currently 22 playable levels and runs under a wide variety of operating systems
(FreeBSD, Linux, Windows, etc.)
-WWW: http://pingus.seul.org/
+WWW: http://pingus.seul.org/
3424'>benchmarks/iorate: USES+=alias to fix build on DragonFlymarino2015-09-221-1/+1 * Typos, whitespace and capitalization fixes (A-F).olgeni2015-09-211-1/+1 * benchmarks/siege: Update version 3.1.0=>3.1.1bofh2015-09-152-3/+3 * benchmarks/filebench: fix cosmetic issuesjbeich2015-09-102-6/+7 * - Fix plist [1]novel2015-09-092-7/+41 * - Update to 3.4.1farrokhi2015-09-045-305/+25 * - Remove useless use of MASTER_SITE_SUBDIR [1]jlaffaye2015-08-252-4/+3 * Commit the real fix.jlaffaye2015-08-251-3/+4 * Unbreak by updating MASTER_SITE_SUBDIRjlaffaye2015-08-251-2/+1 * - Updated to latesvg2015-08-244-18/+27 * - Update The Glorious Glasgow Haskell Compiler to version 7.10.2pgj2015-08-213-7/+7 * remove empty pkg-plistpgollucci2015-08-211-1/+0 * Convert ports to use the options helpers in categories [abc]*, and minor fixes.mat2015-08-1910-124/+39 * - Remove RG linksunpoet2015-08-141-1/+0 * benchmarks/tsung: update 1.5.1 -> 1.6.0robak2015-08-083-4/+23 * - Update to 2.3.0sunpoet2015-07-242-3/+3 * - Mark BROKEN: does not build as it still requires libtarantool.so which data...amdmi32015-07-141-0/+2 * - Remove blank line between NO_ARCH and USE_RUBYsunpoet2015-07-071-1/+0 * Set NO_ARCH for remaining rubygem-* ports with no arch dependent filespgollucci2015-07-032-0/+4 * Update to version 3.7.2skreuzer2015-07-023-6/+5 * Add LOCAL mirror as distfile does not seem to be available anymoremartymac2015-07-021-1/+2 * Convert to USES=autoreconfbapt2015-06-221-4/+1 * - Pass maintainership to submitteramdmi32015-06-195-11/+11 * - Fix shebangsamdmi32015-06-101-2/+3 * benchmarks/siege: Update version 3.0.9=>3.1.0bofh2015-06-045-13/+38 * Fix build after lang/luajit upgrade to latest version.osa2015-06-03