aboutsummaryrefslogtreecommitdiffstats
path: root/games/pioneers/Makefile
diff options
context:
space:
mode:
authorstefan <stefan@FreeBSD.org>2006-05-13 03:29:50 +0800
committerstefan <stefan@FreeBSD.org>2006-05-13 03:29:50 +0800
commitd3ab2592654781d3a743b8977aa254c9f10fcb28 (patch)
treed76173f6fd513ac2022b08e821a6565e783cbf25 /games/pioneers/Makefile
parent866d20a33b1e8ccf640de8f69bc9e1aef2e58a54 (diff)
downloadfreebsd-ports-gnome-d3ab2592654781d3a743b8977aa254c9f10fcb28.tar.gz
freebsd-ports-gnome-d3ab2592654781d3a743b8977aa254c9f10fcb28.tar.zst
freebsd-ports-gnome-d3ab2592654781d3a743b8977aa254c9f10fcb28.zip
Statically depend on libgnome again as it's easier to test this way and includes
the online help, too. Approved by: arved (mentor)
Diffstat (limited to 'games/pioneers/Makefile')
-rw-r--r--games/pioneers/Makefile16
1 files changed, 4 insertions, 12 deletions
diff --git a/games/pioneers/Makefile b/games/pioneers/Makefile
index beacc24c34de..db2958a44062 100644
--- a/games/pioneers/Makefile
+++ b/games/pioneers/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pioneers
PORTVERSION= 0.9.61
+PORTREVISION= 1
CATEGORIES= games gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= pio
@@ -17,7 +18,8 @@ COMMENT= An Internet playable version of the Settlers of Catan for GNOME/GTK+
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GETTEXT= yes
-USE_GNOME= gnomehack gnomeprefix gtk20
+USE_GNOME= gnomehack gnomeprefix gtk20 libgnome
+INSTALLS_OMF= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
@@ -25,14 +27,4 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN6= pioneers.6 pioneers-server-gtk.6 pioneers-server-console.6 \
pioneersai.6 pioneers-meta-server.6
-.include <bsd.port.pre.mk>
-
-.if exists(${X11BASE}/bin/scrollkeeper-config)
-USE_GNOME+= libgnome
-INSTALLS_OMF= yes
-PLIST_SUB+= LIBGNOME=""
-.else
-PLIST_SUB+= LIBGNOME="@comment "
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>