aboutsummaryrefslogtreecommitdiffstats
path: root/games/pp/Makefile
diff options
context:
space:
mode:
authornectar <nectar@FreeBSD.org>1998-08-01 13:00:13 +0800
committernectar <nectar@FreeBSD.org>1998-08-01 13:00:13 +0800
commitc742a0e09f58f62ce283148517ae10a0388bd015 (patch)
treea8bab9f7a0e6e7063ca20a8cd5124d6682837eb5 /games/pp/Makefile
parente89fc4d6f37c9a64c5f5bee50f32f41713018e6c (diff)
downloadfreebsd-ports-gnome-c742a0e09f58f62ce283148517ae10a0388bd015.tar.gz
freebsd-ports-gnome-c742a0e09f58f62ce283148517ae10a0388bd015.tar.zst
freebsd-ports-gnome-c742a0e09f58f62ce283148517ae10a0388bd015.zip
Prometeus Project - real time strategy game for X Window System.
PR: ports/7143 Submitted by: Andrey Zakhvatov <andy@icc.surw.chel.su>
Diffstat (limited to 'games/pp/Makefile')
-rw-r--r--games/pp/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/games/pp/Makefile b/games/pp/Makefile
new file mode 100644
index 000000000000..0494ae100033
--- /dev/null
+++ b/games/pp/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: pp
+# Version required: 0.01
+# Date created: 21 May 1998
+# Whom: Andrey Zakhvatov
+#
+# $Id$
+#
+
+DISTNAME= pp-0.01
+CATEGORIES= games
+MASTER_SITES= ftp://www.mps.de/pub/unix/ \
+ http://www.nectar.com/distfiles/
+DISTFILES= ppinst-0.01.tar.gz ppsrc-0.01.tar.gz
+
+MAINTAINER= andy@icc.surw.chel.su
+
+LIB_DEPENDS= qt\\.1\\.:${PORTSDIR}/x11/qt
+BUILD_DEPENDS= moc:${PORTSDIR}/x11/qt
+
+USE_X11= yes
+WRKSRC= ${WRKDIR}/ppsrc
+
+pre-build:
+ @ cd ${WRKSRC}; make depend
+
+do-install:
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/pp ${PREFIX}/bin/pp.bin
+ @ ${SED} 's#%%PREFIX%%#${PREFIX}#g' ${FILESDIR}/pp.sh > ${WRKDIR}/pp.sh
+ @ ${INSTALL_SCRIPT} ${WRKDIR}/pp.sh ${PREFIX}/bin/pp
+ @ ${MKDIR} ${PREFIX}/share/pp
+ @ ${INSTALL_DATA} ${WRKDIR}/ppinst/autosave.sav ${PREFIX}/share/pp
+ @ ${MKDIR} ${PREFIX}/share/pp/pic
+ @ ${INSTALL_DATA} ${WRKDIR}/ppinst/*.gif ${PREFIX}/share/pp/pic
+ @ ${MKDIR} ${PREFIX}/share/pp/level
+ @ ${INSTALL_DATA} ${WRKDIR}/ppinst/*.map1 ${PREFIX}/share/pp/level
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${PREFIX}/share/doc/pp
+.for file in INSTALL LICENSE RULES WARRANTY free-license.html
+ @ ${INSTALL_DATA} ${WRKDIR}/ppinst/${file} ${PREFIX}/share/doc/pp
+.endfor
+.endif
+
+.include <bsd.port.mk>