aboutsummaryrefslogtreecommitdiffstats
path: root/games/ppracer/Makefile
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2007-06-15 21:19:03 +0800
committerdanfe <danfe@FreeBSD.org>2007-06-15 21:19:03 +0800
commitd232872a15ded96d9928fcc06b19a03655169590 (patch)
treee22019fb39c5208e3d89c4637321e4bcc1c5a8f0 /games/ppracer/Makefile
parent56a247b739769f5ad350948a34d30f4de1154682 (diff)
downloadfreebsd-ports-gnome-d232872a15ded96d9928fcc06b19a03655169590.tar.gz
freebsd-ports-gnome-d232872a15ded96d9928fcc06b19a03655169590.tar.zst
freebsd-ports-gnome-d232872a15ded96d9928fcc06b19a03655169590.zip
- Fix the build with latest GCC [1]
- Improve on COMMENT and port description - Utilize USE_DOS2UNIX - Clean up Makefile Reported by: pointyhat [1]
Diffstat (limited to 'games/ppracer/Makefile')
-rw-r--r--games/ppracer/Makefile16
1 files changed, 6 insertions, 10 deletions
diff --git a/games/ppracer/Makefile b/games/ppracer/Makefile
index e95021891d12..760def119db7 100644
--- a/games/ppracer/Makefile
+++ b/games/ppracer/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: ppracer
+# New ports collection makefile for: PlanetPenguin Racer
# Date created: 28 May, 2005
# Whom: Adam Weinberger <adamw@FreeBSD.org>
#
@@ -13,25 +13,21 @@ MASTER_SITES= ${MASTER_SITE_BERLIOS}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
-COMMENT= 3D Downhill racing game... kindof like TuxRacer Improved
+COMMENT= 3D downhill racing game... kind of like TuxRacer Improved
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
USE_BZIP2= yes
USE_SDL= mixer sdl
USE_GL= yes
-
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
-
-.include <bsd.port.pre.mk>
+USE_DOS2UNIX= yes
+DOS2UNIX_REGEX= .*\.(c|cpp|h)
post-patch:
@${REINPLACE_CMD} -e 's,/usr/X11R6,${X11BASE},g' ${WRKSRC}/configure
- @${ECHO_MSG} "===> Converting DOS text files to UNIX text files"
- @${FIND} ${WRKSRC} -name "*.cpp" -or -name "*.c" -or -name "*.h" \
- -type f -print0 | \
- ${XARGS} -0 ${REINPLACE_CMD} -i '' -e 's/ $$//'
+ @${REINPLACE_CMD} -e 's,RacingMode::,,' ${WRKSRC}/src/racingmode.h
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>