aboutsummaryrefslogtreecommitdiffstats
path: root/games/pvpgn/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-09-04 20:18:18 +0800
committerpav <pav@FreeBSD.org>2005-09-04 20:18:18 +0800
commita1938fb1bdcfaca312313dfdf359a8b03ad8c845 (patch)
tree7229e523d62a43d0f2fa7d04818b19d1911a63a5 /games/pvpgn/Makefile
parent6563382b3f92b8f5aed5e2dd1df4c4a7515175af (diff)
downloadfreebsd-ports-gnome-a1938fb1bdcfaca312313dfdf359a8b03ad8c845.tar.gz
freebsd-ports-gnome-a1938fb1bdcfaca312313dfdf359a8b03ad8c845.tar.zst
freebsd-ports-gnome-a1938fb1bdcfaca312313dfdf359a8b03ad8c845.zip
- Update to 1.7.8
- Provide option to disable Diablo II server PR: ports/85584 Submitted by: Max E. Kuznecov <mek@mek.uz.ua> (maintainer)
Diffstat (limited to 'games/pvpgn/Makefile')
-rw-r--r--games/pvpgn/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/games/pvpgn/Makefile b/games/pvpgn/Makefile
index a2bd4a015039..18cba516c91e 100644
--- a/games/pvpgn/Makefile
+++ b/games/pvpgn/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pvpgn
-PORTVERSION= 1.7.7
+PORTVERSION= 1.7.8
CATEGORIES= games
MASTER_SITES= http://download.berlios.de/pvpgn/
DISTFILES= ${EXTRACT_ONLY} pvpgn-support-1.0.tar.gz
@@ -43,7 +43,8 @@ MAN5= bnetd.conf.5 bntext.5
OPTIONS= MYSQL "Include MySQL user accounts support" off \
PGSQL "Include PostgreSQL user accounts support" off \
- SQLITE3 "Include SQLite3 user accounts support" off
+ SQLITE3 "Include SQLite3 user accounts support" off \
+ D2 "Enable Diablo II server (D2CS/D2DBS)" on
.include <bsd.port.pre.mk>
@@ -62,6 +63,13 @@ CONFIGURE_ARGS+=--with-sqlite3
LIB_DEPENDS+= sqlite3.8:${PORTSDIR}/databases/sqlite3
.endif
+.if defined(WITHOUT_D2)
+CONFIGURE_ARGS+= --disable-d2cs --disable-d2dbs
+PLIST_SUB+= WITH_D2="@comment "
+.else
+PLIST_SUB+= WITH_D2=""
+.endif
+
## support files
SUPPORT_SUFFX= .tar.gz