aboutsummaryrefslogtreecommitdiffstats
path: root/games/pyfa
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-11-30 23:50:30 +0800
committermat <mat@FreeBSD.org>2017-11-30 23:50:30 +0800
commit32512cab3e8dd90b7cd0525bb5dc98007db431e2 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /games/pyfa
parentb4ddc365e88ebdb48627086b02365b74119cf189 (diff)
downloadfreebsd-ports-gnome-32512cab3e8dd90b7cd0525bb5dc98007db431e2.tar.gz
freebsd-ports-gnome-32512cab3e8dd90b7cd0525bb5dc98007db431e2.tar.zst
freebsd-ports-gnome-32512cab3e8dd90b7cd0525bb5dc98007db431e2.zip
Convert Python ports to FLAVORS.
Ports using USE_PYTHON=distutils are now flavored. They will automatically get flavors (py27, py34, py35, py36) depending on what versions they support. There is also a USE_PYTHON=flavors for ports that do not use distutils but need FLAVORS to be set. A USE_PYTHON=noflavors can be set if using distutils but flavors are not wanted. A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been added to cope with Python ports that did not have the Python PKGNAMEPREFIX but are flavored. USES=python now also exports a PY_FLAVOR variable that contains the current python flavor. It can be used in dependency lines when the port itself is not python flavored. For example, deskutils/calibre. By default, all the flavors are generated. To only generate flavors for the versions in PYTHON2_DEFAULT and PYTHON3_DEFAULT, define BUILD_DEFAULT_PYTHON_FLAVORS in your make.conf. In all the ports with Python dependencies, the *_DEPENDS entries MUST end with the flavor so that the framework knows which to build/use. This is done by appending '@${PY_FLAVOR}' after the origin (or @${FLAVOR} if in a Python module with Python flavors, as the content will be the same). For example: RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} PR: 223071 Reviewed by: portmgr, python Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12464
Diffstat (limited to 'games/pyfa')
-rw-r--r--games/pyfa/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/games/pyfa/Makefile b/games/pyfa/Makefile
index a59375a9f1d1..8870dcfd6137 100644
--- a/games/pyfa/Makefile
+++ b/games/pyfa/Makefile
@@ -13,9 +13,9 @@ COMMENT= Fitting tool for EVE Online
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dateutil>0:devel/py-dateutil \
- ${PYTHON_PKGNAMEPREFIX}sqlalchemy10>=0.6:databases/py-sqlalchemy10 \
- ${PYTHON_PKGNAMEPREFIX}requests>=2.3.0:www/py-requests
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dateutil>0:devel/py-dateutil@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sqlalchemy10>=0.6:databases/py-sqlalchemy10@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.3.0:www/py-requests@${PY_FLAVOR}
USE_GITHUB= yes
GH_ACCOUNT= pyfa-org
@@ -34,9 +34,9 @@ WX_COMPS= wx:run python:run
OPTIONS_DEFINE= DPSGRAPHING
DPSGRAPHING_DESC= DPS graphing (requires NumPy and matplotlib)
-DPSGRAPHING_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}matplotlib>=1.5.0:math/py-matplotlib \
- ${PYTHON_PKGNAMEPREFIX}numpy>0:math/py-numpy \
- ${PYTHON_PKGNAMEPREFIX}more-itertools>0:devel/py-more-itertools
+DPSGRAPHING_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}matplotlib>=1.5.0:math/py-matplotlib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}numpy>0:math/py-numpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}more-itertools>0:devel/py-more-itertools@${PY_FLAVOR}
do-build:
@${PYTHON_CMD} -m compileall ${WRKSRC}