aboutsummaryrefslogtreecommitdiffstats
path: root/games/pysol/Makefile
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>2005-03-09 21:31:08 +0800
committertg <tg@FreeBSD.org>2005-03-09 21:31:08 +0800
commite71f50fc7467b6b20b3a15392f03e14cf917e85c (patch)
tree01668003fbcbc6c9ad6d55a999d91844e7658fbf /games/pysol/Makefile
parent944e3fbf61d04b23a8473ba5bc933da9b71eecb5 (diff)
downloadfreebsd-ports-gnome-e71f50fc7467b6b20b3a15392f03e14cf917e85c.tar.gz
freebsd-ports-gnome-e71f50fc7467b6b20b3a15392f03e14cf917e85c.tar.zst
freebsd-ports-gnome-e71f50fc7467b6b20b3a15392f03e14cf917e85c.zip
Use sources, not the pre-compiled package. PySol will now run with
Python-2.4, too.
Diffstat (limited to 'games/pysol/Makefile')
-rw-r--r--games/pysol/Makefile36
1 files changed, 23 insertions, 13 deletions
diff --git a/games/pysol/Makefile b/games/pysol/Makefile
index 37212b12b122..f3640bdde711 100644
--- a/games/pysol/Makefile
+++ b/games/pysol/Makefile
@@ -8,31 +8,41 @@
PORTNAME= pysol
PORTVERSION= 4.82
CATEGORIES= games
-MASTER_SITES= http://www.pysol.org/download/pysol/
+MASTER_SITES= http://www.pysol.org/download/pysol/:source \
+ ${MASTER_SITE_LOCAL:S/$/:support/}
+MASTER_SITE_SUBDIR= tg/:support
+DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:support \
+ ${PORTNAME}-${PORTVERSION}-src${EXTRACT_SUFX}:source
MAINTAINER= tg@FreeBSD.org
COMMENT= Solitaire game, written in Python
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
-
-BROKEN= Incomplete pkg-plist
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pysolsoundserver.so:${PORTSDIR}/audio/pysol-sound-server \
+ ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
USE_BZIP2= yes
-USE_PYTHON= -2.3
-
+USE_PYTHON= yes
+USE_REINPLACE= yes
NO_BUILD= yes
MAN6= pysol.6
-do-install:
- ${SED} -e "s|@pkgdatadir@|${PREFIX}/share/pysol|" \
+post-patch:
+ @${RM} ${WRKSRC}/src/tk/soundoptionsdialog.py.orig
+ @${REINPLACE_CMD} -e "s|@pkgdatadir@|${DATADIR}|" \
-e "s|@prefix@|${PREFIX}|" \
- -e "s|@PYTHON@|${PYTHON_CMD}|" \
- < ${WRKSRC}/pysol > ${WRKDIR}/pysol
- ${INSTALL_SCRIPT} ${WRKDIR}/pysol ${PREFIX}/bin/pysol
+ -e "s|@PYTHON@|${PYTHON_CMD}|" ${WRKSRC}/pysol
+ @${REINPLACE_CMD} -e "s|pysol_\$$PYVER.pyc|src/pysol.py|" \
+ ${WRKSRC}/pysol
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/pysol ${PREFIX}/bin/pysol
${INSTALL_DATA} ${WRKSRC}/pysol.6 ${PREFIX}/man/man6
- @${MKDIR} ${PREFIX}/share/pysol
+ @${MKDIR} ${DATADIR}
(cd ${WRKSRC}/data; tar -cf - .) | \
- (cd ${PREFIX}/share/pysol; tar --unlink -xf -)
+ (cd ${DATADIR}; tar --unlink -xf -)
+ (cd ${WRKSRC}; tar -cf - src) | \
+ (cd ${DATADIR}; tar --unlink -xf -)
+ @cd ${DATADIR} && ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py src
.include <bsd.port.mk>