aboutsummaryrefslogtreecommitdiffstats
path: root/games/pysolfc
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2014-10-08 23:38:53 +0800
committerwg <wg@FreeBSD.org>2014-10-08 23:38:53 +0800
commit636428a60e011ad646f323a91a6ca2ef3c48b530 (patch)
tree180d6d4f14602f04a60b3f69b2b99f73eafbaa5e /games/pysolfc
parent6c647eb88220c716d33ce74f25e984c3ef939a9c (diff)
downloadfreebsd-ports-gnome-636428a60e011ad646f323a91a6ca2ef3c48b530.tar.gz
freebsd-ports-gnome-636428a60e011ad646f323a91a6ca2ef3c48b530.tar.zst
freebsd-ports-gnome-636428a60e011ad646f323a91a6ca2ef3c48b530.zip
games/pysolfc: switch from py-imaging to py-pillow
- USES python With hat: python Approved by: portmgr (bdrewery, implicit)
Diffstat (limited to 'games/pysolfc')
-rw-r--r--games/pysolfc/Makefile4
-rw-r--r--games/pysolfc/files/patch-pysollib__mfxutil.py29
2 files changed, 31 insertions, 2 deletions
diff --git a/games/pysolfc/Makefile b/games/pysolfc/Makefile
index fae7543c8aa3..2c8dfc6857cb 100644
--- a/games/pysolfc/Makefile
+++ b/games/pysolfc/Makefile
@@ -2,7 +2,7 @@
PORTNAME= pysolfc
PORTVERSION= 2.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= games python
MASTER_SITES= SF/${PORTNAME}/PySolFC/PySolFC-${PORTVERSION} \
SF/${PORTNAME}/PySolFC-Cardsets/PySolFC-Cardsets-${PORTVERSION}:cardsets
@@ -15,7 +15,7 @@ COMMENT= Solitaire game, written in Python and the successor of PySol
LICENSE= GPLv3
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkinter \
- ${PYTHON_SITELIBDIR}/PIL/__init__.py:${PORTSDIR}/graphics/py-imaging
+ ${PYTHON_PKGNAMEPREFIX}pillow>0:${PORTSDIR}/graphics/py-pillow
USES= python tar:bzip2
USE_PYTHON= autoplist distutils
diff --git a/games/pysolfc/files/patch-pysollib__mfxutil.py b/games/pysolfc/files/patch-pysollib__mfxutil.py
new file mode 100644
index 000000000000..cb7581beb435
--- /dev/null
+++ b/games/pysolfc/files/patch-pysollib__mfxutil.py
@@ -0,0 +1,29 @@
+--- pysollib/mfxutil.py.orig 2014-10-08 15:37:56 UTC
++++ pysollib/mfxutil.py
+@@ -41,18 +41,18 @@
+ Image = ImageTk = ImageOps = None
+ if TOOLKIT == 'tk':
+ try: # PIL
+- import Image
+- import ImageTk
+- import ImageOps
++ from PIL import Image
++ from PIL import ImageTk
++ from PIL import ImageOps
+ except ImportError:
+ Image = None
+ else:
+ # for py2exe
+- import GifImagePlugin
+- import PngImagePlugin
+- import JpegImagePlugin
+- import BmpImagePlugin
+- import PpmImagePlugin
++ from PIL import GifImagePlugin
++ from PIL import PngImagePlugin
++ from PIL import JpegImagePlugin
++ from PIL import BmpImagePlugin
++ from PIL import PpmImagePlugin
+ Image._initialized = 2
+
+