aboutsummaryrefslogtreecommitdiffstats
path: root/games/q2pro
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2007-01-21 00:08:29 +0800
committeralepulver <alepulver@FreeBSD.org>2007-01-21 00:08:29 +0800
commit3dd3f4fc83f964754f5a4f04a07ce9f6d36758f8 (patch)
treef32aef21784007f6f754ed44468d7c665b7971fd /games/q2pro
parentb593f4a89428da7c7d26c166d1957c4a10c906ec (diff)
downloadfreebsd-ports-gnome-3dd3f4fc83f964754f5a4f04a07ce9f6d36758f8.tar.gz
freebsd-ports-gnome-3dd3f4fc83f964754f5a4f04a07ce9f6d36758f8.tar.zst
freebsd-ports-gnome-3dd3f4fc83f964754f5a4f04a07ce9f6d36758f8.zip
- Disable x86 assembly code on non-i386.
- Add X86_ASM option. Reported by: pointyhat
Diffstat (limited to 'games/q2pro')
-rw-r--r--games/q2pro/Makefile7
-rw-r--r--games/q2pro/files/patch-build__client.mk12
2 files changed, 15 insertions, 4 deletions
diff --git a/games/q2pro/Makefile b/games/q2pro/Makefile
index c7f3d3126cfa..aae05a0432b8 100644
--- a/games/q2pro/Makefile
+++ b/games/q2pro/Makefile
@@ -25,7 +25,8 @@ OPTIONS= CLIENT "Build client" on \
GAME "Build a main game .so file" off \
GL "Build OpenGL render" on \
SOFT "Build software render" on \
- UI "Build user interface (for CLIENT menus)" on
+ UI "Build user interface (for CLIENT menus)" on \
+ X86_ASM "Enable use of optimized x86 assembly code" on
MAKE_ENV= LIBDIR="${LIBDIR}"
PLIST_SUB= LIBDIR="${LIBDIR:S/${PREFIX}\///}"
@@ -87,6 +88,10 @@ PLIST_SUB+= UI=""
PLIST_SUB+= UI="@comment "
.endif
+.if !defined(WITHOUT_X86_ASM) && ${ARCH} == "i386"
+MAKE_ENV+= USE_X86_ASM=yes
+.endif
+
do-install:
${MKDIR} ${LIBDIR}/baseq2
.if !defined(WITHOUT_CLIENT)
diff --git a/games/q2pro/files/patch-build__client.mk b/games/q2pro/files/patch-build__client.mk
index 38567ff80f91..fe098a95a368 100644
--- a/games/q2pro/files/patch-build__client.mk
+++ b/games/q2pro/files/patch-build__client.mk
@@ -1,10 +1,16 @@
---- ./build/client.mk.orig Mon Dec 25 17:07:02 2006
-+++ ./build/client.mk Mon Dec 25 17:07:02 2006
-@@ -42,7 +42,7 @@
+--- build/client.mk.orig Sat Jan 20 12:40:15 2007
++++ build/client.mk Sat Jan 20 12:40:20 2007
+@@ -41,8 +41,13 @@
+ # linux
#
SRCFILES_LINUX = sys_unix.c snd_linux.c cd_linux.c vid_sdl.c in_linux.c
++ifdef USE_X86_ASM
ASMFILES_LINUX = snd_mixa.s
-LDFLAGS_LINUX += -lz -ldl -lSDL
++else
++SRCFILES_LINUX += snd_mix.c
++CFLAGS_LINUX += -DC_ONLY
++endif
+LDFLAGS_LINUX += -lz `sdl-config --libs`
include ../../post.mk