aboutsummaryrefslogtreecommitdiffstats
path: root/games/qccx/Makefile
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2005-01-18 20:41:46 +0800
committerdanfe <danfe@FreeBSD.org>2005-01-18 20:41:46 +0800
commitd10a19be06d828ffe78fa20c8311b292650e8798 (patch)
tree07c2f0b78945c035f55909d3dde2a3c9b3baf463 /games/qccx/Makefile
parent73d6d9164e2a9d9928de193d57a80266931b1cb0 (diff)
downloadfreebsd-ports-gnome-d10a19be06d828ffe78fa20c8311b292650e8798.tar.gz
freebsd-ports-gnome-d10a19be06d828ffe78fa20c8311b292650e8798.tar.zst
freebsd-ports-gnome-d10a19be06d828ffe78fa20c8311b292650e8798.zip
Add qccx 1.0.0, a very fast optimizing QuakeC compiler.
Diffstat (limited to 'games/qccx/Makefile')
-rw-r--r--games/qccx/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/games/qccx/Makefile b/games/qccx/Makefile
new file mode 100644
index 000000000000..900dc8a0f766
--- /dev/null
+++ b/games/qccx/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: QCCX
+# Date created: 18 Jan 2005
+# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qccx
+PORTVERSION= 1.0.0
+CATEGORIES= games devel
+MASTER_SITES= http://www.planetquake.com/qccx/ \
+ http://freebsd.nsu.ru/distfiles/
+DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= A very fast optimizing QuakeC compiler
+
+USE_ZIP= yes
+USE_REINPLACE= yes
+
+MAKEFILE= ${FILESDIR}/Makefile
+WRKSRC= ${WRKDIR}
+
+post-extract:
+ @${FIND} ${WRKDIR} -type f -name "*.[^deo]*" -print0 | \
+ ${XARGS} -0 ${REINPLACE_CMD} -e 's/[[:cntrl:]]*$$//'
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.qc ${WRKSRC}/progs.src ${DATADIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/[^g]*.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>