aboutsummaryrefslogtreecommitdiffstats
path: root/games/qgo/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2003-11-05 23:58:25 +0800
committerkrion <krion@FreeBSD.org>2003-11-05 23:58:25 +0800
commita6078f40ef5d5d1e457da689be16b223d219c88f (patch)
tree53f4152e47f5b8eaab3a96428907e9a0763eabcb /games/qgo/Makefile
parenta6897541bffc3b3a7c759cfed9d5961180a2a2e4 (diff)
downloadfreebsd-ports-gnome-a6078f40ef5d5d1e457da689be16b223d219c88f.tar.gz
freebsd-ports-gnome-a6078f40ef5d5d1e457da689be16b223d219c88f.tar.zst
freebsd-ports-gnome-a6078f40ef5d5d1e457da689be16b223d219c88f.zip
- Update to version 0.1.1
PR: 58962 Submitted by: Ports Fury
Diffstat (limited to 'games/qgo/Makefile')
-rw-r--r--games/qgo/Makefile20
1 files changed, 11 insertions, 9 deletions
diff --git a/games/qgo/Makefile b/games/qgo/Makefile
index 7f0596d0c1df..3f8fe6436c89 100644
--- a/games/qgo/Makefile
+++ b/games/qgo/Makefile
@@ -7,24 +7,26 @@
#
PORTNAME= qgo
-PORTVERSION= 0.0.14
+PORTVERSION= 0.1.1
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@freebsd.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= A Go board and SGF editor written with the Qt library
-USE_REINPLACE= yes
USE_QT_VER= 3
-GNU_CONFIGURE= yes
-QTCPPFLAGS+= -DDONT_USE_GETOPT
-CONFIGURE_ENV= QTDIR=${X11BASE}
+USE_REINPLACE= yes
USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= QTDIR=${QT_PREFIX}
+MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
+ AUTOHEADER="${TRUE}"
post-patch:
- ${REINPLACE_CMD} -e "s,libqt.so,libqt-mt.so,; \
- s,-O2, ${CFLAGS} ${PTHREAD_CFLAGS}," ${WRKSRC}/configure
- ${REINPLACE_CMD} -e "s,-lqt,-lqt-mt ${PTHREAD_LIBS}," ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -e 's|-pedantic||g ; \
+ s|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|/usr/share|$${prefix}/share|g'
.include <bsd.port.mk>