aboutsummaryrefslogtreecommitdiffstats
path: root/games/qgo
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2006-04-16 03:39:37 +0800
committerarved <arved@FreeBSD.org>2006-04-16 03:39:37 +0800
commitf107c73104df0028fbb83553c5a44317f8c910e1 (patch)
treef7fc344b81649ed604485762c1eafcd1ae20a01e /games/qgo
parent86b284d12878cdffb3e938177abdded3506435ae (diff)
downloadfreebsd-ports-gnome-f107c73104df0028fbb83553c5a44317f8c910e1.tar.gz
freebsd-ports-gnome-f107c73104df0028fbb83553c5a44317f8c910e1.tar.zst
freebsd-ports-gnome-f107c73104df0028fbb83553c5a44317f8c910e1.zip
Update to 1.5.1
PR: 95817 Submitted by: KATO Tsuguru
Diffstat (limited to 'games/qgo')
-rw-r--r--games/qgo/Makefile3
-rw-r--r--games/qgo/distinfo6
-rw-r--r--games/qgo/files/patch-src-mainwidget_gui.ui10
-rw-r--r--games/qgo/files/patch-src__mainwin.cpp31
4 files changed, 20 insertions, 30 deletions
diff --git a/games/qgo/Makefile b/games/qgo/Makefile
index 713ae56ce427..5099ecbc2fae 100644
--- a/games/qgo/Makefile
+++ b/games/qgo/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= qgo
-PORTVERSION= 1.0.4.2
+PORTVERSION= 1.5.1
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -19,7 +19,6 @@ COMMENT= A Go board and SGF editor written with the Qt library
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
USE_QT_VER= 3
-USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/games/qgo/distinfo b/games/qgo/distinfo
index 41e4e99e291b..49e57edbbfc2 100644
--- a/games/qgo/distinfo
+++ b/games/qgo/distinfo
@@ -1,3 +1,3 @@
-MD5 (qgo-1.0.4-r2.tar.gz) = 49da743ca769d8d18fc3a4b7a6aa0bf8
-SHA256 (qgo-1.0.4-r2.tar.gz) = b57c07b8270b0da8ea15a146b637e1a9c2c550f306d80ed700ead97ef76244da
-SIZE (qgo-1.0.4-r2.tar.gz) = 2316848
+MD5 (qgo-1.5-r1.tar.gz) = 1051f540aa4e1a83a29ec6be3896c2c2
+SHA256 (qgo-1.5-r1.tar.gz) = ee3d18f00e373f1b547eff68866b557f25b49cc14d83350b429302b0460a8a74
+SIZE (qgo-1.5-r1.tar.gz) = 2325097
diff --git a/games/qgo/files/patch-src-mainwidget_gui.ui b/games/qgo/files/patch-src-mainwidget_gui.ui
deleted file mode 100644
index 946b0258f849..000000000000
--- a/games/qgo/files/patch-src-mainwidget_gui.ui
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/mainwidget_gui.ui.orig Tue Sep 27 20:54:48 2005
-+++ src/mainwidget_gui.ui Tue Sep 27 20:55:06 2005
-@@ -2447,7 +2447,6 @@
- <layoutdefaults spacing="6" margin="11"/>
- <includehints>
- <includehint>board.h</includehint>
-- <includehint>normaltools.h</includehint>
- <includehint>gametree.h</includehint>
- </includehints>
- </UI>
diff --git a/games/qgo/files/patch-src__mainwin.cpp b/games/qgo/files/patch-src__mainwin.cpp
index d8ce8705035e..b08df9f2238f 100644
--- a/games/qgo/files/patch-src__mainwin.cpp
+++ b/games/qgo/files/patch-src__mainwin.cpp
@@ -1,15 +1,16 @@
---- src/mainwin.cpp.orig Thu Nov 24 08:38:33 2005
-+++ src/mainwin.cpp Wed Jan 18 03:09:52 2006
-@@ -1604,10 +1604,10 @@
- //set the params of "who command"
- if ((whoBox1->currentItem() >1) || (whoBox2->currentItem() >1))
- {
-- wparam.append(whoBox1->currentItem()==1 ? "9p" : whoBox1->currentText());
-+ wparam.append(whoBox1->currentItem()==1 ? QString("9p") : whoBox1->currentText());
- if ((whoBox1->currentItem()) && (whoBox2->currentItem()))
- wparam.append("-");
-- wparam.append(whoBox2->currentItem()==1 ? "9p" : whoBox2->currentText());
-+ wparam.append(whoBox2->currentItem()==1 ? QString("9p") : whoBox2->currentText());
- }
- else if ((whoBox1->currentItem()) || (whoBox2->currentItem()))
- wparam.append("1p-9p");
+--- src/mainwin.cpp.orig Mon Mar 27 06:37:41 2006
++++ src/mainwin.cpp Wed Apr 12 13:36:58 2006
+@@ -1589,11 +1589,11 @@
+ //set the params of "who command"
+ if ((whoBox1->currentItem() >1) || (whoBox2->currentItem() >1))
+ {
+- wparam.append(whoBox1->currentItem()==1 ? "9p" : whoBox1->currentText());
++ wparam.append(whoBox1->currentItem()==1 ? QString("9p") : whoBox1->currentText());
+ if ((whoBox1->currentItem()) && (whoBox2->currentItem()))
+ wparam.append("-");
+
+- wparam.append(whoBox2->currentItem()==1 ? "9p" : whoBox2->currentText());
++ wparam.append(whoBox2->currentItem()==1 ? QString("9p") : whoBox2->currentText());
+ }
+ else if ((whoBox1->currentItem()) || (whoBox2->currentItem()))
+ wparam.append("1p-9p");