aboutsummaryrefslogtreecommitdiffstats
path: root/games/qmars/Makefile
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2012-11-02 19:08:29 +0800
committerpawel <pawel@FreeBSD.org>2012-11-02 19:08:29 +0800
commitcbebcb7d52128d413880ff9cea3f5bd0dc0f2ba6 (patch)
tree41ac1e69fe5dbf0fc50fe4435d6ac5db44353389 /games/qmars/Makefile
parent5e4105025d431ea186a6e405b4046947469dbc7c (diff)
downloadfreebsd-ports-gnome-cbebcb7d52128d413880ff9cea3f5bd0dc0f2ba6.tar.gz
freebsd-ports-gnome-cbebcb7d52128d413880ff9cea3f5bd0dc0f2ba6.tar.zst
freebsd-ports-gnome-cbebcb7d52128d413880ff9cea3f5bd0dc0f2ba6.zip
- Update MASTER_SITES
- Add LICENSE - Fix CXXFLAGS PR: ports/172238 Submitted by: KATO Tsuguru <tkato432@yahoo.com> Feature safe: yes
Diffstat (limited to 'games/qmars/Makefile')
-rw-r--r--games/qmars/Makefile32
1 files changed, 17 insertions, 15 deletions
diff --git a/games/qmars/Makefile b/games/qmars/Makefile
index 1edfb542a277..ed488e7fcc24 100644
--- a/games/qmars/Makefile
+++ b/games/qmars/Makefile
@@ -1,38 +1,40 @@
-# New ports collection makefile for: qmars
-# Date created: 2008-01-15
-# Whom: alepulver
-#
+# Created by: alepulver
# $FreeBSD$
-#
PORTNAME= qmars
PORTVERSION= 1.1
+PORTREVISION= 1
CATEGORIES= games
-MASTER_SITES= http://corewar.co.uk/ankerl/
+MASTER_SITES= http://martin.ankerl.com/files/
DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-COMMENT= Quicker Mars is heavily optimized to be as fast as possible
+COMMENT= Quicker Mars - heavily optimized mars simulator
+
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/COPYRIGHT
BUILD_DEPENDS= makedepend:${PORTSDIR}/devel/makedepend
-USE_BZIP2= yes
-REINPLACE_ARGS= -i ""
WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_BZIP2= yes
MAKE_JOBS_UNSAFE= yes
post-patch:
- @${REINPLACE_CMD} -e 's|g++|${CXX}|; s|CCFLAGS =|& ${CXXFLAGS}|' \
- ${WRKSRC}/${MAKEFILE}
+ @${REINPLACE_CMD} -e 's|g++|$${CXX}| ; \
+ s|-O3|$${CXXFLAGS}|' ${WRKSRC}/${MAKEFILE}
@${REINPLACE_CMD} -e 's|\./||' ${WRKSRC}/bench.*
@${REINPLACE_CMD} -e 's|pmars|&-server|' ${WRKSRC}/bench.pmars
@${REINPLACE_CMD} -e 's|Warrior::||' ${WRKSRC}/warrior.hpp
@${REINPLACE_CMD} -e 's|Parser::||' ${WRKSRC}/parser.hpp
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${MKDIR} ${DATADIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/bench.* ${DATADIR}
- ${CP} -r ${WRKSRC}/warriors ${DATADIR}
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} ${PORTNAME} ${PREFIX}/bin)
+ @${MKDIR} ${DATADIR}
+.for i in bench.exhaust bench.exmars bench.pmars bench.qmars
+ (cd ${WRKSRC} && ${INSTALL_SCRIPT} ${i} ${DATADIR})
+.endfor
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} warriors ${DATADIR})
.include <bsd.port.mk>