aboutsummaryrefslogtreecommitdiffstats
path: root/games/qonk
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2006-04-19 02:01:39 +0800
committeralepulver <alepulver@FreeBSD.org>2006-04-19 02:01:39 +0800
commit38ccaee2f4358b3b82b64e95af4c78f536c3e752 (patch)
tree3b3b02535fb151782700ec37554601bee258cda2 /games/qonk
parent1f203b0f85890c1dcadd0b3a6b76dac9eb5ea6ba (diff)
downloadfreebsd-ports-gnome-38ccaee2f4358b3b82b64e95af4c78f536c3e752.tar.gz
freebsd-ports-gnome-38ccaee2f4358b3b82b64e95af4c78f536c3e752.tar.zst
freebsd-ports-gnome-38ccaee2f4358b3b82b64e95af4c78f536c3e752.zip
- Update to version 0.0.2beta1.
- Remove USE_REINPLACE. Approved by: garga (mentor)
Diffstat (limited to 'games/qonk')
-rw-r--r--games/qonk/Makefile5
-rw-r--r--games/qonk/distinfo6
-rw-r--r--games/qonk/files/patch-SDL_gfxPrimitives.h11
3 files changed, 16 insertions, 6 deletions
diff --git a/games/qonk/Makefile b/games/qonk/Makefile
index e60df5081acc..9d861eddd175 100644
--- a/games/qonk/Makefile
+++ b/games/qonk/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= qonk
-PORTVERSION= 0.0.1
+DISTVERSION= 0.0.2beta1
CATEGORIES= games
MASTER_SITES= http://anthony.liekens.net/pub/files/
@@ -15,7 +15,6 @@ COMMENT= Small build and conquer strategy game
USE_GMAKE= yes
USE_SDL= gfx sdl ttf
-USE_REINPLACE= yes
OPTIONS= OPTIMIZED_CFLAGS "Enable compilation optimizations" on
@@ -33,7 +32,7 @@ post-patch:
${WRKSRC}/main.cpp ${WRKSRC}/messages.cpp
# Enable/disable compilation optimizations
-.if !defined(WITH_OPTIMIZED_CFLAGS)
+.if defined(WITHOUT_OPTIMIZED_CFLAGS)
@${REINPLACE_CMD} -e 's|-O3||' \
${WRKSRC}/${MAKEFILE}
.endif
diff --git a/games/qonk/distinfo b/games/qonk/distinfo
index 081e8c63eaa8..f5b09da6ad5a 100644
--- a/games/qonk/distinfo
+++ b/games/qonk/distinfo
@@ -1,3 +1,3 @@
-MD5 (qonk-0.0.1.tar.gz) = 149759ea51a6e129682d1a4fd80148e6
-SHA256 (qonk-0.0.1.tar.gz) = 942ba3af92c422e533103495ba5dbd5f23dcc821aa2a395ce9f5aba1e9514d40
-SIZE (qonk-0.0.1.tar.gz) = 53976
+MD5 (qonk-0.0.2beta1.tar.gz) = d3f445f94c11c5d2ac1c4ca4533ba412
+SHA256 (qonk-0.0.2beta1.tar.gz) = 3dd5add09f1fc4c9c3d00e125509197b13b70d586c3595f01f565a794eca8f64
+SIZE (qonk-0.0.2beta1.tar.gz) = 92832
diff --git a/games/qonk/files/patch-SDL_gfxPrimitives.h b/games/qonk/files/patch-SDL_gfxPrimitives.h
new file mode 100644
index 000000000000..71d5e4ae3b20
--- /dev/null
+++ b/games/qonk/files/patch-SDL_gfxPrimitives.h
@@ -0,0 +1,11 @@
+--- SDL_gfxPrimitives.h.orig Sat Aug 6 08:53:38 2005
++++ SDL_gfxPrimitives.h Thu Apr 13 23:20:20 2006
+@@ -14,7 +14,7 @@
+ #define M_PI 3.141592654
+ #endif
+
+-#include <SDL/SDL.h>
++#include <SDL.h>
+
+ /* Set up for C function definitions, even when using C++ */
+ #ifdef __cplusplus