aboutsummaryrefslogtreecommitdiffstats
path: root/games/quackle
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-11-24 01:42:04 +0800
committermakc <makc@FreeBSD.org>2013-11-24 01:42:04 +0800
commitf46fec2e974200d1d5ac3b335e6f22ac057e264e (patch)
tree454c89b72563e9b85650d49a357f4dea8c19dd4e /games/quackle
parent2b23d36eee758832428d10f4f18b9dffdbacb40d (diff)
downloadfreebsd-ports-gnome-f46fec2e974200d1d5ac3b335e6f22ac057e264e.tar.gz
freebsd-ports-gnome-f46fec2e974200d1d5ac3b335e6f22ac057e264e.tar.zst
freebsd-ports-gnome-f46fec2e974200d1d5ac3b335e6f22ac057e264e.zip
- Convert to USES=qmake
Approved by: portmgr (blanket approval)
Diffstat (limited to 'games/quackle')
-rw-r--r--games/quackle/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/games/quackle/Makefile b/games/quackle/Makefile
index b9d8615a1a73..098aae1dc356 100644
--- a/games/quackle/Makefile
+++ b/games/quackle/Makefile
@@ -18,9 +18,9 @@ LICENSE_COMB= dual
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
BUILD_WRKSRC= ${WRKSRC}/quacker
-USES= gmake
+USES= gmake qmake
USE_GCC= any
-USE_QT4= gui moc_build qmake_build
+USE_QT4= gui moc_build
DESKTOP_ENTRIES="Quackle" "${COMMENT}" "" "quackle" "Game;BoardGame;" "true"
@@ -35,9 +35,9 @@ post-patch:
'/QFile::exists/s|("data")|("${DATADIR}")| ; \
/setDataDirectory/s|("data")|("${DATADIR}")|' ${BUILD_WRKSRC}/settings.cpp
-do-configure:
-.for dir in . quackleio quacker
- @(cd ${WRKSRC}/${dir} && ${SETENV} ${MAKE_ENV} ${QMAKE} ${QMAKEFLAGS})
+post-configure:
+.for dir in quackleio quacker
+ @(cd ${WRKSRC}/${dir} && ${SETENV} ${QMAKE_ENV} ${QMAKE} ${QMAKE_ARGS})
.endfor
pre-build: